[ANN] Release 8.1.9

classic Classic list List threaded Threaded
30 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Re: iOS app Error ITMS-90529 submitting to app store via Application Loader

Mike Bonner via use-livecode
Hi Ralph,
Have you included an AppStore icon (1024x1024) png in the iOS standalone
settings?
Panos
-

On Feb 9, 2018 21:16, "Brian Milby via use-livecode" <
[hidden email]> wrote:

> Try with 8.1.9 - I think that is a bug that was fixed.
> On Fri, Feb 9, 2018 at 3:00 PM Ralph DiMola via use-livecode <
> [hidden email]> wrote:
>
> > Here's a new one I never received before. Using 8.1.9 rc2. I made the app
> > using the distribution profile and zipped it up as usual.
> > Xcode 9.2
> > Application Loader 3.7
> > OS X 10.12.6
> >
> > The upload to the app store starts and the I get this error during
> > "Verifying assets with the App Store."
> >
> > ERROR ITMS-90529: "Invalid package. Applications built with sdk 9.0 or
> > later
> > must be packaged as proper IPA files."
> >
> > Has the zipping procedure changes with 8.1.9 rc2? I did not get this with
> > 8.1.9 rc1.
> >
> > Thanks in advance...
> >
> > Ralph DiMola
> > IT Director
> > Evergreen Information Services
> > [hidden email]
> >
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

RE: iOS app Error ITMS-90529 submitting to app store via Application Loader

Mike Bonner via use-livecode
Panos.

Yes I did. I just tried with 8.1.9gm just to make sure... Same error. I
tried sending an .ipa with a .zip extension but same error. I included all
icons and splash screens. I received no "dimension" errors when adding or LC
build errors or warnings

Thanks

Ralph DiMola
IT Director
Evergreen Information Services
[hidden email]
Phone: 518-636-3998 Ex:11
Cell: 518-796-9332


-----Original Message-----
From: use-livecode [mailto:[hidden email]] On Behalf
Of panagiotis merakos via use-livecode
Sent: Friday, February 09, 2018 4:41 PM
To: How to use LiveCode
Cc: panagiotis merakos
Subject: Re: iOS app Error ITMS-90529 submitting to app store via
Application Loader

Hi Ralph,
Have you included an AppStore icon (1024x1024) png in the iOS standalone
settings?
Panos
-

On Feb 9, 2018 21:16, "Brian Milby via use-livecode" <
[hidden email]> wrote:

> Try with 8.1.9 - I think that is a bug that was fixed.
> On Fri, Feb 9, 2018 at 3:00 PM Ralph DiMola via use-livecode <
> [hidden email]> wrote:
>
> > Here's a new one I never received before. Using 8.1.9 rc2. I made
> > the app using the distribution profile and zipped it up as usual.
> > Xcode 9.2
> > Application Loader 3.7
> > OS X 10.12.6
> >
> > The upload to the app store starts and the I get this error during
> > "Verifying assets with the App Store."
> >
> > ERROR ITMS-90529: "Invalid package. Applications built with sdk 9.0
> > or later must be packaged as proper IPA files."
> >
> > Has the zipping procedure changes with 8.1.9 rc2? I did not get this
> > with
> > 8.1.9 rc1.
> >
> > Thanks in advance...
> >
> > Ralph DiMola
> > IT Director
> > Evergreen Information Services
> > [hidden email]
> >
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

RE: iOS app Error ITMS-90529 submitting to app store via Application Loader

Mike Bonner via use-livecode
In reply to this post by Mike Bonner via use-livecode
Brain,

 

Thanks but still no-go.

 

 

Ralph DiMola

IT Director

Evergreen Information Services

[hidden email]

Phone: 518-636-3998 Ex:11

Cell: 518-796-9332

 

From: Brian Milby [mailto:[hidden email]]
Sent: Friday, February 09, 2018 4:16 PM
To: How to use LiveCode
Cc: Ralph DiMola
Subject: Re: iOS app Error ITMS-90529 submitting to app store via Application Loader

 

Try with 8.1.9 - I think that is a bug that was fixed.

On Fri, Feb 9, 2018 at 3:00 PM Ralph DiMola via use-livecode <[hidden email]> wrote:

Here's a new one I never received before. Using 8.1.9 rc2. I made the app
using the distribution profile and zipped it up as usual.
Xcode 9.2
Application Loader 3.7
OS X 10.12.6

The upload to the app store starts and the I get this error during
"Verifying assets with the App Store."

ERROR ITMS-90529: "Invalid package. Applications built with sdk 9.0 or later
must be packaged as proper IPA files."

Has the zipping procedure changes with 8.1.9 rc2? I did not get this with
8.1.9 rc1.

Thanks in advance...

Ralph DiMola
IT Director
Evergreen Information Services
[hidden email]


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: iOS app Error ITMS-90529 submitting to app store via Application Loader

Mike Bonner via use-livecode
Hi Ralph,

The file you should upload should be called "application.ipa", not
"application.ipa.zip"

Try this:

1. In LC, create an iOS standalone as usual
2. Suppose the standalone is saved in a folder called myApp, located in
user's Desktop folder so you should see something like:

Desktop/myApp/myApp.app

3. Open a terminal and navigate to Desktop folder:
"cd ~/Desktop"

4. From the terminal, rename the "myApp" folder to "Payload"
"mv myApp Payload"

5. From the terminal, zip the "Payload" folder and rename it to
"application.ipa":
"zip -r application.ipa Payload"

6. Now use Application Loader to upload the "application.ipa" file.

These are the steps I followed when testing uploading to AppStore with LC
8.1.9 RC-2 and 8.1.9, and it worked.

Keep us posted.

Panos
--



On Fri, Feb 9, 2018 at 9:51 PM, Ralph DiMola via use-livecode <
[hidden email]> wrote:

> Brain,
>
>
>
> Thanks but still no-go.
>
>
>
>
>
> Ralph DiMola
>
> IT Director
>
> Evergreen Information Services
>
> [hidden email]
>
> Phone: 518-636-3998 Ex:11
>
> Cell: 518-796-9332
>
>
>
> From: Brian Milby [mailto:[hidden email]]
> Sent: Friday, February 09, 2018 4:16 PM
> To: How to use LiveCode
> Cc: Ralph DiMola
> Subject: Re: iOS app Error ITMS-90529 submitting to app store via
> Application Loader
>
>
>
> Try with 8.1.9 - I think that is a bug that was fixed.
>
> On Fri, Feb 9, 2018 at 3:00 PM Ralph DiMola via use-livecode <
> [hidden email]> wrote:
>
> Here's a new one I never received before. Using 8.1.9 rc2. I made the app
> using the distribution profile and zipped it up as usual.
> Xcode 9.2
> Application Loader 3.7
> OS X 10.12.6
>
> The upload to the app store starts and the I get this error during
> "Verifying assets with the App Store."
>
> ERROR ITMS-90529: "Invalid package. Applications built with sdk 9.0 or
> later
> must be packaged as proper IPA files."
>
> Has the zipping procedure changes with 8.1.9 rc2? I did not get this with
> 8.1.9 rc1.
>
> Thanks in advance...
>
> Ralph DiMola
> IT Director
> Evergreen Information Services
> [hidden email]
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

RE: iOS app Error ITMS-90529 submitting to app store via Application Loader

Mike Bonner via use-livecode
In reply to this post by Mike Bonner via use-livecode
Panos,

Hold the presses. I reorganized the folder with the icons and must have
deleted the iStore icon file. I did not get an error when building. I am
going to try again.

Ralph DiMola
IT Director
Evergreen Information Services
[hidden email]
Phone: 518-636-3998 Ex:11
Cell: 518-796-9332


-----Original Message-----
From: use-livecode [mailto:[hidden email]] On Behalf
Of panagiotis merakos via use-livecode
Sent: Friday, February 09, 2018 4:41 PM
To: How to use LiveCode
Cc: panagiotis merakos
Subject: Re: iOS app Error ITMS-90529 submitting to app store via
Application Loader

Hi Ralph,
Have you included an AppStore icon (1024x1024) png in the iOS standalone
settings?
Panos
-

On Feb 9, 2018 21:16, "Brian Milby via use-livecode" <
[hidden email]> wrote:

> Try with 8.1.9 - I think that is a bug that was fixed.
> On Fri, Feb 9, 2018 at 3:00 PM Ralph DiMola via use-livecode <
> [hidden email]> wrote:
>
> > Here's a new one I never received before. Using 8.1.9 rc2. I made
> > the app using the distribution profile and zipped it up as usual.
> > Xcode 9.2
> > Application Loader 3.7
> > OS X 10.12.6
> >
> > The upload to the app store starts and the I get this error during
> > "Verifying assets with the App Store."
> >
> > ERROR ITMS-90529: "Invalid package. Applications built with sdk 9.0
> > or later must be packaged as proper IPA files."
> >
> > Has the zipping procedure changes with 8.1.9 rc2? I did not get this
> > with
> > 8.1.9 rc1.
> >
> > Thanks in advance...
> >
> > Ralph DiMola
> > IT Director
> > Evergreen Information Services
> > [hidden email]
> >
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

RE: iOS app Error ITMS-90529 submitting to app store via Application Loader

Mike Bonner via use-livecode
In reply to this post by Mike Bonner via use-livecode
Panos,

Thanks! That did it. Uploaded and waiting for review.

Have a good weekend.

Ralph DiMola
IT Director
Evergreen Information Services
[hidden email]
Phone: 518-636-3998 Ex:11
Cell: 518-796-9332


-----Original Message-----
From: use-livecode [mailto:[hidden email]] On Behalf
Of panagiotis merakos via use-livecode
Sent: Friday, February 09, 2018 4:55 PM
To: How to use LiveCode
Cc: panagiotis merakos
Subject: Re: iOS app Error ITMS-90529 submitting to app store via
Application Loader

Hi Ralph,

The file you should upload should be called "application.ipa", not
"application.ipa.zip"

Try this:

1. In LC, create an iOS standalone as usual 2. Suppose the standalone is
saved in a folder called myApp, located in user's Desktop folder so you
should see something like:

Desktop/myApp/myApp.app

3. Open a terminal and navigate to Desktop folder:
"cd ~/Desktop"

4. From the terminal, rename the "myApp" folder to "Payload"
"mv myApp Payload"

5. From the terminal, zip the "Payload" folder and rename it to
"application.ipa":
"zip -r application.ipa Payload"

6. Now use Application Loader to upload the "application.ipa" file.

These are the steps I followed when testing uploading to AppStore with LC
8.1.9 RC-2 and 8.1.9, and it worked.

Keep us posted.

Panos
--



On Fri, Feb 9, 2018 at 9:51 PM, Ralph DiMola via use-livecode <
[hidden email]> wrote:

> Brain,
>
>
>
> Thanks but still no-go.
>
>
>
>
>
> Ralph DiMola
>
> IT Director
>
> Evergreen Information Services
>
> [hidden email]
>
> Phone: 518-636-3998 Ex:11
>
> Cell: 518-796-9332
>
>
>
> From: Brian Milby [mailto:[hidden email]]
> Sent: Friday, February 09, 2018 4:16 PM
> To: How to use LiveCode
> Cc: Ralph DiMola
> Subject: Re: iOS app Error ITMS-90529 submitting to app store via
> Application Loader
>
>
>
> Try with 8.1.9 - I think that is a bug that was fixed.
>
> On Fri, Feb 9, 2018 at 3:00 PM Ralph DiMola via use-livecode <
> [hidden email]> wrote:
>
> Here's a new one I never received before. Using 8.1.9 rc2. I made the
> app using the distribution profile and zipped it up as usual.
> Xcode 9.2
> Application Loader 3.7
> OS X 10.12.6
>
> The upload to the app store starts and the I get this error during
> "Verifying assets with the App Store."
>
> ERROR ITMS-90529: "Invalid package. Applications built with sdk 9.0 or
> later must be packaged as proper IPA files."
>
> Has the zipping procedure changes with 8.1.9 rc2? I did not get this
> with
> 8.1.9 rc1.
>
> Thanks in advance...
>
> Ralph DiMola
> IT Director
> Evergreen Information Services
> [hidden email]
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: [ANN] Release 8.1.9

Mike Bonner via use-livecode
In reply to this post by Mike Bonner via use-livecode
On 02/09/2018 09:07 AM, Ralph DiMola via use-livecode wrote:

> ...\Roaming\...

Hah! I was listening to Ornette's "Rambling" when that email arrived.

--
  Mark Wieder
  [hidden email]

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

RE: [ANN] Release 8.1.9

Mike Bonner via use-livecode
"Jazz is not dead, it just smells funny"
          Frank Zappa  

Ralph DiMola
IT Director
Evergreen Information Services
[hidden email]


-----Original Message-----
From: use-livecode [mailto:[hidden email]] On Behalf
Of Mark Wieder via use-livecode
Sent: Friday, February 09, 2018 7:01 PM
To: Ralph DiMola via use-livecode
Cc: Mark Wieder
Subject: Re: [ANN] Release 8.1.9

On 02/09/2018 09:07 AM, Ralph DiMola via use-livecode wrote:

> ...\Roaming\...

Hah! I was listening to Ornette's "Rambling" when that email arrived.

--
  Mark Wieder
  [hidden email]

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: [ANN] Release 8.1.9

Mike Bonner via use-livecode
Hi,
I was having an issue building standalones for iOS when I up'd to 8.1.9 and
Xcode 9.2. I tried with an empty stack and everything then learnt that a
setting within XCode was the issue. In preferences>Locations there is a
selector for 'Command Line Tools'. I had to select the latest version to
make it work. This is just a heads up for anyone who runs into the same
issue.

Sean Cole
*Pi Digital *

On 10 February 2018 at 01:03, Ralph DiMola via use-livecode <
[hidden email]> wrote:

> "Jazz is not dead, it just smells funny"
>           Frank Zappa
>
> Ralph DiMola
> IT Director
> Evergreen Information Services
> [hidden email]
>
>
> -----Original Message-----
> From: use-livecode [mailto:[hidden email]] On
> Behalf
> Of Mark Wieder via use-livecode
> Sent: Friday, February 09, 2018 7:01 PM
> To: Ralph DiMola via use-livecode
> Cc: Mark Wieder
> Subject: Re: [ANN] Release 8.1.9
>
> On 02/09/2018 09:07 AM, Ralph DiMola via use-livecode wrote:
>
> > ...\Roaming\...
>
> Hah! I was listening to Ornette's "Rambling" when that email arrived.
>
> --
>   Mark Wieder
>   [hidden email]
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: [ANN] Release 8.1.9

Mike Bonner via use-livecode
Hi Sean,

Thanks for that. I should have posted that here as well. For anyone
interested, see:

http://forums.livecode.com/viewtopic.php?f=49&t=30611

http://quality.livecode.com/show_bug.cgi?id=20936

Best,
Panos
--

On Fri, Feb 16, 2018 at 3:08 PM, Sean Cole (Pi) via use-livecode <
[hidden email]> wrote:

> Hi,
> I was having an issue building standalones for iOS when I up'd to 8.1.9 and
> Xcode 9.2. I tried with an empty stack and everything then learnt that a
> setting within XCode was the issue. In preferences>Locations there is a
> selector for 'Command Line Tools'. I had to select the latest version to
> make it work. This is just a heads up for anyone who runs into the same
> issue.
>
> Sean Cole
> *Pi Digital *
>
> On 10 February 2018 at 01:03, Ralph DiMola via use-livecode <
> [hidden email]> wrote:
>
> > "Jazz is not dead, it just smells funny"
> >           Frank Zappa
> >
> > Ralph DiMola
> > IT Director
> > Evergreen Information Services
> > [hidden email]
> >
> >
> > -----Original Message-----
> > From: use-livecode [mailto:[hidden email]] On
> > Behalf
> > Of Mark Wieder via use-livecode
> > Sent: Friday, February 09, 2018 7:01 PM
> > To: Ralph DiMola via use-livecode
> > Cc: Mark Wieder
> > Subject: Re: [ANN] Release 8.1.9
> >
> > On 02/09/2018 09:07 AM, Ralph DiMola via use-livecode wrote:
> >
> > > ...\Roaming\...
> >
> > Hah! I was listening to Ornette's "Rambling" when that email arrived.
> >
> > --
> >   Mark Wieder
> >   [hidden email]
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription
> > preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
12