App Submission Errors

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

App Submission Errors

Bob Sneidar via use-livecode
Using LC 8.1.9, Max OS 10.12.6, XCode 9.2 I created my app for iOS.  I followed the instructions to create a ipa file.  When I upload the ipa with version 3.7 of Application Loader, I get these errors:

ERROR ITMS-90032: "Invalid Image Path - No image found at the path referenced under key 'CFBundleIcons': 'AppIcon60x60'"
ERROR ITMS-90023: "Missing required icon file. The bundle does not contain an app icon for iPad of exactly '76x76' pixels, in .png format for iOS versions >= 7.0."
ERROR ITMS-90023: "Missing required icon file. The bundle does not contain an app icon for iPad of exactly '152x152' pixels, in .png format for iOS versions >= 7.0."
ERROR ITMS-90022: "Missing required icon file. The bundle does not contain an app icon for iPhone / iPod Touch of exactly '120x120' pixels, in .png format for iOS versions >= 7.0."

Have I got a setting wrong?  Or is there a LC bug?

Anyone have any insight to share?

-Dan
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: App Submission Errors

Bob Sneidar via use-livecode
Hi Dan,

You have to include *all* the required icons for your app. Just go to the
iOS standalone settings and make sure you add a .png of the specified
dimensions (shown in the tooltip) for each icon field.

Best,
Panos
--

On Tue, Apr 3, 2018 at 4:14 PM, Dan Friedman via use-livecode <
[hidden email]> wrote:

> Using LC 8.1.9, Max OS 10.12.6, XCode 9.2 I created my app for iOS.  I
> followed the instructions to create a ipa file.  When I upload the ipa with
> version 3.7 of Application Loader, I get these errors:
>
> ERROR ITMS-90032: "Invalid Image Path - No image found at the path
> referenced under key 'CFBundleIcons': 'AppIcon60x60'"
> ERROR ITMS-90023: "Missing required icon file. The bundle does not contain
> an app icon for iPad of exactly '76x76' pixels, in .png format for iOS
> versions >= 7.0."
> ERROR ITMS-90023: "Missing required icon file. The bundle does not contain
> an app icon for iPad of exactly '152x152' pixels, in .png format for iOS
> versions >= 7.0."
> ERROR ITMS-90022: "Missing required icon file. The bundle does not contain
> an app icon for iPhone / iPod Touch of exactly '120x120' pixels, in .png
> format for iOS versions >= 7.0."
>
> Have I got a setting wrong?  Or is there a LC bug?
>
> Anyone have any insight to share?
>
> -Dan
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: App Submission Errors

Bob Sneidar via use-livecode
In reply to this post by Bob Sneidar via use-livecode
Panos,

Thank you for the tip!   Actually, I had all the icons in place, but the icon folder was moved.  Now I am left with this feeling of stupidity and embarrassment.   :)

-Dan

--------------------------------------------------------

Hi Dan,

You have to include *all* the required icons for your app. Just go to the
iOS standalone settings and make sure you add a .png of the specified
dimensions (shown in the tooltip) for each icon field.

Best,
Panos

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode