Quantcast

Are SVG icons supposed to work on Android?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Are SVG icons supposed to work on Android?

Mark Talluto via use-livecode
per the subject really - I added some snazzy SVG icons into my app, for no
better reason than that I could - but when I built to Android, one of them
didn't appear at all, and when the other is supposed to briefly fade in and
out again, instead a square of approximately the same size does so.

Is this a known issue? (I couldn't find any reference to it, in user guide, or
QCC. Then again, the only reference to SVG in the - 8.1.3 - user guide is to
say that there is a third-party library to import and export.)

TIA,

Ben

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Inclusions on Android (was Re: Are SVG icons supposed to work on Android?)

Mark Talluto via use-livecode
Immediately after sending the below, I decide to put that project on hold and
try another one on Android - and found that a segmented control widget was
missing.

I switched to manually-selected inclusions, and was then able to see the
segmented control widget on Android; and then went back to the previous
project, manually selected SVG icons, and found thqt worked too.

So, forget the question about SVG working on Android; but is there a known
issue with the inclusion search not working for Android builds?

TIA,

Ben

On 21/02/2017 17:13, Ben Rubinstein wrote:

> per the subject really - I added some snazzy SVG icons into my app, for no
> better reason than that I could - but when I built to Android, one of them
> didn't appear at all, and when the other is supposed to briefly fade in and
> out again, instead a square of approximately the same size does so.
>
> Is this a known issue? (I couldn't find any reference to it, in user guide, or
> QCC. Then again, the only reference to SVG in the - 8.1.3 - user guide is to
> say that there is a third-party library to import and export.)
>
> TIA,
>
> Ben

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Are SVG icons supposed to work on Android?

Mark Talluto via use-livecode
In reply to this post by Mark Talluto via use-livecode
I'm using svg in a couple of Android apps and they work fine. You do need
to make sure that SVG is selected in the Inclusions pane of the standalone
settings.

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com



On February 21, 2017 11:47:35 AM Ben Rubinstein via use-livecode
<[hidden email]> wrote:

> per the subject really - I added some snazzy SVG icons into my app, for no
> better reason than that I could - but when I built to Android, one of them
> didn't appear at all, and when the other is supposed to briefly fade in and
> out again, instead a square of approximately the same size does so.
>
> Is this a known issue? (I couldn't find any reference to it, in user guide, or
> QCC. Then again, the only reference to SVG in the - 8.1.3 - user guide is to
> say that there is a third-party library to import and export.)
>
> TIA,
>
> Ben
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Inclusions on Android (was Re: Are SVG icons supposed to work on Android?)

Mark Talluto via use-livecode
In reply to this post by Mark Talluto via use-livecode
Not as far as I know- if the search for inclusions wasn't working I would
expect it to be an ide bug... does it work in a desktop standalone?

On Tue, 21 Feb 2017 at 17:32, Ben Rubinstein via use-livecode <
[hidden email]> wrote:

> Immediately after sending the below, I decide to put that project on hold
> and
> try another one on Android - and found that a segmented control widget was
> missing.
>
> I switched to manually-selected inclusions, and was then able to see the
> segmented control widget on Android; and then went back to the previous
> project, manually selected SVG icons, and found thqt worked too.
>
> So, forget the question about SVG working on Android; but is there a known
> issue with the inclusion search not working for Android builds?
>
> TIA,
>
> Ben
>
> On 21/02/2017 17:13, Ben Rubinstein wrote:
> > per the subject really - I added some snazzy SVG icons into my app, for
> no
> > better reason than that I could - but when I built to Android, one of
> them
> > didn't appear at all, and when the other is supposed to briefly fade in
> and
> > out again, instead a square of approximately the same size does so.
> >
> > Is this a known issue? (I couldn't find any reference to it, in user
> guide, or
> > QCC. Then again, the only reference to SVG in the - 8.1.3 - user guide
> is to
> > say that there is a third-party library to import and export.)
> >
> > TIA,
> >
> > Ben
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Inclusions on Android (was Re: Are SVG icons supposed to work on Android?)

Mark Talluto via use-livecode
Hi Ali (and Jacque) - thanks for responding.

Here's what I'm seeing:

A very simple stack with a field and a segemented widget (I've concentrated on
this stack because it's an easier test for me than the SVG icon, but I think
it's the same thing).

Standalone settings for both Android and iOS.

1. Start with manually selected inclusions: segmented control widget checked.

- App has the widget on both Android and iOS.

2. Now switch to 'search for inclusions', build new apps.

- App has the widget on both Android and iOS.

3. Now switch to 'select inclusions', uncheck the segmented control widget;
switch back to 'search for inclusions'. Build new apps.

- App on iOS has the widget, but app on Android doesn't.

In other words, it seems that the standalone builder for Android always works
from the manually selected inclusions, ignoring the result of the 'search for
required inclusions'.


(BTW in case it turns out to make a difference to reproduce this - I'm too
lazy to use Xcode and APK directly, so although in my tests both apps were
being built each time, I was actually checking the results by switching the
"Test Target" between an Android and an iOS device, and using "Test" - so
actually building both apps twice for each condition.)

Ben

On 21/02/2017 18:09, Ali Lloyd via use-livecode wrote:

> Not as far as I know- if the search for inclusions wasn't working I would
> expect it to be an ide bug... does it work in a desktop standalone?
>
> On Tue, 21 Feb 2017 at 17:32, Ben Rubinstein via use-livecode <
> [hidden email]> wrote:
>
>> Immediately after sending the below, I decide to put that project on hold
>> and
>> try another one on Android - and found that a segmented control widget was
>> missing.
>>
>> I switched to manually-selected inclusions, and was then able to see the
>> segmented control widget on Android; and then went back to the previous
>> project, manually selected SVG icons, and found thqt worked too.
>>
>> So, forget the question about SVG working on Android; but is there a known
>> issue with the inclusion search not working for Android builds?
>>
>> TIA,
>>
>> Ben
>>
>> On 21/02/2017 17:13, Ben Rubinstein wrote:
>>> per the subject really - I added some snazzy SVG icons into my app, for
>> no
>>> better reason than that I could - but when I built to Android, one of
>> them
>>> didn't appear at all, and when the other is supposed to briefly fade in
>> and
>>> out again, instead a square of approximately the same size does so.
>>>
>>> Is this a known issue? (I couldn't find any reference to it, in user
>> guide, or
>>> QCC. Then again, the only reference to SVG in the - 8.1.3 - user guide
>> is to
>>> say that there is a third-party library to import and export.)
>>>
>>> TIA,
>>>
>>> Ben
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Loading...