Bug in the inspector palette

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug in the inspector palette

Rick Harrison via use-livecode
I have come across what must be a bug in the IDE, in the inspector palette to be precise. I have a script where I set some text properties of the templateField on the fly, like font, size and color. These settings also affect the objects of the “Basic" pane in the inspector, changing the properties of fields and buttons. Switching from the “Basic” pane to any other pane and back again fixes the problem. If the font size is set to a very high value, the “Basic” pane becomes useless, as only parts of the text of the label fields will be shown, and the text of the buttons “disappears”. The whole layout of the pane gets distorted. Has anyone else come across this problem? It appears both in LC 8.1.3 and LC 9 (dp5) on a Mac with macOS 10.12.4.

Regards
Tore Nilsen
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Bug in the inspector palette

Rick Harrison via use-livecode
I can confirm your findings, also affects LC8.1.4 (rc 1).

Paul

MacOS Sierra 10.12.4

> On 17 Apr 2017, at 02:08, Tore Nilsen via use-livecode <[hidden email]> wrote:
>
> I have come across what must be a bug in the IDE, in the inspector palette to be precise. I have a script where I set some text properties of the templateField on the fly, like font, size and color. These settings also affect the objects of the “Basic" pane in the inspector, changing the properties of fields and buttons. Switching from the “Basic” pane to any other pane and back again fixes the problem. If the font size is set to a very high value, the “Basic” pane becomes useless, as only parts of the text of the label fields will be shown, and the text of the buttons “disappears”. The whole layout of the pane gets distorted. Has anyone else come across this problem? It appears both in LC 8.1.3 and LC 9 (dp5) on a Mac with macOS 10.12.4.
>
> Regards
> Tore Nilsen
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode