Cannot run .exec file of project

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot run .exec file of project

charles61
I am using Rev Enterprise 4.0.0 (built 950). After compiling my project, I found that my app ran fine on OS X (10.6.2) but it will not run on Windows XP using Parallels Version Build 5.0.9344. The splash screen appears but the application does not launch and an error message dialog that is set using the error reporting in Standalone Applications setting appears:

Executing at 1:48:22 PM on Tuesday, April 27, 2010
Type: Chunk: can't find stack
Object: card 'card id 1002' of stack 'C:/Documents and Settings/Administrator/Desktop/S504.exe'
Line: show stack 'Support 504 Assist'
Line Num: 48
Hint: continue

And I had to use Control-Alt-Delete to stop the splash from continuing to try to find the Support 504 Assist stack.

The above script refers to my script in the splash stack below which is supposed to launch my app:

on openStack
   send continue to me in 2 seconds
end openStack
   
on continue
   close stack "AppStart"
   go stack "Support 504 Assist"
   show stack "Support 504 Assist"
end continue

The funny thing is that this same script work about a year ago when I created another app. When I tested my old app, I got the same error message except with only the name of the app being different! In both instances, I tried to launch both apps from the desktop.

I check my standalone application settings to see if the stack "Support 504 Assist" was accidentally left out but it is included in the stack files.

Has anyone ran into this problem? Or is this script needs to be changed?


Reply | Threaded
Open this post in threaded view
|

Re: Cannot run .exec file of project

Richmond Mathewson-2
  On 27/04/2010 22:15, charles61 wrote:

> I am using Rev Enterprise 4.0.0 (built 950). After compiling my project, I
> found that my app ran fine on OS X (10.6.2) but it will not run on Windows
> XP using Parallels Version Build 5.0.9344. The splash screen appears but the
> application does not launch and an error message dialog that is set using
> the error reporting in Standalone Applications setting appears:
>
> Executing at 1:48:22 PM on Tuesday, April 27, 2010
> Type: Chunk: can't find stack
> Object: card 'card id 1002' of stack 'C:/Documents and
> Settings/Administrator/Desktop/S504.exe'
> Line: show stack 'Support 504 Assist'
> Line Num: 48
> Hint: continue
>
> And I had to use Control-Alt-Delete to stop the splash from continuing to
> try to find the Support 504 Assist stack.
>
> The above script refers to my script in the splash stack below which is
> supposed to launch my app:
>
> on openStack
>     send continue to me in 2 seconds
> end openStack
>
> on continue
>     close stack "AppStart"
>     go stack "Support 504 Assist"
>     show stack "Support 504 Assist"
> end continue
>
> The funny thing is that this same script work about a year ago when I
> created another app. When I tested my old app, I got the same error message
> except with only the name of the app being different! In both instances, I
> tried to launch both apps from the desktop.
>
> I check my standalone application settings to see if the stack "Support 504
> Assist" was accidentally left out but it is included in the stack files.
>
> Has anyone ran into this problem? Or is this script needs to be changed?
>
>
>
Knowing that RunRev 4.0 for Windows will not run under WINE in Linux
makes me
think that Windows executables made by the RunRev standalone builder are
probably not very "haooy" with any sort of emulated environment.
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Cannot run .exec file of project

J. Landman Gay
Richmond Mathewson wrote:

> Knowing that RunRev 4.0 for Windows will not run under WINE in Linux
> makes me
> think that Windows executables made by the RunRev standalone builder are
> probably not very "haooy" with any sort of emulated environment.

I run, test, and work with Windows executables in emulation all the time
without issue.

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Cannot run .exec file of project

Richmond Mathewson-2
  On 27/04/2010 22:42, J. Landman Gay wrote:

> Richmond Mathewson wrote:
>
>> Knowing that RunRev 4.0 for Windows will not run under WINE in Linux
>> makes me
>> think that Windows executables made by the RunRev standalone builder are
>> probably not very "haooy" with any sort of emulated environment.
>
> I run, test, and work with Windows executables in emulation all the
> time without issue.
>
  Wow I rattled that one off fast; hitting the 'O' key twice instead of
the 'P' . . .  :)

Here we go again: all sorts of unknowns are coming to the surface re RunRev:

1. RunRev IDE for Windows does not run under WINE

(Woops; before I get all domatic about the inevitable number 2 I'd
better see if I can
get a Windows standalone to function in WINE; turning on the Ubu-Box and
here we go . . . )

2. WOW! I got a (albeit crude, basic stack) Windows exe standalone,
built on Ubuntu 10.04 beta something
     to run under WINE. Although all the colours were inverted.

3. Now somebody with some jazzier computers than mine had better try the
same tests with VMware,
     CrossOver, CrossDresser and all the rest. [Trick Question; which of
those last 3 methods of emulation
     is not an emulator?]

I am beginning to think that RunRev's REAL shortcoming is not that it
cannot do this and that on some
OS or another, but that it is suffering from serious UNDER-DOCUMENTATION.

Adequate Documentation will require a whole lot of work and a whole lot
of testing.
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Cannot run .exec file of project

charles61
In reply to this post by Richmond Mathewson-2
Richmond,

Thanks for you comment! It did run under previous versions of Parallel last year. And I am actually running on XP. This latest version of Parallels is supposed to be much improved. So the problem is my script, Rev. 4.0, or Parallels. I don't have a windows computer to try it on but I may be able to try on one in a few days.

Charles Szasz
[hidden email]




On Apr 27, 2010, at 3:36 PM, Richmond Mathewson-2 [via Runtime Revolution] wrote:

  On 27/04/2010 22:15, charles61 wrote:

> I am using Rev Enterprise 4.0.0 (built 950). After compiling my project, I
> found that my app ran fine on OS X (10.6.2) but it will not run on Windows
> XP using Parallels Version Build 5.0.9344. The splash screen appears but the
> application does not launch and an error message dialog that is set using
> the error reporting in Standalone Applications setting appears:
>
> Executing at 1:48:22 PM on Tuesday, April 27, 2010
> Type: Chunk: can't find stack
> Object: card 'card id 1002' of stack 'C:/Documents and
> Settings/Administrator/Desktop/S504.exe'
> Line: show stack 'Support 504 Assist'
> Line Num: 48
> Hint: continue
>
> And I had to use Control-Alt-Delete to stop the splash from continuing to
> try to find the Support 504 Assist stack.
>
> The above script refers to my script in the splash stack below which is
> supposed to launch my app:
>
> on openStack
>     send continue to me in 2 seconds
> end openStack
>
> on continue
>     close stack "AppStart"
>     go stack "Support 504 Assist"
>     show stack "Support 504 Assist"
> end continue
>
> The funny thing is that this same script work about a year ago when I
> created another app. When I tested my old app, I got the same error message
> except with only the name of the app being different! In both instances, I
> tried to launch both apps from the desktop.
>
> I check my standalone application settings to see if the stack "Support 504
> Assist" was accidentally left out but it is included in the stack files.
>
> Has anyone ran into this problem? Or is this script needs to be changed?
>
>
>
Knowing that RunRev 4.0 for Windows will not run under WINE in Linux
makes me
think that Windows executables made by the RunRev standalone builder are
probably not very "haooy" with any sort of emulated environment.
_______________________________________________
use-revolution mailing list
<a href="x-msg://15/user/SendEmail.jtp?type=node&amp;node=2068148&amp;i=0" target="_top" rel="nofollow">[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution





Reply | Threaded
Open this post in threaded view
|

Re: Cannot run .exec file of project

Luis-24
In reply to this post by Richmond Mathewson-2
I think in this instance you might want to define 'emulation'...

Cheers,

Luis.


Richmond Mathewson wrote:
>  On 27/04/2010 22:42, J. Landman Gay wrote:
>> Richmond Mathewson wrote:

>
> 3. Now somebody with some jazzier computers than mine had better try the
> same tests with VMware,
>     CrossOver, CrossDresser and all the rest. [Trick Question; which of
> those last 3 methods of emulation
>     is not an emulator?]
>
> I am beginning to think that RunRev's REAL shortcoming is not that it
> cannot do this and that on some
> OS or another, but that it is suffering from serious UNDER-DOCUMENTATION.
>
> Adequate Documentation will require a whole lot of work and a whole lot
> of testing.
> _______________________________________________
> use-revolution mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution
>
>
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Cannot run .exec file of project

Sarah Reichelt-2
In reply to this post by charles61
> I am using Rev Enterprise 4.0.0 (built 950). After compiling my project, I
> found that my app ran fine on OS X (10.6.2) but it will not run on Windows
> XP using Parallels Version Build 5.0.9344. The splash screen appears but the
> application does not launch and an error message dialog that is set using
> the error reporting in Standalone Applications setting appears:
>
> Executing at 1:48:22 PM on Tuesday, April 27, 2010
> Type: Chunk: can't find stack
> Object: card 'card id 1002' of stack 'C:/Documents and
> Settings/Administrator/Desktop/S504.exe'
> Line: show stack 'Support 504 Assist'
> Line Num: 48
> Hint: continue

Are you sure the missing stack is part of the exe? Is is it a separate
sub-stack, in which case, you need to make sure it is kept with the
exe if you move it.

Cheers,
Sarah
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Cannot run .exec file of project

charles61
In reply to this post by charles61
Thanks Sarah for your suggestion! Prior to just reading your suggestion, I discovered that the problem is related to dragging the exec. file to the XP desktop without the other stack. So your are right! When I drag the whole window folder to the desktop, everything works fine.