Could not open module file

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Could not open module file

Monte Goulding via use-livecode
Building a stand-alone in LC 8.1.4 (RC1) on Mac OS 10.11.6.

I get “Could not open module file”.

This is a very un-helpful error message. What could it mean? I get it if I let LC find all inclusions. It would seem that the error message would be able to include the name of the module file?? Hmm...

Bill

William A. Prothero
http://earthlearningsolution.org/

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Could not open module file

Monte Goulding via use-livecode
Hi Bill,
Just a shot in the dark: Does the stack contain a spinner widget from
LiveCode 9.0 DP x? If yes, this will not compile in LiveCode 8.x.

Best,
Panos

On 6 Apr 2017 02:35, "William Prothero via use-livecode" <
[hidden email]> wrote:

Building a stand-alone in LC 8.1.4 (RC1) on Mac OS 10.11.6.

I get “Could not open module file”.

This is a very un-helpful error message. What could it mean? I get it if I
let LC find all inclusions. It would seem that the error message would be
able to include the name of the module file?? Hmm...

Bill

William A. Prothero
http://earthlearningsolution.org/

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Could not open module file

Monte Goulding via use-livecode
I don't think so, but I'll try it tomorrow with lc9.
Thanks,
Good call!
Bill

William Prothero
http://es.earthednet.org

> On Apr 5, 2017, at 10:11 PM, panagiotis merakos via use-livecode <[hidden email]> wrote:
>
> Hi Bill,
> Just a shot in the dark: Does the stack contain a spinner widget from
> LiveCode 9.0 DP x? If yes, this will not compile in LiveCode 8.x.
>
> Best,
> Panos
>
> On 6 Apr 2017 02:35, "William Prothero via use-livecode" <
> [hidden email]> wrote:
>
> Building a stand-alone in LC 8.1.4 (RC1) on Mac OS 10.11.6.
>
> I get “Could not open module file”.
>
> This is a very un-helpful error message. What could it mean? I get it if I
> let LC find all inclusions. It would seem that the error message would be
> able to include the name of the module file?? Hmm...
>
> Bill
>
> William A. Prothero
> http://earthlearningsolution.org/
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Could not open module file

Monte Goulding via use-livecode
In reply to this post by Monte Goulding via use-livecode
This is a project I haven’t worked on for awhile. LiveCode 9.0 produces the same error message. I’ve tried it when setting it to detect inclusions, but there is the same error.

Is there any reason the error dialog couldn’t specify which module it can’t load? I am assuming it is wanting some widget? Or, for now, is there a way I can identify the module it is having trouble loading without tedious substitutions and thrashing around?

My desperation move is to go back to an older version that will save, but I hate to lose work I’ve done since..

Regards,
Bill

> On Apr 5, 2017, at 10:11 PM, panagiotis merakos via use-livecode <[hidden email]> wrote:
>
> Hi Bill,
> Just a shot in the dark: Does the stack contain a spinner widget from
> LiveCode 9.0 DP x? If yes, this will not compile in LiveCode 8.x.
>
> Best,
> Panos
>
> On 6 Apr 2017 02:35, "William Prothero via use-livecode" <
> [hidden email]> wrote:
>
> Building a stand-alone in LC 8.1.4 (RC1) on Mac OS 10.11.6.
>
> I get “Could not open module file”.
>
> This is a very un-helpful error message. What could it mean? I get it if I
> let LC find all inclusions. It would seem that the error message would be
> able to include the name of the module file?? Hmm...
>
> Bill
>
> William A. Prothero
> http://earthlearningsolution.org/
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Could not open module file

Monte Goulding via use-livecode
My problem was that I had the Calendar widget installed. It is not in the correct format for current LC Versions.
Bill

> On Apr 6, 2017, at 7:48 AM, William Prothero via use-livecode <[hidden email]> wrote:
>
> This is a project I haven’t worked on for awhile. LiveCode 9.0 produces the same error message. I’ve tried it when setting it to detect inclusions, but there is the same error.
>
> Is there any reason the error dialog couldn’t specify which module it can’t load? I am assuming it is wanting some widget? Or, for now, is there a way I can identify the module it is having trouble loading without tedious substitutions and thrashing around?
>
> My desperation move is to go back to an older version that will save, but I hate to lose work I’ve done since..
>
> Regards,
> Bill
>
>> On Apr 5, 2017, at 10:11 PM, panagiotis merakos via use-livecode <[hidden email]> wrote:
>>
>> Hi Bill,
>> Just a shot in the dark: Does the stack contain a spinner widget from
>> LiveCode 9.0 DP x? If yes, this will not compile in LiveCode 8.x.
>>
>> Best,
>> Panos
>>
>> On 6 Apr 2017 02:35, "William Prothero via use-livecode" <
>> [hidden email]> wrote:
>>
>> Building a stand-alone in LC 8.1.4 (RC1) on Mac OS 10.11.6.
>>
>> I get “Could not open module file”.
>>
>> This is a very un-helpful error message. What could it mean? I get it if I
>> let LC find all inclusions. It would seem that the error message would be
>> able to include the name of the module file?? Hmm...
>>
>> Bill
>>
>> William A. Prothero
>> http://earthlearningsolution.org/
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Could not open module file

Monte Goulding via use-livecode
Hi Bill,

Thank you for the update. We have to make this error more descriptive, to
indicate the specific widget that caused the problem.

Best,
Panos
--

On Thu, Apr 6, 2017 at 6:25 PM, William Prothero via use-livecode <
[hidden email]> wrote:

> My problem was that I had the Calendar widget installed. It is not in the
> correct format for current LC Versions.
> Bill
>
> > On Apr 6, 2017, at 7:48 AM, William Prothero via use-livecode <
> [hidden email]> wrote:
> >
> > This is a project I haven’t worked on for awhile. LiveCode 9.0 produces
> the same error message. I’ve tried it when setting it to detect inclusions,
> but there is the same error.
> >
> > Is there any reason the error dialog couldn’t specify which module it
> can’t load? I am assuming it is wanting some widget? Or, for now, is there
> a way I can identify the module it is having trouble loading without
> tedious substitutions and thrashing around?
> >
> > My desperation move is to go back to an older version that will save,
> but I hate to lose work I’ve done since..
> >
> > Regards,
> > Bill
> >
> >> On Apr 5, 2017, at 10:11 PM, panagiotis merakos via use-livecode <
> [hidden email]> wrote:
> >>
> >> Hi Bill,
> >> Just a shot in the dark: Does the stack contain a spinner widget from
> >> LiveCode 9.0 DP x? If yes, this will not compile in LiveCode 8.x.
> >>
> >> Best,
> >> Panos
> >>
> >> On 6 Apr 2017 02:35, "William Prothero via use-livecode" <
> >> [hidden email]> wrote:
> >>
> >> Building a stand-alone in LC 8.1.4 (RC1) on Mac OS 10.11.6.
> >>
> >> I get “Could not open module file”.
> >>
> >> This is a very un-helpful error message. What could it mean? I get it
> if I
> >> let LC find all inclusions. It would seem that the error message would
> be
> >> able to include the name of the module file?? Hmm...
> >>
> >> Bill
> >>
> >> William A. Prothero
> >> http://earthlearningsolution.org/
> >>
> >> _______________________________________________
> >> use-livecode mailing list
> >> [hidden email]
> >> Please visit this url to subscribe, unsubscribe and manage your
> >> subscription preferences:
> >> http://lists.runrev.com/mailman/listinfo/use-livecode
> >> _______________________________________________
> >> use-livecode mailing list
> >> [hidden email]
> >> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> >> http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Could not open module file

Monte Goulding via use-livecode
Panos:
Agreed. Thanks!
I found that the Calendar widget was causing the problem. It is not compatible with livecode 9.
Bill

> On Apr 6, 2017, at 10:28 AM, panagiotis merakos via use-livecode <[hidden email]> wrote:
>
> Hi Bill,
>
> Thank you for the update. We have to make this error more descriptive, to
> indicate the specific widget that caused the problem.
>
> Best,
> Panos
> --
>
> On Thu, Apr 6, 2017 at 6:25 PM, William Prothero via use-livecode <
> [hidden email]> wrote:
>
>> My problem was that I had the Calendar widget installed. It is not in the
>> correct format for current LC Versions.
>> Bill
>>
>>> On Apr 6, 2017, at 7:48 AM, William Prothero via use-livecode <
>> [hidden email]> wrote:
>>>
>>> This is a project I haven’t worked on for awhile. LiveCode 9.0 produces
>> the same error message. I’ve tried it when setting it to detect inclusions,
>> but there is the same error.
>>>
>>> Is there any reason the error dialog couldn’t specify which module it
>> can’t load? I am assuming it is wanting some widget? Or, for now, is there
>> a way I can identify the module it is having trouble loading without
>> tedious substitutions and thrashing around?
>>>
>>> My desperation move is to go back to an older version that will save,
>> but I hate to lose work I’ve done since..
>>>
>>> Regards,
>>> Bill
>>>
>>>> On Apr 5, 2017, at 10:11 PM, panagiotis merakos via use-livecode <
>> [hidden email]> wrote:
>>>>
>>>> Hi Bill,
>>>> Just a shot in the dark: Does the stack contain a spinner widget from
>>>> LiveCode 9.0 DP x? If yes, this will not compile in LiveCode 8.x.
>>>>
>>>> Best,
>>>> Panos
>>>>
>>>> On 6 Apr 2017 02:35, "William Prothero via use-livecode" <
>>>> [hidden email]> wrote:
>>>>
>>>> Building a stand-alone in LC 8.1.4 (RC1) on Mac OS 10.11.6.
>>>>
>>>> I get “Could not open module file”.
>>>>
>>>> This is a very un-helpful error message. What could it mean? I get it
>> if I
>>>> let LC find all inclusions. It would seem that the error message would
>> be
>>>> able to include the name of the module file?? Hmm...
>>>>
>>>> Bill
>>>>
>>>> William A. Prothero
>>>> http://earthlearningsolution.org/
>>>>
>>>> _______________________________________________
>>>> use-livecode mailing list
>>>> [hidden email]
>>>> Please visit this url to subscribe, unsubscribe and manage your
>>>> subscription preferences:
>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>> _______________________________________________
>>>> use-livecode mailing list
>>>> [hidden email]
>>>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>
>>>
>>> _______________________________________________
>>> use-livecode mailing list
>>> [hidden email]
>>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Loading...