DataGrid image display woes

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

DataGrid image display woes

Skip Kimpel via use-livecode
Okay, I have a datagrid Form with a template to display an image and 4
fields.

The fields display the correct data for each line/record, but the unique
image for each line/record is not being correctly displayed.

If the dataGrid height can show all records, the image for the last record
is displayed in the first line and all the other images are empty. If the
dataGrid requires scrolling to display all the records, only every 7th line
displays an image and the image changes as the group is scrolled. I have
tried all the versions I have from from 5.54 up to 8.1 with the same
problem.

Is this a known issue?

Hugh Senior


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: DataGrid image display woes

Skip Kimpel via use-livecode
Are you missing an “of me” in the code that sets the image data?

--
Trevor DeVore

On Sat, Aug 4, 2018 at 5:38 AM FlexibleLearning.com via use-livecode <
[hidden email]> wrote:

> Okay, I have a datagrid Form with a template to display an image and 4
> fields.
>
> The fields display the correct data for each line/record, but the unique
> image for each line/record is not being correctly displayed.
>
> If the dataGrid height can show all records, the image for the last record
> is displayed in the first line and all the other images are empty. If the
> dataGrid requires scrolling to display all the records, only every 7th line
> displays an image and the image changes as the group is scrolled. I have
> tried all the versions I have from from 5.54 up to 8.1 with the same
> problem.
>
> Is this a known issue?
>
> Hugh Senior
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

RE: DataGrid image display woes

Skip Kimpel via use-livecode
In reply to this post by Skip Kimpel via use-livecode
 I recently wrote...

> Okay, I have a datagrid Form with a template to display an image and 4
fields.
>
> The fields display the correct data for each line/record, but the unique
image
> for each line/record is not being correctly displayed.
>
> If the dataGrid height can show all records, the image for the last record
is
> displayed in the first line and all the other images are empty. If the
dataGrid
> requires scrolling to display all the records, only every 7th line
displays an
> image and the image changes as the group is scrolled. I have tried all the
> versions I have from from 5.54 up to 8.1 with the same problem.
>
> Is this a known issue?
>
> Hugh Senior


Cancel all that... my object referencing error by omitting "of me". Must be
tyred.

Except now the dataGrid no longer scrolls... Restart the engine... Now it
scrolls.

I should write a book entitled "DataGrids or Voodoo, you decide"

Hugh Senior




_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: DataGrid image display woes

Skip Kimpel via use-livecode
Wow, and Trevor knew right away... pretty impressive!
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: DataGrid image display woes

Skip Kimpel via use-livecode
I think Trevor wrote the original datagrid behavior, or at least was instrumental in it.

Bob S


> On Aug 4, 2018, at 11:17 , Brian Milby via use-livecode <[hidden email]> wrote:
>
> Wow, and Trevor knew right away... pretty impressive!
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: DataGrid image display woes

Skip Kimpel via use-livecode
Yes, I did write the original Data Grid. One thing I’ve learned when
working with any code in LiveCode that is shared between objects, however,
is that when you see one object updating and none of the other objects
you’ve forgotten to add “of me”.

--
Trevor DeVore

On Mon, Aug 6, 2018 at 10:41 AM Bob Sneidar via use-livecode <
[hidden email]> wrote:

> I think Trevor wrote the original datagrid behavior, or at least was
> instrumental in it.
>
> Bob S
>
>
> > On Aug 4, 2018, at 11:17 , Brian Milby via use-livecode <
> [hidden email]> wrote:
> >
> > Wow, and Trevor knew right away... pretty impressive!
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode