Deploying to Android from Linux

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Deploying to Android from Linux

Niggemann, Bernd via use-livecode
Hello folks,

Spent some time on this today, so I post it here in case anyone sees the
same problem:

I wanted to deploy to my Android device from Linux. My device was shown as
"Android ???????" in the "Test Target" menu. I ignored this and chose it
and clicked Test.

The S/B was stuck to the "Installing app to device" dialog.

I used "adb logcat" in the terminal and instead of seeing the log from my
device there was just a "Insufficient permissions" message.

I tried several suggestions from the web, including killing and restarting
the adb server with sudo, but this did not work.

What finally worked was:

1. disable USB debugging in the device
2. Choose to use the device for "File Transfers" <—— THIS IS THE CRUCIAL
STEP
3. enable USB debugging again

Before that, I had tried steps 1+3 only, which did not fix the problem.

After doing all steps 1-3, my device was correctly shown in the Test Target
menu ("Android FA034GT5654376" instead of "Android ????????"), the adb
logcat command was showing logs from my device and I was able to install
the app in the device.

Cheers,
Panos
--
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode