Drag Drop State of Affairs

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Drag Drop State of Affairs

Knapp Martin via use-livecode
Hi all.

I've mentioned before that on a Mac current OS latest LC (and prior) I have some drag/drop operations, where I will process text dropped onto a field. The actual process works, but afterwards, the controls in the window will be unresponsive, until I click the window title bar, after which all works as normal again.

It's not critical, but it is a nuisance especially I am constantly drag/dropping data from installation requests into my app for the sake of convenience and data consistency. It gets to the point where every drag/drop operation has to be followd by a click on the title bar.

I suppose I could simply click at the location of the title bar, but I'd really like to know if there is a way to make sure that any drag/drop operations are "flushed" so to speak. And since I am almost certain that LC interacts with the OS to accomplish this, my suspicion is that the OS has not received any "termination" for the drag/drop operation, and must time out at some point.

The reason I think this is because it seems that when I first begin drag/dropping data, it works for a bit without the issue, but after a time I get the loss of control issue, and from then on all drag drop operations exhibit this "anomaly". But if I wait for a time, things seem to be restored again for a bit.

So I am hoping that maybe there is some system message that gets sent that causes LC to "clean up" after a grag drop operation.

Bob S


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
I’ve had the same issue. FWIW I’ve found that after a drag and drop, if I move my mouse into the LC toolbar and back (with no clicking) it returns to normal.
Marty

> On Aug 3, 2018, at 10:58 AM, Bob Sneidar via use-livecode <[hidden email]> wrote:
>
> Hi all.
>
> I've mentioned before that on a Mac current OS latest LC (and prior) I have some drag/drop operations, where I will process text dropped onto a field. The actual process works, but afterwards, the controls in the window will be unresponsive, until I click the window title bar, after which all works as normal again.
>
> It's not critical, but it is a nuisance especially I am constantly drag/dropping data from installation requests into my app for the sake of convenience and data consistency. It gets to the point where every drag/drop operation has to be followd by a click on the title bar.
>
> I suppose I could simply click at the location of the title bar, but I'd really like to know if there is a way to make sure that any drag/drop operations are "flushed" so to speak. And since I am almost certain that LC interacts with the OS to accomplish this, my suspicion is that the OS has not received any "termination" for the drag/drop operation, and must time out at some point.
>
> The reason I think this is because it seems that when I first begin drag/dropping data, it works for a bit without the issue, but after a time I get the loss of control issue, and from then on all drag drop operations exhibit this "anomaly". But if I wait for a time, things seem to be restored again for a bit.
>
> So I am hoping that maybe there is some system message that gets sent that causes LC to "clean up" after a grag drop operation.
>
> Bob S
>


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
Thanks for the confirmation Marty. My suspicion is that for whatever reason the IDE is not "focused" on the current card after the drop, but only sometimes. I have been unable after much trial and error to produce a reliable formula for reproducing the effect.

Bob S


> On Aug 3, 2018, at 11:13 , Knapp Martin via use-livecode <[hidden email]> wrote:
>
> I’ve had the same issue. FWIW I’ve found that after a drag and drop, if I move my mouse into the LC toolbar and back (with no clicking) it returns to normal.
> Marty

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
In reply to this post by Knapp Martin via use-livecode
Could the defaultstack have changed? It sounds a bit like that.

On 8/3/18 1:13 PM, Knapp Martin via use-livecode wrote:

> I’ve had the same issue. FWIW I’ve found that after a drag and drop, if I move my mouse into the LC toolbar and back (with no clicking) it returns to normal.
> Marty
>
>> On Aug 3, 2018, at 10:58 AM, Bob Sneidar via use-livecode <[hidden email]> wrote:
>>
>> Hi all.
>>
>> I've mentioned before that on a Mac current OS latest LC (and prior) I have some drag/drop operations, where I will process text dropped onto a field. The actual process works, but afterwards, the controls in the window will be unresponsive, until I click the window title bar, after which all works as normal again.
>>
>> It's not critical, but it is a nuisance especially I am constantly drag/dropping data from installation requests into my app for the sake of convenience and data consistency. It gets to the point where every drag/drop operation has to be followd by a click on the title bar.
>>
>> I suppose I could simply click at the location of the title bar, but I'd really like to know if there is a way to make sure that any drag/drop operations are "flushed" so to speak. And since I am almost certain that LC interacts with the OS to accomplish this, my suspicion is that the OS has not received any "termination" for the drag/drop operation, and must time out at some point.
>>
>> The reason I think this is because it seems that when I first begin drag/dropping data, it works for a bit without the issue, but after a time I get the loss of control issue, and from then on all drag drop operations exhibit this "anomaly". But if I wait for a time, things seem to be restored again for a bit.
>>
>> So I am hoping that maybe there is some system message that gets sent that causes LC to "clean up" after a grag drop operation.
>>
>> Bob S


--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
I'll check that. I'll put the defaultStack before the operation and then after and see if it changes.

Bob S


> On Aug 3, 2018, at 11:42 , J. Landman Gay via use-livecode <[hidden email]> wrote:
>
> Could the defaultstack have changed? It sounds a bit like that.


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
No tamalies Jacque. With the stack unresponsive, I type "put the short name of the defaultStack" into the message box and it's correct.

Bob S


> On Aug 3, 2018, at 14:56 , Bob Sneidar via use-livecode <[hidden email]> wrote:
>
> I'll check that. I'll put the defaultStack before the operation and then after and see if it changes.
>
> Bob S


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
Try checking the topstack, that's another one that sometimes resets.

--
Jacqueline Landman Gay | [hidden email]
HyperActive Software | http://www.hyperactivesw.com
On August 3, 2018 5:22:36 PM Bob Sneidar via use-livecode
<[hidden email]> wrote:

> No tamalies Jacque. With the stack unresponsive, I type "put the short name
> of the defaultStack" into the message box and it's correct.
>
> Bob S
>
>
>> On Aug 3, 2018, at 14:56 , Bob Sneidar via use-livecode
>> <[hidden email]> wrote:
>>
>> I'll check that. I'll put the defaultStack before the operation and then
>> after and see if it changes.
>>
>> Bob S
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
In reply to this post by Knapp Martin via use-livecode
Have you found a work around for this Bob? Or filed a bug report? For me the problem exists whether in the IDE or a standalone.

Marty

> On Aug 3, 2018, at 3:20 PM, Bob Sneidar via use-livecode <[hidden email]> wrote:
>
> No tamalies Jacque. With the stack unresponsive, I type "put the short name of the defaultStack" into the message box and it's correct.
>
> Bob S
>
>
>> On Aug 3, 2018, at 14:56 , Bob Sneidar via use-livecode <[hidden email]> wrote:
>>
>> I'll check that. I'll put the defaultStack before the operation and then after and see if it changes.
>>
>> Bob S
>


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
No, and the topStack is the same before and after, which is the stack I am drag/dropping onto. Curiously, I cannot think of a time when the first drag/drop operation failed. It seems it's always on some subsequent drag/drop operation to the same object, which is why I suspect some state that ought to be clearing after the drop isn't. However, I cannot reproduce it every time. It only happens every 3 or 4 times if I do the same operation over and over again. Once it DOES happen though, it seems like I can get it to happen every time, unless as I said I wait a while, then it clears for a bit.

Odd, huh?

Bob S


> On Aug 7, 2018, at 13:46 , Knapp Martin via use-livecode <[hidden email]> wrote:
>
> Have you found a work around for this Bob? Or filed a bug report? For me the problem exists whether in the IDE or a standalone.
>
> Marty


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
I filed a bug report #21474 <https://quality.livecode.com/show_bug.cgi?id=21474>
---
Marty

> On Aug 7, 2018, at 2:47 PM, Bob Sneidar via use-livecode <[hidden email]> wrote:
>
> No, and the topStack is the same before and after, which is the stack I am drag/dropping onto. Curiously, I cannot think of a time when the first drag/drop operation failed. It seems it's always on some subsequent drag/drop operation to the same object, which is why I suspect some state that ought to be clearing after the drop isn't. However, I cannot reproduce it every time. It only happens every 3 or 4 times if I do the same operation over and over again. Once it DOES happen though, it seems like I can get it to happen every time, unless as I said I wait a while, then it clears for a bit.
>
> Odd, huh?
>
> Bob S
>
>
>> On Aug 7, 2018, at 13:46 , Knapp Martin via use-livecode <[hidden email]> wrote:
>>
>> Have you found a work around for this Bob? Or filed a bug report? For me the problem exists whether in the IDE or a standalone.
>>
>> Marty
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Drag Drop State of Affairs

Knapp Martin via use-livecode
Thanks Marty. I didn't because I cannot provide a way to reliably reproduce it. I will bump it.

Bob S


> On Aug 8, 2018, at 14:00 , Knapp Martin via use-livecode <[hidden email]> wrote:
>
> I filed a bug report #21474 <https://quality.livecode.com/show_bug.cgi?id=21474>
> ---
> Marty


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode