Iconify Stack

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Iconify Stack

masmit
Is this property broken? I'm using 2.9 on mac 10.4.11, and the  
following line seems to do nothing at all:

set the iconic of this stack to true

Am I right in thinking that it should send the stack swooping off to  
the dock?

Best,

Mark Smith
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Iconify Stack

Sarah Reichelt-2
On Thu, Jul 3, 2008 at 4:27 AM, Mark Smith <[hidden email]> wrote:
> Is this property broken? I'm using 2.9 on mac 10.4.11, and the following
> line seems to do nothing at all:
>
> set the iconic of this stack to true
>
> Am I right in thinking that it should send the stack swooping off to the
> dock?


Yes, it should and it does here with Rev 2.9 and Mac OS X 10.5.4 but
only if the stack's mode is topLevel or modeless.

Cheers,
Sarah
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Iconify Stack

masmit
That's weird - if I do it by script - nothing, if I click the stack's  
OS iconify button (the middle, yellow one on a mac) off it  
swoops...The stacks I've been trying it with (including a fresh new  
one with no other scripts) all fail to iconify by script.

Thanks for checking it, though.

Mark

On 2 Jul 2008, at 21:27, Sarah Reichelt wrote:

> On Thu, Jul 3, 2008 at 4:27 AM, Mark Smith <[hidden email]> wrote:
>> Is this property broken? I'm using 2.9 on mac 10.4.11, and the  
>> following
>> line seems to do nothing at all:
>>
>> set the iconic of this stack to true
>>
>> Am I right in thinking that it should send the stack swooping off  
>> to the
>> dock?
>
>
> Yes, it should and it does here with Rev 2.9 and Mac OS X 10.5.4 but
> only if the stack's mode is topLevel or modeless.
>
> Cheers,
> Sarah
> _______________________________________________
> use-revolution mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Iconify Stack

J. Landman Gay
Mark Smith wrote:
> That's weird - if I do it by script - nothing, if I click the stack's OS
> iconify button (the middle, yellow one on a mac) off it swoops...The
> stacks I've been trying it with (including a fresh new one with no other
> scripts) all fail to iconify by script.

Works here too, Rev 2.9, Mac OS 10.4.11. Do you have any frontscripts?
Plugins? Does it work if you suspend the development environment?

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Iconify Stack

Sarah Reichelt-2
In reply to this post by masmit
On Thu, Jul 3, 2008 at 11:46 AM, Mark Smith <[hidden email]> wrote:
> That's weird - if I do it by script - nothing, if I click the stack's OS
> iconify button (the middle, yellow one on a mac) off it swoops...The stacks
> I've been trying it with (including a fresh new one with no other scripts)
> all fail to iconify by script.

I tested using the message box, but I just put the script in a button
and that worked fine too.

Sarah
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Iconify Stack

masmit
Got it...I was in too much of a hurry - it <does> work in a 'virgin'  
stack - the problem is that I've been experimenting with doing my own  
stack decorations, and it seems like if the OS title bar buttons are  
missing, then you simply can't iconify, which is a pain, but makes  
some kind of sense...

Thanks again Sarah and Jaque for checking, though.

Mark

On 3 Jul 2008, at 03:15, Sarah Reichelt wrote:

> On Thu, Jul 3, 2008 at 11:46 AM, Mark Smith <[hidden email]>  
> wrote:
>> That's weird - if I do it by script - nothing, if I click the  
>> stack's OS
>> iconify button (the middle, yellow one on a mac) off it  
>> swoops...The stacks
>> I've been trying it with (including a fresh new one with no other  
>> scripts)
>> all fail to iconify by script.
>
> I tested using the message box, but I just put the script in a button
> and that worked fine too.
>
> Sarah
> _______________________________________________
> use-revolution mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution