LC8 lineOffset

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

LC8 lineOffset

Peter Haworth
Has anyone run into problems using lineOffset in LC8?  I'm seeing it return
an incorrect line number in some cases.

I'm wondering if it could have something to do with the data I'm searching,
since some lines have the characters \n embedded in them

Pete
lcSQL Software <http://www.lcsql.com>
Home of lcStackBrowser <http://www.lcsql.com/lcstackbrowser.html> and
SQLiteAdmin <http://www.lcsql.com/sqliteadmin.html>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: LC8 lineOffset

Mark Talluto
> On Oct 14, 2015, at 4:05 PM, Peter Haworth <[hidden email]> wrote:
>
> Has anyone run into problems using lineOffset in LC8?  I'm seeing it return
> an incorrect line number in some cases.
>
> I'm wondering if it could have something to do with the data I'm searching,
> since some lines have the characters \n embedded in them
>


It may be related to bug:  http://quality.runrev.com/show_bug.cgi?id=15512 <http://quality.runrev.com/show_bug.cgi?id=15512>


Best regards,

Mark Talluto
canelasoftware.com <http://canelasoftware.com/>
CassiaDB: The rapid development, free local storage database, made for LiveCode developers: livecloud.io <http://www.livecloud.io/>





_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: LC8 lineOffset

Charles Warwick

Do either of you have a sample stack you can send me that exhibits this problem?

I went to look at this a while back, but couldn't replicate it and there wasn't a sample stack in the bug report for me to try.


--
Sent from my iPhone

On 15 Oct 2015 at 09:28:18 AEST, Mark Talluto <[hidden email]> wrote:
   

> > On Oct 14, 2015, at 4:05 PM, Peter Haworth <[hidden email]> wrote:
> >
> > Has anyone run into problems using lineOffset in LC8?  I'm seeing it return
> > an incorrect line number in some cases.
> >
> > I'm wondering if it could have something to do with the data I'm searching,
> > since some lines have the characters \n embedded in them
> >
>
>
> It may be related to bug:  http://quality.runrev.com/show_bug.cgi?id=15512 <http://quality.runrev.com/show_bug.cgi?id=15512>
>
>
> Best regards,
>
> Mark Talluto
> canelasoftware.com <http://canelasoftware.com/>
> CassiaDB: The rapid development, free local storage database, made for LiveCode developers: livecloud.io <http://www.livecloud.io/>
>
>
>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: LC8 lineOffset

Peter Haworth
In reply to this post by Mark Talluto
Thanks Mark, I think it's the same bug, except on OSX.  I'm using the
linestoskip parameter of lineOffset as you were.  I'm using lineOffset in a
loop to return lines between a start and end line number.  I've worked
around the problem by deleting the lines after I've finished using them, so
the start line number is always 1.  For some reason it manages to get the
correct offset for the end line number that way.

Pete
lcSQL Software <http://www.lcsql.com>
Home of lcStackBrowser <http://www.lcsql.com/lcstackbrowser.html> and
SQLiteAdmin <http://www.lcsql.com/sqliteadmin.html>

On Wed, Oct 14, 2015 at 4:28 PM, Mark Talluto <[hidden email]>
wrote:

> > On Oct 14, 2015, at 4:05 PM, Peter Haworth <[hidden email]> wrote:
> >
> > Has anyone run into problems using lineOffset in LC8?  I'm seeing it
> return
> > an incorrect line number in some cases.
> >
> > I'm wondering if it could have something to do with the data I'm
> searching,
> > since some lines have the characters \n embedded in them
> >
>
>
> It may be related to bug:  http://quality.runrev.com/show_bug.cgi?id=15512
> <http://quality.runrev.com/show_bug.cgi?id=15512>
>
>
> Best regards,
>
> Mark Talluto
> canelasoftware.com <http://canelasoftware.com/>
> CassiaDB: The rapid development, free local storage database, made for
> LiveCode developers: livecloud.io <http://www.livecloud.io/>
>
>
>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: LC8 lineOffset

Peter Haworth
In reply to this post by Mark Talluto
I'd have to recreate the issue since I'm not using the workaround I just
posted.  But Mark posted several stacks that illustrate the problem to the
bug report.
Pete

Pete
lcSQL Software <http://www.lcsql.com>
Home of lcStackBrowser <http://www.lcsql.com/lcstackbrowser.html> and
SQLiteAdmin <http://www.lcsql.com/sqliteadmin.html>

On Wed, Oct 14, 2015 at 5:30 PM, Charles Warwick <
[hidden email]> wrote:

>
> Do either of you have a sample stack you can send me that exhibits this
> problem?
>
> I went to look at this a while back, but couldn't replicate it and there
> wasn't a sample stack in the bug report for me to try.
>
>
> --
> Sent from my iPhone
>
> On 15 Oct 2015 at 09:28:18 AEST, Mark Talluto <[hidden email]>
> wrote:
>
> > > On Oct 14, 2015, at 4:05 PM, Peter Haworth <[hidden email]> wrote:
> > >
> > > Has anyone run into problems using lineOffset in LC8?  I'm seeing it
> return
> > > an incorrect line number in some cases.
> > >
> > > I'm wondering if it could have something to do with the data I'm
> searching,
> > > since some lines have the characters \n embedded in them
> > >
> >
> >
> > It may be related to bug:
> http://quality.runrev.com/show_bug.cgi?id=15512 <
> http://quality.runrev.com/show_bug.cgi?id=15512>
> >
> >
> > Best regards,
> >
> > Mark Talluto
> > canelasoftware.com <http://canelasoftware.com/>
> > CassiaDB: The rapid development, free local storage database, made for
> LiveCode developers: livecloud.io <http://www.livecloud.io/>
> >
> >
> >
> >
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: LC8 lineOffset

Charles Warwick

I can't see a sample stack in the bug report (unless I'm reading it wrong). There are some additional attachments but it looks like the actual sample stack was emailed direct to LC.


--
Sent from my iPhone

On 15 Oct 2015 at 10:59:30 AEST, Peter Haworth <[hidden email]> wrote:
   

> I'd have to recreate the issue since I'm not using the workaround I just
> posted.  But Mark posted several stacks that illustrate the problem to the
> bug report.
> Pete
>
> Pete
> lcSQL Software <http://www.lcsql.com>
> Home of lcStackBrowser <http://www.lcsql.com/lcstackbrowser.html> and
> SQLiteAdmin <http://www.lcsql.com/sqliteadmin.html>
>
> On Wed, Oct 14, 2015 at 5:30 PM, Charles Warwick <
> [hidden email]> wrote:
>
> >
> > Do either of you have a sample stack you can send me that exhibits this
> > problem?
> >
> > I went to look at this a while back, but couldn't replicate it and there
> > wasn't a sample stack in the bug report for me to try.
> >
> >
> > --
> > Sent from my iPhone
> >
> > On 15 Oct 2015 at 09:28:18 AEST, Mark Talluto <[hidden email]>
> > wrote:
> >
> > > > On Oct 14, 2015, at 4:05 PM, Peter Haworth <[hidden email]> wrote:
> > > >
> > > > Has anyone run into problems using lineOffset in LC8?  I'm seeing it
> > return
> > > > an incorrect line number in some cases.
> > > >
> > > > I'm wondering if it could have something to do with the data I'm
> > searching,
> > > > since some lines have the characters \n embedded in them
> > > >
> > >
> > >
> > > It may be related to bug:
> > http://quality.runrev.com/show_bug.cgi?id=15512 <
> > http://quality.runrev.com/show_bug.cgi?id=15512>
> > >
> > >
> > > Best regards,
> > >
> > > Mark Talluto
> > > canelasoftware.com <http://canelasoftware.com/>
> > > CassiaDB: The rapid development, free local storage database, made for
> > LiveCode developers: livecloud.io <http://www.livecloud.io/>
> > >
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > use-livecode mailing list
> > > [hidden email]
> > > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: LC8 lineOffset

Mark Talluto
In reply to this post by Peter Haworth

> On Oct 14, 2015, at 5:58 PM, Peter Haworth <[hidden email]> wrote:
>
> Thanks Mark, I think it's the same bug, except on OSX.  I'm using the
> linestoskip parameter of lineOffset as you were.  I'm using lineOffset in a
> loop to return lines between a start and end line number.  I've worked
> around the problem by deleting the lines after I've finished using them, so
> the start line number is always 1.  For some reason it manages to get the
> correct offset for the end line number that way.

Hey Pete,

That is the problem right there. I was able to recreate our issue on a Mac as well. Hans works on a Windows system right now and reported the issue there.

Best regards,

Mark Talluto
canelasoftware.com <http://canelasoftware.com/>
CassiaDB: The rapid development, free local storage database, made for LiveCode developers: livecloud.io <http://www.livecloud.io/>





_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode