Linux CGI Missing a Library on Server

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Linux CGI Missing a Library on Server

Dan Shafer
I am trying to get Rev CGI scripting working at dreamhost.com, my new  
favorite hosting service.

I uploaded the Linux.x86 engine to the server, set its permissions  
per their instructions, and uploaded two known-good rev CGi scripts  
that work fine on my OS X Apache server.

It appears Rev is being invoked because it responds with an error.  
However, the error may indicate I just can't run Rev CGI on that  
server. Any clues?

the error says:

revolution: /lib/libc.so.6: version `GLIBC_2.3' not found (required  
by revolution)

I suppose it's possible they're not running an x86 Linux and that  
could be the whole problem.

Thanks.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Dan Shafer, Co-Chair
RevConWest '05
June 17-18, 2005, Monterey, California
http://www.altuit.com/webs/altuit/RevConWest

_______________________________________________
use-revolution mailing list
[hidden email]
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Linux CGI Missing a Library on Server

Richard Gaskin
Dan Shafer wrote:

> I am trying to get Rev CGI scripting working at dreamhost.com, my new  
> favorite hosting service.
>
> I uploaded the Linux.x86 engine to the server, set its permissions  per
> their instructions, and uploaded two known-good rev CGi scripts  that
> work fine on my OS X Apache server.
>
> It appears Rev is being invoked because it responds with an error.  
> However, the error may indicate I just can't run Rev CGI on that  
> server. Any clues?
>
> the error says:
>
> revolution: /lib/libc.so.6: version `GLIBC_2.3' not found (required  by
> revolution)
>
> I suppose it's possible they're not running an x86 Linux and that  could
> be the whole problem.

I don't believe RunRev produces a Yellow Dog build anymore, but if
you're getting enough of a response from the server to identify the
missing libs they're probably running x86.

For background on the libraries needed to support the engine on Linux:
<http://www.google.com/search?as_sitesearch=lists.runrev.com&num=20&as_q=linux+libraries+missing&Search=Search>


One of the reasons I've stayed with Tierra.net for so long is that they
maintain a server farm pre-configured specifically for running the Rev
engine, with all the libraries set up as needed.  They cost a little
more than discount hosting services, but for the convenience and stellar
service I've always found them to be a good value.

If anyone chooses to sign up with TierraNet, be sure to ask to be hosted
on server farm 2 for MetaCard support (I've been using them since before
the engine was acquired).

--
  Richard Gaskin
  Fourth World Media Corporation
  __________________________________________________
  Rev tools and more: http://www.fourthworld.com/rev
_______________________________________________
use-revolution mailing list
[hidden email]
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Linux CGI Missing a Library on Server

J. Landman Gay
In reply to this post by Dan Shafer
On 6/14/05 5:04 PM, Dan Shafer wrote:

> I am trying to get Rev CGI scripting working at dreamhost.com, my new  
> favorite hosting service.
>
> I uploaded the Linux.x86 engine to the server, set its permissions  per
> their instructions, and uploaded two known-good rev CGi scripts  that
> work fine on my OS X Apache server.
>
> It appears Rev is being invoked because it responds with an error.  
> However, the error may indicate I just can't run Rev CGI on that  
> server. Any clues?
>
> the error says:
>
> revolution: /lib/libc.so.6: version `GLIBC_2.3' not found (required  by
> revolution)
>
> I suppose it's possible they're not running an x86 Linux and that  could
> be the whole problem.

That's really common (only usually there are two missing.) They are
supposed to be included with your ISP's installation of Apache. But not
all ISPs will install those two so you have to ask them to do it. The
Rev engine checks for certain libraries and won't start up without them.
The odd thing is, the engine doesn't ever *read* those files, so -- I
was told -- your ISP can even just put in blank text files as long as
they have the same names. If they won't do it, then your only choice is
to take your business elsewhere.

It happened to me, and I moved. JaguarPC. You don't have to ask for
anything special, their standard installation has everything Rev needs.

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com
_______________________________________________
use-revolution mailing list
[hidden email]
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Linux CGI Missing a Library on Server

Damien Girard
In reply to this post by Dan Shafer
If you can install softwares on your web server, just install glibc and
Runrev will work.

Damien Girard
Email: [hidden email]

Le mardi 14 juin 2005 ?? 15:04 -0700, Dan Shafer a ??crit :

> I am trying to get Rev CGI scripting working at dreamhost.com, my new  
> favorite hosting service.
>
> I uploaded the Linux.x86 engine to the server, set its permissions  
> per their instructions, and uploaded two known-good rev CGi scripts  
> that work fine on my OS X Apache server.
>
> It appears Rev is being invoked because it responds with an error.  
> However, the error may indicate I just can't run Rev CGI on that  
> server. Any clues?
>
> the error says:
>
> revolution: /lib/libc.so.6: version `GLIBC_2.3' not found (required  
> by revolution)
>
> I suppose it's possible they're not running an x86 Linux and that  
> could be the whole problem.
>
> Thanks.
>
>
>
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Dan Shafer, Co-Chair
> RevConWest '05
> June 17-18, 2005, Monterey, California
> http://www.altuit.com/webs/altuit/RevConWest
>
> _______________________________________________
> use-revolution mailing list
> [hidden email]
> http://lists.runrev.com/mailman/listinfo/use-revolution

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution