No screenshot from LC video possible

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

No screenshot from LC video possible

Richmond Mathewson via use-livecode
Hello,

LC 8.1.4, Windows 10

I am using the standard LC videoPayer (directShow) to play H.264 mp4 videos.
One essential feature of my program is, that the user can take screenshots
from the video, edit and save them.

Today I got the second customer call with a Win 10 machine, who can't take
screenshots from my LC videos. The video screen is just black on the taken
screenshot. This issue does not only happen with the build in LiveCode
screenshot feature, but also, if they take a screenshot with the windows
print key or other screenshot tools.

Up to now, this issue happens only at 2 customers, on all other Win 10
machines, taking a video screenshot works fine. The alwaysBuffer of the
videoPlayer is set to false (setting it to true, I don't see any video
playing) I also checked to disable the Kaspersky AV on the client computer
(Kaspersky has a feature to prevent screenshots), but without success. Btw.
the old version of my program with the quicktime player works fine on these
machines.

I googled a lot, but didn't found any related issues in the net, so I
assume, it must be related to the LiveCode implementation of the directShow
videoPlayer. But in combination with any special hardware or software
setting on these two computers.

Has anybody already experienced similar issues or has any shot in the dark,
what system options, drivers, other tools in combination with LiveCode could
have an influence on taking a screenshot?

Any idea, what I could check for is welcome

Tiemo

 

 

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No screenshot from LC video possible

Richmond Mathewson via use-livecode
My guess is that it could be Digital Rights Management related?

If you can screenshot a DRM protected video then, in principle, you
could screenshot every frame and encode the frames back into a DRM-free
version of the video. Do you know what the videos that had the problem were?


On 7/11/2017 3:20 AM, Tiemo Hollmann TB via use-livecode wrote:

> Hello,
>
> LC 8.1.4, Windows 10
>
> I am using the standard LC videoPayer (directShow) to play H.264 mp4 videos.
> One essential feature of my program is, that the user can take screenshots
> from the video, edit and save them.
>
> Today I got the second customer call with a Win 10 machine, who can't take
> screenshots from my LC videos. The video screen is just black on the taken
> screenshot. This issue does not only happen with the build in LiveCode
> screenshot feature, but also, if they take a screenshot with the windows
> print key or other screenshot tools.
>
> Up to now, this issue happens only at 2 customers, on all other Win 10
> machines, taking a video screenshot works fine. The alwaysBuffer of the
> videoPlayer is set to false (setting it to true, I don't see any video
> playing) I also checked to disable the Kaspersky AV on the client computer
> (Kaspersky has a feature to prevent screenshots), but without success. Btw.
> the old version of my program with the quicktime player works fine on these
> machines.
>
> I googled a lot, but didn't found any related issues in the net, so I
> assume, it must be related to the LiveCode implementation of the directShow
> videoPlayer. But in combination with any special hardware or software
> setting on these two computers.
>
> Has anybody already experienced similar issues or has any shot in the dark,
> what system options, drivers, other tools in combination with LiveCode could
> have an influence on taking a screenshot?
>
> Any idea, what I could check for is welcome
>
> Tiemo
>
>  
>
>  
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No screenshot from LC video possible

Richmond Mathewson via use-livecode
I don't think it's DRM since the OP also said, " Up to now, this issue
happens only at 2 customers, on all other Win 10 machines, taking a video
screenshot works fine."

I'll place my 2 cent bet on the video card.  Look for a common thread like
- the fails happening on Nvidia, ATI, or built-in graphics controllers.

~Roger

On Jul 11, 2017 7:12 AM, "Paul Dupuis via use-livecode" <
[hidden email]> wrote:

> My guess is that it could be Digital Rights Management related?
>
> If you can screenshot a DRM protected video then, in principle, you
> could screenshot every frame and encode the frames back into a DRM-free
> version of the video. Do you know what the videos that had the problem
> were?
>
>
> On 7/11/2017 3:20 AM, Tiemo Hollmann TB via use-livecode wrote:
> > Hello,
> >
> > LC 8.1.4, Windows 10
> >
> > I am using the standard LC videoPayer (directShow) to play H.264 mp4
> videos.
> > One essential feature of my program is, that the user can take
> screenshots
> > from the video, edit and save them.
> >
> > Today I got the second customer call with a Win 10 machine, who can't
> take
> > screenshots from my LC videos. The video screen is just black on the
> taken
> > screenshot. This issue does not only happen with the build in LiveCode
> > screenshot feature, but also, if they take a screenshot with the windows
> > print key or other screenshot tools.
> >
> > Up to now, this issue happens only at 2 customers, on all other Win 10
> > machines, taking a video screenshot works fine. The alwaysBuffer of the
> > videoPlayer is set to false (setting it to true, I don't see any video
> > playing) I also checked to disable the Kaspersky AV on the client
> computer
> > (Kaspersky has a feature to prevent screenshots), but without success.
> Btw.
> > the old version of my program with the quicktime player works fine on
> these
> > machines.
> >
> > I googled a lot, but didn't found any related issues in the net, so I
> > assume, it must be related to the LiveCode implementation of the
> directShow
> > videoPlayer. But in combination with any special hardware or software
> > setting on these two computers.
> >
> > Has anybody already experienced similar issues or has any shot in the
> dark,
> > what system options, drivers, other tools in combination with LiveCode
> could
> > have an influence on taking a screenshot?
> >
> > Any idea, what I could check for is welcome
> >
> > Tiemo
> >
> >
> >
> >
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No screenshot from LC video possible

Richmond Mathewson via use-livecode
In reply to this post by Richmond Mathewson via use-livecode
May be connected to fullscreen mode (=black) or windowed mode (=working).

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: No screenshot from LC video possible

Richmond Mathewson via use-livecode
Hi Paul, Roger and Hermann,
No DRM involved, all videos are self produced and as Roger said, on most
machines they are playing fine.
The video never is fullscreen, because it is played in a frame within my LC
program.
The video card and it's handling of the video buffer is also my guess, but
up to now, I didn't found an exotic video card on the customer machines and
no thread about issues capturing video screenshots.
Thanks for your brainstorms
Tiemo


-----Urspr√ľngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag
von hh via use-livecode
Gesendet: Dienstag, 11. Juli 2017 13:50
An: [hidden email]
Cc: hh <[hidden email]>
Betreff: Re: No screenshot from LC video possible

May be connected to fullscreen mode (=black) or windowed mode (=working).

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: No screenshot from LC video possible

Richmond Mathewson via use-livecode
Although this is for a browser and recommended for use by some banks.  I have used this "app/plugin" before on Windows and it does prevent screenshots from taking place.

https://www.trusteer.com/en/support/rapport-installation-links 

I don't know if it would interfere with Livecode, but it might be little program like this causing you some pain.

Paul


-----Original Message-----
From: use-livecode [mailto:[hidden email]] On Behalf Of Tiemo Hollmann TB via use-livecode
Sent: 11 July 2017 14:45
To: 'How to use LiveCode' <[hidden email]>
Cc: Tiemo Hollmann TB <[hidden email]>
Subject: AW: No screenshot from LC video possible

Hi Paul, Roger and Hermann,
No DRM involved, all videos are self produced and as Roger said, on most machines they are playing fine.
The video never is fullscreen, because it is played in a frame within my LC program.
The video card and it's handling of the video buffer is also my guess, but up to now, I didn't found an exotic video card on the customer machines and no thread about issues capturing video screenshots.
Thanks for your brainstorms
Tiemo


-----Urspr√ľngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag von hh via use-livecode
Gesendet: Dienstag, 11. Juli 2017 13:50
An: [hidden email]
Cc: hh <[hidden email]>
Betreff: Re: No screenshot from LC video possible

May be connected to fullscreen mode (=black) or windowed mode (=working).

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Loading...