Performance issue with groups

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Performance issue with groups

JosepM
Hi,

I experimented a slow (very) slow performance when I grouped the fields of one card into 4 groups showing one of each as required. But the problem seems that isn't show and hide the groups, the problem is located when click the datagrid and then the fields of the visible group are showed. if I ungroup the 4 groups and show all the fields at same time the performance is the normal.

Any idea why?


Salut,
Josep
Reply | Threaded
Open this post in threaded view
|

Re: Performance issue with groups

Geoff Canyon Rev
My guess would be screen updates -- lock screen before you show/hide and see
if the delay goes away.

On Thu, Feb 17, 2011 at 5:50 PM, JosepM <[hidden email]> wrote:

>
> Hi,
>
> I experimented a slow (very) slow performance when I grouped the fields of
> one card into 4 groups showing one of each as required. But the problem
> seems that isn't show and hide the groups, the problem is located when
> click
> the datagrid and then the fields of the visible group are showed. if I
> ungroup the 4 groups and show all the fields at same time the performance
> is
> the normal.
>
> Any idea why?
>
>
> Salut,
> Josep
> --
> View this message in context:
> http://runtime-revolution.278305.n4.nabble.com/Performance-issue-with-groups-tp3311867p3311867.html
> Sent from the Revolution - User mailing list archive at Nabble.com.
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Performance issue with groups

JosepM
Yes, with lock screen the performance is the normal. But why this big difference to group the fields into 4 groups?

Salut,
Josep
Reply | Threaded
Open this post in threaded view
|

Re: Performance issue with groups

Geoff Canyon Rev
Not sure what's specifically going on in your case, but any time you work
with fields the engine works to render all the text whenever something
changes. It can really add up.

gc


On Fri, Feb 18, 2011 at 2:43 AM, JosepM <[hidden email]> wrote:

>
> Yes, with lock screen the performance is the normal. But why this big
> difference to group the fields into 4 groups?
>
> Salut,
> Josep
> --
> View this message in context:
> http://runtime-revolution.278305.n4.nabble.com/Performance-issue-with-groups-tp3311867p3312216.html
> Sent from the Revolution - User mailing list archive at Nabble.com.
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode