Playing Sound question

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Playing Sound question

Wprothero
Folks:
I have an app that I am building for mobile. In previous versions of LC, I used the
mobilePlaySoundOnChannel
command and its associated control commands. I play an mp3 file.
This no longer works on LC8.1 (at least on the simulator) in the latest iOS version.

I have two looping sounds that are background and another sound containing instructions, that play over the looping background sound. To do this, I’ve created 3 players and each plays one of the sounds.

So, does the player widget work on iOS too? I can get it working in the IDE. There are numerous sound play commands listed in the dictionary and it’s very confusing which ones apply to the new avFoundation player.

Could someone enlighten me. Do I need 3 players, or are there channels in the avFoundation player? Will the avFoundation player play in iOS? Are the mobilePlaySoundOnChannel commands deprecated or am I just getting confused because they don’t work in the simulator?

Best,
Bill

William Prothero, Ph.D.
University of California, Santa Barbara, Emeritus
[hidden email]



_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Http://es.earthednet.org
Reply | Threaded
Open this post in threaded view
|

Re: Playing Sound question

Wprothero
I made a test stack with 3 players. BUT, I can’t find a property to set the volume level of the players. Is there a way to set the play volume?
Bill


> On Sep 15, 2016, at 5:11 PM, William Prothero <[hidden email]> wrote:
>
> Folks:
> I have an app that I am building for mobile. In previous versions of LC, I used the
> mobilePlaySoundOnChannel
> command and its associated control commands. I play an mp3 file.
> This no longer works on LC8.1 (at least on the simulator) in the latest iOS version.
>
> I have two looping sounds that are background and another sound containing instructions, that play over the looping background sound. To do this, I’ve created 3 players and each plays one of the sounds.
>
> So, does the player widget work on iOS too? I can get it working in the IDE. There are numerous sound play commands listed in the dictionary and it’s very confusing which ones apply to the new avFoundation player.
>
> Could someone enlighten me. Do I need 3 players, or are there channels in the avFoundation player? Will the avFoundation player play in iOS? Are the mobilePlaySoundOnChannel commands deprecated or am I just getting confused because they don’t work in the simulator?
>
> Best,
> Bill
>
> William Prothero, Ph.D.
> University of California, Santa Barbara, Emeritus
> [hidden email]
>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Http://es.earthednet.org
Reply | Threaded
Open this post in threaded view
|

Re: Playing Sound question

Wprothero
Ok, answered my own question. Set the playLoudness of player “playername” to “a percentage between 0 and 100”

It would be nice if that property was mentioned in the player object dictionary entry.
Best,
Bill

> On Sep 15, 2016, at 5:30 PM, William Prothero <[hidden email]> wrote:
>
> I made a test stack with 3 players. BUT, I can’t find a property to set the volume level of the players. Is there a way to set the play volume?
> Bill
>
>
>> On Sep 15, 2016, at 5:11 PM, William Prothero <[hidden email]> wrote:
>>
>> Folks:
>> I have an app that I am building for mobile. In previous versions of LC, I used the
>> mobilePlaySoundOnChannel
>> command and its associated control commands. I play an mp3 file.
>> This no longer works on LC8.1 (at least on the simulator) in the latest iOS version.
>>
>> I have two looping sounds that are background and another sound containing instructions, that play over the looping background sound. To do this, I’ve created 3 players and each plays one of the sounds.
>>
>> So, does the player widget work on iOS too? I can get it working in the IDE. There are numerous sound play commands listed in the dictionary and it’s very confusing which ones apply to the new avFoundation player.
>>
>> Could someone enlighten me. Do I need 3 players, or are there channels in the avFoundation player? Will the avFoundation player play in iOS? Are the mobilePlaySoundOnChannel commands deprecated or am I just getting confused because they don’t work in the simulator?
>>
>> Best,
>> Bill
>>
>> William Prothero, Ph.D.
>> University of California, Santa Barbara, Emeritus
>> [hidden email]
>>
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Http://es.earthednet.org
Reply | Threaded
Open this post in threaded view
|

Re: Playing Sound question

Wprothero
Last thing to do: get it working in iOS. The avPlayer object doesn’t work for me in the simulator. I’ll have to experiment further.

If anybody has any suggestions of which command to use, plse comment. I’m done for the day.
Otherwise, I’ll fumble around in the dictionary until I find something that works.

I’m making a test stack that I’ll share when I’m done.
Best,
Bill

> On Sep 15, 2016, at 5:36 PM, William Prothero <[hidden email]> wrote:
>
> Ok, answered my own question. Set the playLoudness of player “playername” to “a percentage between 0 and 100”
>
> It would be nice if that property was mentioned in the player object dictionary entry.
> Best,
> Bill
>
>> On Sep 15, 2016, at 5:30 PM, William Prothero <[hidden email]> wrote:
>>
>> I made a test stack with 3 players. BUT, I can’t find a property to set the volume level of the players. Is there a way to set the play volume?
>> Bill
>>
>>
>>> On Sep 15, 2016, at 5:11 PM, William Prothero <[hidden email]> wrote:
>>>
>>> Folks:
>>> I have an app that I am building for mobile. In previous versions of LC, I used the
>>> mobilePlaySoundOnChannel
>>> command and its associated control commands. I play an mp3 file.
>>> This no longer works on LC8.1 (at least on the simulator) in the latest iOS version.
>>>
>>> I have two looping sounds that are background and another sound containing instructions, that play over the looping background sound. To do this, I’ve created 3 players and each plays one of the sounds.
>>>
>>> So, does the player widget work on iOS too? I can get it working in the IDE. There are numerous sound play commands listed in the dictionary and it’s very confusing which ones apply to the new avFoundation player.
>>>
>>> Could someone enlighten me. Do I need 3 players, or are there channels in the avFoundation player? Will the avFoundation player play in iOS? Are the mobilePlaySoundOnChannel commands deprecated or am I just getting confused because they don’t work in the simulator?
>>>
>>> Best,
>>> Bill
>>>
>>> William Prothero, Ph.D.
>>> University of California, Santa Barbara, Emeritus
>>> [hidden email]
>>>
>>>
>>>
>>> _______________________________________________
>>> use-livecode mailing list
>>> [hidden email]
>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Http://es.earthednet.org
Reply | Threaded
Open this post in threaded view
|

Re: Playing Sound question

Wprothero
Folks:
I have a small sample stack that plays audio on desktop and iOS. I haven’t debugged in on Android or Windows, but if anybody would like to see it, here is the link.

https://www.dropbox.com/s/aqnlgzph5x5h23l/PlaySound Tests.zip?dl=0 <https://www.dropbox.com/s/aqnlgzph5x5h23l/PlaySound%20Tests.zip?dl=0>

It’s very simple, but for those who are not familiar with playing sounds in version 8, it may save you some time.
Best,
Bill

> On Sep 15, 2016, at 5:49 PM, William Prothero <[hidden email]> wrote:
>
> Last thing to do: get it working in iOS. The avPlayer object doesn’t work for me in the simulator. I’ll have to experiment further.
>
> If anybody has any suggestions of which command to use, plse comment. I’m done for the day.
> Otherwise, I’ll fumble around in the dictionary until I find something that works.
>
> I’m making a test stack that I’ll share when I’m done.
> Best,
> Bill
>
>> On Sep 15, 2016, at 5:36 PM, William Prothero <[hidden email]> wrote:
>>
>> Ok, answered my own question. Set the playLoudness of player “playername” to “a percentage between 0 and 100”
>>
>> It would be nice if that property was mentioned in the player object dictionary entry.
>> Best,
>> Bill
>>
>>> On Sep 15, 2016, at 5:30 PM, William Prothero <[hidden email]> wrote:
>>>
>>> I made a test stack with 3 players. BUT, I can’t find a property to set the volume level of the players. Is there a way to set the play volume?
>>> Bill
>>>
>>>
>>>> On Sep 15, 2016, at 5:11 PM, William Prothero <[hidden email]> wrote:
>>>>
>>>> Folks:
>>>> I have an app that I am building for mobile. In previous versions of LC, I used the
>>>> mobilePlaySoundOnChannel
>>>> command and its associated control commands. I play an mp3 file.
>>>> This no longer works on LC8.1 (at least on the simulator) in the latest iOS version.
>>>>
>>>> I have two looping sounds that are background and another sound containing instructions, that play over the looping background sound. To do this, I’ve created 3 players and each plays one of the sounds.
>>>>
>>>> So, does the player widget work on iOS too? I can get it working in the IDE. There are numerous sound play commands listed in the dictionary and it’s very confusing which ones apply to the new avFoundation player.
>>>>
>>>> Could someone enlighten me. Do I need 3 players, or are there channels in the avFoundation player? Will the avFoundation player play in iOS? Are the mobilePlaySoundOnChannel commands deprecated or am I just getting confused because they don’t work in the simulator?
>>>>
>>>> Best,
>>>> Bill
>>>>
>>>> William Prothero, Ph.D.
>>>> University of California, Santa Barbara, Emeritus
>>>> [hidden email]
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> use-livecode mailing list
>>>> [hidden email]
>>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>
>>>
>>> _______________________________________________
>>> use-livecode mailing list
>>> [hidden email]
>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Http://es.earthednet.org
Reply | Threaded
Open this post in threaded view
|

Re: Playing Sound question

Rick Harrison
Hi Bill,

Thanks for the meditation! LOL

Rick

> On Sep 16, 2016, at 7:45 PM, William Prothero <[hidden email]> wrote:
>
> Folks:
> I have a small sample stack that plays audio on desktop and iOS. I haven’t debugged in on Android or Windows, but if anybody would like to see it, here is the link.
>
> https://www.dropbox.com/s/aqnlgzph5x5h23l/PlaySound Tests.zip?dl=0 <https://www.dropbox.com/s/aqnlgzph5x5h23l/PlaySound%20Tests.zip?dl=0>
>
> It’s very simple, but for those who are not familiar with playing sounds in version 8, it may save you some time.
> Best,
> Bill
>
>> On Sep 15, 2016, at 5:49 PM, William Prothero <[hidden email]> wrote:
>>
>> Last thing to do: get it working in iOS. The avPlayer object doesn’t work for me in the simulator. I’ll have to experiment further.
>>
>> If anybody has any suggestions of which command to use, plse comment. I’m done for the day.
>> Otherwise, I’ll fumble around in the dictionary until I find something that works.
>>
>> I’m making a test stack that I’ll share when I’m done.
>> Best,
>> Bill
>>
>>> On Sep 15, 2016, at 5:36 PM, William Prothero <[hidden email]> wrote:
>>>
>>> Ok, answered my own question. Set the playLoudness of player “playername” to “a percentage between 0 and 100”
>>>
>>> It would be nice if that property was mentioned in the player object dictionary entry.
>>> Best,
>>> Bill
>>>
>>>> On Sep 15, 2016, at 5:30 PM, William Prothero <[hidden email]> wrote:
>>>>
>>>> I made a test stack with 3 players. BUT, I can’t find a property to set the volume level of the players. Is there a way to set the play volume?
>>>> Bill
>>>>
>>>>
>>>>> On Sep 15, 2016, at 5:11 PM, William Prothero <[hidden email]> wrote:
>>>>>
>>>>> Folks:
>>>>> I have an app that I am building for mobile. In previous versions of LC, I used the
>>>>> mobilePlaySoundOnChannel
>>>>> command and its associated control commands. I play an mp3 file.
>>>>> This no longer works on LC8.1 (at least on the simulator) in the latest iOS version.
>>>>>
>>>>> I have two looping sounds that are background and another sound containing instructions, that play over the looping background sound. To do this, I’ve created 3 players and each plays one of the sounds.
>>>>>
>>>>> So, does the player widget work on iOS too? I can get it working in the IDE. There are numerous sound play commands listed in the dictionary and it’s very confusing which ones apply to the new avFoundation player.
>>>>>
>>>>> Could someone enlighten me. Do I need 3 players, or are there channels in the avFoundation player? Will the avFoundation player play in iOS? Are the mobilePlaySoundOnChannel commands deprecated or am I just getting confused because they don’t work in the simulator?
>>>>>
>>>>> Best,
>>>>> Bill
>>>>>
>>>>> William Prothero, Ph.D.
>>>>> University of California, Santa Barbara, Emeritus
>>>>> [hidden email]
>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> use-livecode mailing list
>>>>> [hidden email]
>>>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>>
>>>>
>>>> _______________________________________________
>>>> use-livecode mailing list
>>>> [hidden email]
>>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>
>>>
>>> _______________________________________________
>>> use-livecode mailing list
>>> [hidden email]
>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Playing Sound question

Wprothero
Rick,
It's for an update of a very simple app that plays a collection of sound files of yoga poses in a user defined order, with settable pauses containing only background sounds. It's for my own use for a yoga experience I share with my friends. I made it as an intro to making an iOS app. The recent update of the iOS made my previous version crash, tho so I am redoing it in lc8. The biggest challenge is dealing with the certificate and provisioning challenges that always seem to take a full day to sort out.

I really should make the example I shared look better in the iOS simulator, tho. The basic code is a start.

Best,
Bill

William Prothero
http://es.earthednet.org

> On Sep 17, 2016, at 7:08 AM, Rick Harrison <[hidden email]> wrote:
>
> Hi Bill,
>
> Thanks for the meditation! LOL
>
> Rick
>
>> On Sep 16, 2016, at 7:45 PM, William Prothero <[hidden email]> wrote:
>>
>> Folks:
>> I have a small sample stack that plays audio on desktop and iOS. I haven’t debugged in on Android or Windows, but if anybody would like to see it, here is the link.
>>
>> https://www.dropbox.com/s/aqnlgzph5x5h23l/PlaySound Tests.zip?dl=0 <https://www.dropbox.com/s/aqnlgzph5x5h23l/PlaySound%20Tests.zip?dl=0>
>>
>> It’s very simple, but for those who are not familiar with playing sounds in version 8, it may save you some time.
>> Best,
>> Bill
>>
>>> On Sep 15, 2016, at 5:49 PM, William Prothero <[hidden email]> wrote:
>>>
>>> Last thing to do: get it working in iOS. The avPlayer object doesn’t work for me in the simulator. I’ll have to experiment further.
>>>
>>> If anybody has any suggestions of which command to use, plse comment. I’m done for the day.
>>> Otherwise, I’ll fumble around in the dictionary until I find something that works.
>>>
>>> I’m making a test stack that I’ll share when I’m done.
>>> Best,
>>> Bill
>>>
>>>> On Sep 15, 2016, at 5:36 PM, William Prothero <[hidden email]> wrote:
>>>>
>>>> Ok, answered my own question. Set the playLoudness of player “playername” to “a percentage between 0 and 100”
>>>>
>>>> It would be nice if that property was mentioned in the player object dictionary entry.
>>>> Best,
>>>> Bill
>>>>
>>>>> On Sep 15, 2016, at 5:30 PM, William Prothero <[hidden email]> wrote:
>>>>>
>>>>> I made a test stack with 3 players. BUT, I can’t find a property to set the volume level of the players. Is there a way to set the play volume?
>>>>> Bill
>>>>>
>>>>>
>>>>>> On Sep 15, 2016, at 5:11 PM, William Prothero <[hidden email]> wrote:
>>>>>>
>>>>>> Folks:
>>>>>> I have an app that I am building for mobile. In previous versions of LC, I used the
>>>>>> mobilePlaySoundOnChannel
>>>>>> command and its associated control commands. I play an mp3 file.
>>>>>> This no longer works on LC8.1 (at least on the simulator) in the latest iOS version.
>>>>>>
>>>>>> I have two looping sounds that are background and another sound containing instructions, that play over the looping background sound. To do this, I’ve created 3 players and each plays one of the sounds.
>>>>>>
>>>>>> So, does the player widget work on iOS too? I can get it working in the IDE. There are numerous sound play commands listed in the dictionary and it’s very confusing which ones apply to the new avFoundation player.
>>>>>>
>>>>>> Could someone enlighten me. Do I need 3 players, or are there channels in the avFoundation player? Will the avFoundation player play in iOS? Are the mobilePlaySoundOnChannel commands deprecated or am I just getting confused because they don’t work in the simulator?
>>>>>>
>>>>>> Best,
>>>>>> Bill
>>>>>>
>>>>>> William Prothero, Ph.D.
>>>>>> University of California, Santa Barbara, Emeritus
>>>>>> [hidden email]
>>>>>>
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> use-livecode mailing list
>>>>>> [hidden email]
>>>>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> use-livecode mailing list
>>>>> [hidden email]
>>>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>>
>>>>
>>>> _______________________________________________
>>>> use-livecode mailing list
>>>> [hidden email]
>>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>
>>>
>>> _______________________________________________
>>> use-livecode mailing list
>>> [hidden email]
>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Http://es.earthednet.org