Relayering Controls in 9 dp5 problematic?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Relayering Controls in 9 dp5 problematic?

Bob Sneidar via use-livecode
layout card
make some controls
click on prop inspector
try to set the layer of fld now set to layer 6

nothing happens, IDE "blinks" are resets the field to 6

select fld; object menu, arrange, send back… now it works

property inspector is not updated.  use revApplicationOverview, click on a control button "whatever" and instead we get inspector for fld "title" even thought control button is highlighted.

Go back to Project Browser. Hmm… one control I tried to set to layer 2, does now in fact as layer 2

three of these controls were previously in a group. I ungrouped them theoretically that group is now "gone" from the stack…

relayerGroupControls is true (even though there is no group on the card)… still cannot relayer some objects?

What other conditions will "lock" a control into a specific layer?

Anyone else struggling with this?

BR
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Relayering Controls in 9 dp5 problematic?

Bob Sneidar via use-livecode
I think there was a bug in dp5 with respect to relayering... It was either fixed in dp6 or will be in dp7 (when that finally appears!).

Mark.

Sent from my iPhone

> On 7 May 2017, at 03:43, Sannyasin Brahmanathaswami via use-livecode <[hidden email]> wrote:
>
> layout card
> make some controls
> click on prop inspector
> try to set the layer of fld now set to layer 6
>
> nothing happens, IDE "blinks" are resets the field to 6
>
> select fld; object menu, arrange, send back… now it works
>
> property inspector is not updated.  use revApplicationOverview, click on a control button "whatever" and instead we get inspector for fld "title" even thought control button is highlighted.
>
> Go back to Project Browser. Hmm… one control I tried to set to layer 2, does now in fact as layer 2
>
> three of these controls were previously in a group. I ungrouped them theoretically that group is now "gone" from the stack…
>
> relayerGroupControls is true (even though there is no group on the card)… still cannot relayer some objects?
>
> What other conditions will "lock" a control into a specific layer?
>
> Anyone else struggling with this?
>
> BR
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Relayering Controls in 9 dp5 problematic?

Bob Sneidar via use-livecode
Hi all,

This is the bug:

http://quality.livecode.com/show_bug.cgi?id=19349

which will be fixed in LC 9 DP7.

Best,
Panos
--

On Sun, May 7, 2017 at 12:36 PM, Mark Waddingham via use-livecode <
[hidden email]> wrote:

> I think there was a bug in dp5 with respect to relayering... It was either
> fixed in dp6 or will be in dp7 (when that finally appears!).
>
> Mark.
>
> Sent from my iPhone
>
> > On 7 May 2017, at 03:43, Sannyasin Brahmanathaswami via use-livecode <
> [hidden email]> wrote:
> >
> > layout card
> > make some controls
> > click on prop inspector
> > try to set the layer of fld now set to layer 6
> >
> > nothing happens, IDE "blinks" are resets the field to 6
> >
> > select fld; object menu, arrange, send back… now it works
> >
> > property inspector is not updated.  use revApplicationOverview, click on
> a control button "whatever" and instead we get inspector for fld "title"
> even thought control button is highlighted.
> >
> > Go back to Project Browser. Hmm… one control I tried to set to layer 2,
> does now in fact as layer 2
> >
> > three of these controls were previously in a group. I ungrouped them
> theoretically that group is now "gone" from the stack…
> >
> > relayerGroupControls is true (even though there is no group on the
> card)… still cannot relayer some objects?
> >
> > What other conditions will "lock" a control into a specific layer?
> >
> > Anyone else struggling with this?
> >
> > BR
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode