Remote Debugger 9.6dp1?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Remote Debugger 9.6dp1?

Mark Wieder via use-livecode
I have Remote Debugger in the inclusions for making a mobile standalone
The Development Menu has checked "Script Debug Mode"

I put an explicit "breakpoint" in a handler; test (target) my iPhone.
Boot the app on the phone. The app hangs where I have the breakpoint.
But the script editor does not open, allowing us to step through the rest of the handler.

Is there something else to do? I could have sworn this worked on iOS before…

BR

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Remote Debugger 9.6dp1?

Mark Wieder via use-livecode
I haven't tried it with a separate standalone running independently, but
if I build directly to the device it works, at least on Android and the
iOS simulator.

On 11/30/19 8:27 PM, Sannyasin Brahmanathaswami via use-livecode wrote:

> I have Remote Debugger in the inclusions for making a mobile standalone
> The Development Menu has checked "Script Debug Mode"
>
> I put an explicit "breakpoint" in a handler; test (target) my iPhone.
> Boot the app on the phone. The app hangs where I have the breakpoint.
> But the script editor does not open, allowing us to step through the rest of the handler.
>
> Is there something else to do? I could have sworn this worked on iOS before…
>
> BR
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Remote Debugger 9.6dp1?

Mark Wieder via use-livecode
In reply to this post by Mark Wieder via use-livecode
Is the iPhone on the same local network as IDE?

> On 1 Dec 2019, at 1:27 pm, Sannyasin Brahmanathaswami via use-livecode <[hidden email]> wrote:
>
> I have Remote Debugger in the inclusions for making a mobile standalone
> The Development Menu has checked "Script Debug Mode"
>
> I put an explicit "breakpoint" in a handler; test (target) my iPhone.
> Boot the app on the phone. The app hangs where I have the breakpoint.
> But the script editor does not open, allowing us to step through the rest of the handler.
>
> Is there something else to do? I could have sworn this worked on iOS before…
>
> BR
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Remote Debugger 9.6dp1?

Mark Wieder via use-livecode
Yes, same local network, via wifi, but it is also plugged into an external dock with multiple ports. The dock itself goes into the new USB  "C" ports on the Mac Book Pro. (The only way I can see it among the test targets)

Is the iPhone on the same local network as IDE?

> On 1 Dec 2019, at 1:27 pm, Sannyasin Brahmanathaswami via use-livecode <[hidden email]<mailto:[hidden email]>> wrote:
>
> I have Remote Debugger in the inclusions for making a mobile standalone
> The Development Menu has checked "Script Debug Mode"
>
> I put an explicit "breakpoint" in a handler; test (target) my iPhone.
> Boot the app on the phone. The app hangs where I have the breakpoint.
> But the script editor does not open, allowing us to step through the rest of the handler.
>
> Is there something else to do? I could have sworn this worked on iOS before…
>
> BR
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode