Script colorization not working

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Script colorization not working

J. Landman Gay via use-livecode
Hi all,

One of my students is having a problem where the script colorization is not working completely. That is, the bold face style is applied for things like **on** mouseUp and **end** mouseUp, and commands are boldfaced. But nothing else is colorized.

We have checked all of her script editor preferences. Colorization is set to default.

There is nothing in the script editor menu that would affect this as far as I can tell.

My student likes script colorization and finds it very helpful, so she’s anxious to get it fixed.

Has anyone ever seen this? Any suggestions for how to fix it?

She’s on Mac, probably Catalina, LiveCode Community 9.6.1.

Devin


Devin Asay
Director
Office of Digital Humanities
Brigham Young University

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Script colorization not working

J. Landman Gay via use-livecode
Hello Devin,

A rough guess is that she is on Big Sur. There is a known issue where
colorization is lost if the default font (Source Code Pro) is used. If this
is the case, she can try switching to a different font, and the issue will
be fixed.

Kind regards,
Panos
--

On Wed, 18 Nov 2020 at 23:18, Devin Asay via use-livecode <
[hidden email]> wrote:

> Hi all,
>
> One of my students is having a problem where the script colorization is
> not working completely. That is, the bold face style is applied for things
> like **on** mouseUp and **end** mouseUp, and commands are boldfaced. But
> nothing else is colorized.
>
> We have checked all of her script editor preferences. Colorization is set
> to default.
>
> There is nothing in the script editor menu that would affect this as far
> as I can tell.
>
> My student likes script colorization and finds it very helpful, so she’s
> anxious to get it fixed.
>
> Has anyone ever seen this? Any suggestions for how to fix it?
>
> She’s on Mac, probably Catalina, LiveCode Community 9.6.1.
>
> Devin
>
>
> Devin Asay
> Director
> Office of Digital Humanities
> Brigham Young University
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Script colorization not working

J. Landman Gay via use-livecode
Thanks, Panos! I believe I did notice that she is using Source Code Pro. I’ll have her look into that.

Devin

> On Nov 18, 2020, at 2:26 PM, panagiotis merakos via use-livecode <[hidden email]> wrote:
>
> Hello Devin,
>
> A rough guess is that she is on Big Sur. There is a known issue where
> colorization is lost if the default font (Source Code Pro) is used. If this
> is the case, she can try switching to a different font, and the issue will
> be fixed.
>
> Kind regards,
> Panos
> --
>
> On Wed, 18 Nov 2020 at 23:18, Devin Asay via use-livecode <
> [hidden email]> wrote:
>
>> Hi all,
>>
>> One of my students is having a problem where the script colorization is
>> not working completely. That is, the bold face style is applied for things
>> like **on** mouseUp and **end** mouseUp, and commands are boldfaced. But
>> nothing else is colorized.
>>
>> We have checked all of her script editor preferences. Colorization is set
>> to default.
>>
>> There is nothing in the script editor menu that would affect this as far
>> as I can tell.
>>
>> My student likes script colorization and finds it very helpful, so she’s
>> anxious to get it fixed.
>>
>> Has anyone ever seen this? Any suggestions for how to fix it?
>>
>> She’s on Mac, probably Catalina, LiveCode Community 9.6.1.
>>
>> Devin
>>
>>
>> Devin Asay
>> Director
>> Office of Digital Humanities
>> Brigham Young University
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

Devin Asay
Director
Office of Digital Humanities
Brigham Young University

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Script colorization not working

J. Landman Gay via use-livecode
In reply to this post by J. Landman Gay via use-livecode
panagiotis merakos via use-livecode<https://www.mail-archive.com/search?l=use-livecode@...&q=from:%22panagiotis+merakos+via+use%5C-livecode%22> Wed, 18 Nov 2020 13:28:22 -0800<https://www.mail-archive.com/search?l=use-livecode@...&q=date:20201118>

Hello Devin,

A rough guess is that she is on Big Sur. There is a known issue where
colorization is lost if the default font (Source Code Pro) is used. If this
is the case, she can try switching to a different font, and the issue will
be fixed.

Kind regards,
Panos

It  seems there is a new release of Source Code Pro that removes an experimental offending "SVG table with colored glyphs" from the font that causes the problem on Big Sur.

https://github.com/adobe-fonts/source-code-pro/releases/tag/2.032R-ro%2F1.052R-it%2F1.012R-VAR

The discussiion of the problem is here

https://github.com/adobe-fonts/source-code-pro/issues/250

Kind regards
Bernd


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Script colorization not working

J. Landman Gay via use-livecode
In reply to this post by J. Landman Gay via use-livecode
Thanks Panos, and Bernd also for the tip on the new version of Source Code Pro.

The student was indeed using Source Code Pro, and when she changed to a different font for the script editor, it fixed the problem.

Devin


> On Nov 18, 2020, at 2:26 PM, panagiotis merakos via use-livecode <[hidden email]> wrote:
>
> Hello Devin,
>
> A rough guess is that she is on Big Sur. There is a known issue where
> colorization is lost if the default font (Source Code Pro) is used. If this
> is the case, she can try switching to a different font, and the issue will
> be fixed.
>
> Kind regards,
> Panos
> --
>
> On Wed, 18 Nov 2020 at 23:18, Devin Asay via use-livecode <
> [hidden email]> wrote:
>
>> Hi all,
>>
>> One of my students is having a problem where the script colorization is
>> not working completely. That is, the bold face style is applied for things
>> like **on** mouseUp and **end** mouseUp, and commands are boldfaced. But
>> nothing else is colorized.
>>
>> We have checked all of her script editor preferences. Colorization is set
>> to default.
>>
>> There is nothing in the script editor menu that would affect this as far
>> as I can tell.
>>
>> My student likes script colorization and finds it very helpful, so she’s
>> anxious to get it fixed.
>>
>> Has anyone ever seen this? Any suggestions for how to fix it?
>>
>> She’s on Mac, probably Catalina, LiveCode Community 9.6.1.
>>
>> Devin
>>
>>
>> Devin Asay
>> Director
>> Office of Digital Humanities
>> Brigham Young University
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

Devin Asay
Director
Office of Digital Humanities
Brigham Young University

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode