Segmented Control Bugs?

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

Segmented Control Bugs?

J. Landman Gay via use-livecode
Anyone experiencing any anomalies with the segmented control

Scenario

Added to stack in 8.1.7 (or earlier)
open stacks in 9.0.0 dp9  save
open in 8.2.0dp1  control is blank.

shut down LC

open again in 9.0.0dp9 it appears again, but has a bug.. it seems to be catching a mouse down message when the stack opens.. .even though none is issued. none of our code is firing any mouse event on start up of the stack but the widget acts as though it received a clicked on one of the tabs.

Seems to be some major differences in this control between 8 and 9

is it even safe to use?

BR


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
Hi BR,

The main difference between the segmented control between LC 8.x and 9.0 is
that:

- In LC 8.x you can select **exactly** one segment
- In LC 9 this has changed (--> enhanced) and you can select 0 or more
segments

See the properties "toggleHilites" and "multipleHilites" in LC 9.0 DP-9.

Note that there is currently a bug in LC 9.0 DP-9, which will be fixed in
the next release:

http://quality.livecode.com/show_bug.cgi?id=20461

Best regards,
Panos
--




On Tue, Oct 3, 2017 at 3:37 AM, Sannyasin Brahmanathaswami via use-livecode
<[hidden email]> wrote:

> Anyone experiencing any anomalies with the segmented control
>
> Scenario
>
> Added to stack in 8.1.7 (or earlier)
> open stacks in 9.0.0 dp9  save
> open in 8.2.0dp1  control is blank.
>
> shut down LC
>
> open again in 9.0.0dp9 it appears again, but has a bug.. it seems to be
> catching a mouse down message when the stack opens.. .even though none is
> issued. none of our code is firing any mouse event on start up of the stack
> but the widget acts as though it received a clicked on one of the tabs.
>
> Seems to be some major differences in this control between 8 and 9
>
> is it even safe to use?
>
> BR
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
Hmm the bug I have is a bit different… appears in both 8 and 9

I "deprecated" the control by moving it to -2000,-2000 and used the "old-fashioned way" of three buttons in group/get the target and go.  save… went off for some other work.. came back

Then  every time the stack opens, the script of the widget at -2000,-2000 would receive what I thought was a custom message (because we were sending it on mouseup)_

on hiliteChanged
   put the hilitedItemNames of me into tName
   put tName into sPreviousSelection
   answer tName with "OK"
    DoSomething  
end hiliteChanged

on doSomething
  answer "command issued" with "OK"
end doSomething

Though obvious in function,  "hiliteChanged"  is not a documented property of the segmented control


so I copied the three segment control to a brand new stack,

three tabs/names

 Favorites | Activity | Date

reduced the longer script to the above very simple test. saved and close the stack…

now I reopen the stack and the answer dialog is trigged on open stack.. the control is "hearing" the openstack message as a change of hilite.  the tName was empty.  OK so I select "Activity" which then become hilited. save the stack, close and reopen… bingo it fires the dialog with

Activity  
OK

and in our larger framework… it was "getting worse" as somehow this segmented control widget on stack A was still receiving that message even when stack B was opened, if stack A with the widget on it's top card was still open "behind" Stack B…  and I clicked on a widget/icon in stack B that had it's hiliite set to toggle (I usually turn them off) the script editor would fire with an error in the script of the widget appearing, "like out of nowhere" (because its stack is behind the scenes) with a break at "doSomething" …can't find the command "doSomething"

almost as if the widget had become some global or backscript in the brain of the IDE.  

I don't have time for more forensics. Lost nearly literally 6 hours on this… so I have just removed it from the stack. Old method may not look as good across platforms, but it works.

moving on…


 

On 10/2/17, 11:58 PM, "use-livecode on behalf of panagiotis merakos via use-livecode" <[hidden email] on behalf of [hidden email]> wrote:

    Hi BR,
   
    The main difference between the segmented control between LC 8.x and 9.0 is
    that:
   
    - In LC 8.x you can select **exactly** one segment
    - In LC 9 this has changed (--> enhanced) and you can select 0 or more
    segments
   
    See the properties "toggleHilites" and "multipleHilites" in LC 9.0 DP-9.
   
    Note that there is currently a bug in LC 9.0 DP-9, which will be fixed in
    the next release:
   
    http://quality.livecode.com/show_bug.cgi?id=20461
   
    Best regards,
    Panos
    --
   
   

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
Hi BR,

>>>>>>>Though obvious in function,  "hiliteChanged"  is not a documented
property of the segmented control

It is documented. In the dictionary, select "Segmented Control" in the API
dropdown, and you'll see all the properties/messages related to this widget.

Best,
Panos
--

On Tue, Oct 3, 2017 at 4:00 PM, Sannyasin Brahmanathaswami via use-livecode
<[hidden email]> wrote:

> Hmm the bug I have is a bit different… appears in both 8 and 9
>
> I "deprecated" the control by moving it to -2000,-2000 and used the
> "old-fashioned way" of three buttons in group/get the target and go.  save…
> went off for some other work.. came back
>
> Then  every time the stack opens, the script of the widget at -2000,-2000
> would receive what I thought was a custom message (because we were sending
> it on mouseup)_
>
> on hiliteChanged
>    put the hilitedItemNames of me into tName
>    put tName into sPreviousSelection
>    answer tName with "OK"
>     DoSomething
> end hiliteChanged
>
> on doSomething
>   answer "command issued" with "OK"
> end doSomething
>
> Though obvious in function,  "hiliteChanged"  is not a documented property
> of the segmented control
>
>
> so I copied the three segment control to a brand new stack,
>
> three tabs/names
>
>  Favorites | Activity | Date
>
> reduced the longer script to the above very simple test. saved and close
> the stack…
>
> now I reopen the stack and the answer dialog is trigged on open stack..
> the control is "hearing" the openstack message as a change of hilite.  the
> tName was empty.  OK so I select "Activity" which then become hilited. save
> the stack, close and reopen… bingo it fires the dialog with
>
> Activity
> OK
>
> and in our larger framework… it was "getting worse" as somehow this
> segmented control widget on stack A was still receiving that message even
> when stack B was opened, if stack A with the widget on it's top card was
> still open "behind" Stack B…  and I clicked on a widget/icon in stack B
> that had it's hiliite set to toggle (I usually turn them off) the script
> editor would fire with an error in the script of the widget appearing,
> "like out of nowhere" (because its stack is behind the scenes) with a break
> at "doSomething" …can't find the command "doSomething"
>
> almost as if the widget had become some global or backscript in the brain
> of the IDE.
>
> I don't have time for more forensics. Lost nearly literally 6 hours on
> this… so I have just removed it from the stack. Old method may not look as
> good across platforms, but it works.
>
> moving on…
>
>
>
>
> On 10/2/17, 11:58 PM, "use-livecode on behalf of panagiotis merakos via
> use-livecode" <[hidden email] on behalf of
> [hidden email]> wrote:
>
>     Hi BR,
>
>     The main difference between the segmented control between LC 8.x and
> 9.0 is
>     that:
>
>     - In LC 8.x you can select **exactly** one segment
>     - In LC 9 this has changed (--> enhanced) and you can select 0 or more
>     segments
>
>     See the properties "toggleHilites" and "multipleHilites" in LC 9.0
> DP-9.
>
>     Note that there is currently a bug in LC 9.0 DP-9, which will be fixed
> in
>     the next release:
>
>     http://quality.livecode.com/show_bug.cgi?id=20461
>
>     Best regards,
>     Panos
>     --
>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
I may be blind today… been tracing code for three days…

see all props listed in the API guide

https://www.dropbox.com/s/tpo38y5q491w0hr/seg-control-props.jpeg?dl=0

"hiliteChanged"

does not appear among them.



 

On 10/3/17, 5:53 AM, "use-livecode on behalf of panagiotis merakos via use-livecode" <[hidden email] on behalf of [hidden email]> wrote:

    It is documented. In the dictionary, select "Segmented Control" in the API
    dropdown, and you'll see all the properties/messages related to this widget.

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
Look at the description for the widget. Appears there isn’t a separate
dictionary entry.
On Tue, Oct 3, 2017 at 1:43 PM Sannyasin Brahmanathaswami via use-livecode <
[hidden email]> wrote:

> I may be blind today… been tracing code for three days…
>
> see all props listed in the API guide
>
> https://www.dropbox.com/s/tpo38y5q491w0hr/seg-control-props.jpeg?dl=0
>
> "hiliteChanged"
>
> does not appear among them.
>
>
>
>
>
> On 10/3/17, 5:53 AM, "use-livecode on behalf of panagiotis merakos via
> use-livecode" <[hidden email] on behalf of
> [hidden email]> wrote:
>
>     It is documented. In the dictionary, select "Segmented Control" in the
> API
>     dropdown, and you'll see all the properties/messages related to this
> widget.
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
In reply to this post by J. Landman Gay via use-livecode
Hi BR,

Sorry, I should have been more clear. The "hiliteChanged" is a **message**
related to the segmented control. In your screenshot, you have applied the
"property" filter, thus this message is not shown. Remove the "property"
filter and this message will appear.

Best,
Panos
--

On Tue, Oct 3, 2017 at 7:43 PM, Sannyasin Brahmanathaswami via use-livecode
<[hidden email]> wrote:

> I may be blind today… been tracing code for three days…
>
> see all props listed in the API guide
>
> https://www.dropbox.com/s/tpo38y5q491w0hr/seg-control-props.jpeg?dl=0
>
> "hiliteChanged"
>
> does not appear among them.
>
>
>
>
>
> On 10/3/17, 5:53 AM, "use-livecode on behalf of panagiotis merakos via
> use-livecode" <[hidden email] on behalf of
> [hidden email]> wrote:
>
>     It is documented. In the dictionary, select "Segmented Control" in the
> API
>     dropdown, and you'll see all the properties/messages related to this
> widget.
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
Oh, looks like the docs for the segmented control have become mangled
somehow... perhaps a mis-merge.

On Tue, Oct 3, 2017 at 8:38 PM panagiotis merakos via use-livecode <
[hidden email]> wrote:

> Hi BR,
>
> Sorry, I should have been more clear. The "hiliteChanged" is a **message**
> related to the segmented control. In your screenshot, you have applied the
> "property" filter, thus this message is not shown. Remove the "property"
> filter and this message will appear.
>
> Best,
> Panos
> --
>
> On Tue, Oct 3, 2017 at 7:43 PM, Sannyasin Brahmanathaswami via use-livecode
> <[hidden email]> wrote:
>
> > I may be blind today… been tracing code for three days…
> >
> > see all props listed in the API guide
> >
> > https://www.dropbox.com/s/tpo38y5q491w0hr/seg-control-props.jpeg?dl=0
> >
> > "hiliteChanged"
> >
> > does not appear among them.
> >
> >
> >
> >
> >
> > On 10/3/17, 5:53 AM, "use-livecode on behalf of panagiotis merakos via
> > use-livecode" <[hidden email] on behalf of
> > [hidden email]> wrote:
> >
> >     It is documented. In the dictionary, select "Segmented Control" in
> the
> > API
> >     dropdown, and you'll see all the properties/messages related to this
> > widget.
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
That’s what I was just looking at. Develop branch impacted, 8.1 & 8.2 are
good.
On Tue, Oct 3, 2017 at 3:18 PM Ali Lloyd via use-livecode <
[hidden email]> wrote:

> Oh, looks like the docs for the segmented control have become mangled
> somehow... perhaps a mis-merge.
>
> On Tue, Oct 3, 2017 at 8:38 PM panagiotis merakos via use-livecode <
> [hidden email]> wrote:
>
> > Hi BR,
> >
> > Sorry, I should have been more clear. The "hiliteChanged" is a
> **message**
> > related to the segmented control. In your screenshot, you have applied
> the
> > "property" filter, thus this message is not shown. Remove the "property"
> > filter and this message will appear.
> >
> > Best,
> > Panos
> > --
> >
> > On Tue, Oct 3, 2017 at 7:43 PM, Sannyasin Brahmanathaswami via
> use-livecode
> > <[hidden email]> wrote:
> >
> > > I may be blind today… been tracing code for three days…
> > >
> > > see all props listed in the API guide
> > >
> > > https://www.dropbox.com/s/tpo38y5q491w0hr/seg-control-props.jpeg?dl=0
> > >
> > > "hiliteChanged"
> > >
> > > does not appear among them.
> > >
> > >
> > >
> > >
> > >
> > > On 10/3/17, 5:53 AM, "use-livecode on behalf of panagiotis merakos via
> > > use-livecode" <[hidden email] on behalf of
> > > [hidden email]> wrote:
> > >
> > >     It is documented. In the dictionary, select "Segmented Control" in
> > the
> > > API
> > >     dropdown, and you'll see all the properties/messages related to
> this
> > > widget.
> > >
> > > _______________________________________________
> > > use-livecode mailing list
> > > [hidden email]
> > > Please visit this url to subscribe, unsubscribe and manage your
> > > subscription preferences:
> > > http://lists.runrev.com/mailman/listinfo/use-livecode
> > >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
Appears to be here:
https://github.com/livecode/livecode/commit/4a25b3be357bcb8c92523d6f8cc4f9ea5d94836e#diff-48360427573246fc3b20d170e09eb8b1

On Tue, Oct 3, 2017 at 9:38 PM Brian Milby <[hidden email]> wrote:

> That’s what I was just looking at. Develop branch impacted, 8.1 & 8.2 are
> good.
> On Tue, Oct 3, 2017 at 3:18 PM Ali Lloyd via use-livecode <
> [hidden email]> wrote:
>
>> Oh, looks like the docs for the segmented control have become mangled
>> somehow... perhaps a mis-merge.
>>
>> On Tue, Oct 3, 2017 at 8:38 PM panagiotis merakos via use-livecode <
>> [hidden email]> wrote:
>>
>> > Hi BR,
>> >
>> > Sorry, I should have been more clear. The "hiliteChanged" is a
>> **message**
>> > related to the segmented control. In your screenshot, you have applied
>> the
>> > "property" filter, thus this message is not shown. Remove the "property"
>> > filter and this message will appear.
>> >
>> > Best,
>> > Panos
>> > --
>> >
>> > On Tue, Oct 3, 2017 at 7:43 PM, Sannyasin Brahmanathaswami via
>> use-livecode
>> > <[hidden email]> wrote:
>> >
>> > > I may be blind today… been tracing code for three days…
>> > >
>> > > see all props listed in the API guide
>> > >
>> > > https://www.dropbox.com/s/tpo38y5q491w0hr/seg-control-props.jpeg?dl=0
>> > >
>> > > "hiliteChanged"
>> > >
>> > > does not appear among them.
>> > >
>> > >
>> > >
>> > >
>> > >
>> > > On 10/3/17, 5:53 AM, "use-livecode on behalf of panagiotis merakos via
>> > > use-livecode" <[hidden email] on behalf of
>> > > [hidden email]> wrote:
>> > >
>> > >     It is documented. In the dictionary, select "Segmented Control" in
>> > the
>> > > API
>> > >     dropdown, and you'll see all the properties/messages related to
>> this
>> > > widget.
>> > >
>> > > _______________________________________________
>> > > use-livecode mailing list
>> > > [hidden email]
>> > > Please visit this url to subscribe, unsubscribe and manage your
>> > > subscription preferences:
>> > > http://lists.runrev.com/mailman/listinfo/use-livecode
>> > >
>> > _______________________________________________
>> > use-livecode mailing list
>> > [hidden email]
>> > Please visit this url to subscribe, unsubscribe and manage your
>> > subscription preferences:
>> > http://lists.runrev.com/mailman/listinfo/use-livecode
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
In reply to this post by J. Landman Gay via use-livecode
Pants wrote>,
> Sorry, I should have been more clear. The "hiliteChanged" is a **message**
> related to the segmented control. In your screenshot, you have applied the
> "property" filter, thus this message is not shown. Remove the "property"
> filter and this message will appear.

Actually no. It appears that the message is described for three widgets but not for the segmented control.
Looking at the lcb file...
https://github.com/livecode/livecode/blob/develop/extensions/widgets/segmented/segmented.lcb
...it is mentioned 12 times but not actually described in a way for the dictionary API to retrieve.

Bug report anyone?

James

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
I think Ali is already on it. He found the commit with the removal.
On Tue, Oct 3, 2017 at 3:49 PM James At The Hale via use-livecode <
[hidden email]> wrote:

> Pants wrote>,
> > Sorry, I should have been more clear. The "hiliteChanged" is a
> **message**
> > related to the segmented control. In your screenshot, you have applied
> the
> > "property" filter, thus this message is not shown. Remove the "property"
> > filter and this message will appear.
>
> Actually no. It appears that the message is described for three widgets
> but not for the segmented control.
> Looking at the lcb file...
>
> https://github.com/livecode/livecode/blob/develop/extensions/widgets/segmented/segmented.lcb
> ...it is mentioned 12 times but not actually described in a way for the
> dictionary API to retrieve.
>
> Bug report anyone?
>
> James
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
In reply to this post by J. Landman Gay via use-livecode
LC team: Thanks for getting the docs fixed… can we go back on point?

Bug still stands

The segmented still seems to be "globally enabled" and "hears" the hilitedChanged msg from "across the universe"

-- when card is opened even though no handler is checking that property
-- even from a top stack A when the stack with the segmentedcontrol is a substack B which is still open "behind"
-- clicking on a widget on the top stack A (with hilited checked) .. the segmentedControl in substack B  which has a script like this

on hiliteChanged
   put the hilitedItemNames of me into tName
   put tName into sPreviousSelection
   answer tName with "OK"
    #DoSomething  
end hiliteChanged

fires.. and you get the answer dialog.

I just wanted to see if that was an oddity I had created or if this is what you see also. (anybody)
 

On 10/3/17, 10:18 AM, "use-livecode on behalf of Ali Lloyd via use-livecode" <[hidden email] on behalf of [hidden email]> wrote:

    Oh, looks like the docs for the segmented control have become mangled
    somehow... perhaps a mis-merge.

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
Hi Brahmanathaswami,

What you see is a bug, see this report:

http://quality.livecode.com/show_bug.cgi?id=20509

Best,
Panos
--

On Thu, Oct 5, 2017 at 9:45 PM, Sannyasin Brahmanathaswami via use-livecode
<[hidden email]> wrote:

> LC team: Thanks for getting the docs fixed… can we go back on point?
>
> Bug still stands
>
> The segmented still seems to be "globally enabled" and "hears" the
> hilitedChanged msg from "across the universe"
>
> -- when card is opened even though no handler is checking that property
> -- even from a top stack A when the stack with the segmentedcontrol is a
> substack B which is still open "behind"
> -- clicking on a widget on the top stack A (with hilited checked) .. the
> segmentedControl in substack B  which has a script like this
>
> on hiliteChanged
>    put the hilitedItemNames of me into tName
>    put tName into sPreviousSelection
>    answer tName with "OK"
>     #DoSomething
> end hiliteChanged
>
> fires.. and you get the answer dialog.
>
> I just wanted to see if that was an oddity I had created or if this is
> what you see also. (anybody)
>
>
> On 10/3/17, 10:18 AM, "use-livecode on behalf of Ali Lloyd via
> use-livecode" <[hidden email] on behalf of
> [hidden email]> wrote:
>
>     Oh, looks like the docs for the segmented control have become mangled
>     somehow... perhaps a mis-merge.
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: Segmented Control Bugs?

J. Landman Gay via use-livecode
I've posted a PR that should address this issue:
https://github.com/livecode/livecode/pull/6044
I created a stack with a segmented control with a substack with a segmented
control.  As you described, the hiliteChanged message was dispatched for
both controls upon opening the stack.  In my case, I observed the substack
message coming first and then the parent stack message.  If you would like
assistance testing to see if the change corrects your situation, let me
know (there should just be 2 files that need to be replaced in your DP9
install).

On Thu, Oct 5, 2017 at 3:50 PM, panagiotis merakos via use-livecode <
[hidden email]> wrote:

> Hi Brahmanathaswami,
>
> What you see is a bug, see this report:
>
> http://quality.livecode.com/show_bug.cgi?id=20509
>
> Best,
> Panos
> --
>
> On Thu, Oct 5, 2017 at 9:45 PM, Sannyasin Brahmanathaswami via use-livecode
> <[hidden email]> wrote:
>
> > LC team: Thanks for getting the docs fixed… can we go back on point?
> >
> > Bug still stands
> >
> > The segmented still seems to be "globally enabled" and "hears" the
> > hilitedChanged msg from "across the universe"
> >
> > -- when card is opened even though no handler is checking that property
> > -- even from a top stack A when the stack with the segmentedcontrol is a
> > substack B which is still open "behind"
> > -- clicking on a widget on the top stack A (with hilited checked) .. the
> > segmentedControl in substack B  which has a script like this
> >
> > on hiliteChanged
> >    put the hilitedItemNames of me into tName
> >    put tName into sPreviousSelection
> >    answer tName with "OK"
> >     #DoSomething
> > end hiliteChanged
> >
> > fires.. and you get the answer dialog.
> >
> > I just wanted to see if that was an oddity I had created or if this is
> > what you see also. (anybody)
> >
> >
> > On 10/3/17, 10:18 AM, "use-livecode on behalf of Ali Lloyd via
> > use-livecode" <[hidden email] on behalf of
> > [hidden email]> wrote:
> >
> >     Oh, looks like the docs for the segmented control have become mangled
> >     somehow... perhaps a mis-merge.
> >
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode