Quantcast

Standalone Magnify Problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Standalone Magnify Problem

prothero--- via use-livecode
I'm following an approach published sometime ago (http://forums.livecode.com/viewtopic.php?f=7&t=8288 <http://forums.livecode.com/viewtopic.php?f=7&t=8288>) to provide a floating magnifier over the top of quite a large image.  I have it working fine when I'm in the development environment but it's not working reliably in a standalone app.  Here's a summary of what I'm doing:

- I generate images of 1,000 x 1,000 pixels, created using the export snapshot facility
- my app lets the user select a magnification factor in the range 4-16 times the original
- I scale-up a copy of the image (making an image of 16,000 x 16,000 say) and magnify this scaled copy
- I present the magnified view through a group using the hScroll/vScroll and formattedHeight/formattedWidth properties

The above works well when in the development environment.  When it's a standalone app I get various incorrect behaviours:

- the magnified view is all white, or all black
- the magnified view is of the wrong part of the image
- it sometimes works in the Mac standalone but not the Windows standalone

I have built the standalone using lc 8.1.2, lc 8.1.3, lc 8.1.4-rc1 and lc 9.0.0-dp6.  In all cases I have tried building using automatic inclusions and manual inclusion selection, but none of this makes it work in the standalone!  For manual selection I tried inluding every option available for Mac & Windows irrespective of whether I needed it or not.  However, even when I include "everything", it still doesn't work in the standalones!

The problems imply the lack of some inclusion and/or memory issues.  Has anyone come across this and, if so do you have a solution?!

Thanks.

Peter
--
Peter Reid
Loughborough, UK


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Standalone Magnify Problem

prothero--- via use-livecode
> Peter R. wrote:
> I have it working fine when I'm in the development environment
> but it's not working reliably in a standalone app.

a) Did you already check to have the same paintcompression in both environments?
b) If you make such large images (why?) you may get a conflict with the 8bit-coords
limit. May be the standalone engine has still more of such limits included for
'formatted'-measurements than the IDE.
c) Did you already check to have the same resizequality in both environments?
("best" may create an alphachannel)
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Loading...