Strang cursor behaviour after a drag event...

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Strang cursor behaviour after a drag event...

Jan Sælid
Hi

I have two fields. In the first one I have placed an empty "On dragEnd" event because I don't want the user to change the field only drag.

In the second one I have an "Acceptdrop" event together with an "On dragDrop" event because I want to check the dragdata before I place it in the field.

Something like this:

In script of Field 1:

    On dragEnd
        -- nothing in here
    end dragEnd

In script of field 2:

    on dragEnter
       set the acceptDrop to true
    end dragEnter

    on dragDrop
       --- check the dragdata
       --- place it in the field if it is allowed
    end dragDrop


Now here is the strange behaviour:

After the text is dragged and placed into the second field. The cursor behaves in a reversed order. When entering a field the cursor becomes an arrow.
When entering a button the cursor becomes an iBeam. The opposite of normal behaviour I would say. This happens only in the event of dragging from field 1 to field 2.
I have tried to create two new fields with no script in them. And dragging between these two do not make the same strange behaviour.

Have my computer got a fever? what is happening?


J.S
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Strang cursor behaviour after a drag event...

Eric Chatonet
Hi Jan,

This happens sometimes in the IDE.
Try to add a handler like the following into an appropriate object  
(field, card, etc. depending if you lock the cursor by yourself  
elsewhere):

on mouseMove
   unlock cursor
end mouseMove

Hope this helps.
Best Regards from Paris,

Eric Chatonet.

Le 31 oct. 05 à 18:28, Jan Sælid a écrit :

> Hi
>
> I have two fields. In the first one I have placed an empty "On  
> dragEnd" event because I don't want the user to change the field  
> only drag.
>
> In the second one I have an "Acceptdrop" event together with an "On  
> dragDrop" event because I want to check the dragdata before I place  
> it in the field.
>
> Something like this:
>
> In script of Field 1:
>
>     On dragEnd
>         -- nothing in here
>     end dragEnd
>
> In script of field 2:
>
>     on dragEnter
>        set the acceptDrop to true
>     end dragEnter
>
>     on dragDrop
>        --- check the dragdata
>        --- place it in the field if it is allowed
>     end dragDrop
>
>
> Now here is the strange behaviour:
>
> After the text is dragged and placed into the second field. The  
> cursor behaves in a reversed order. When entering a field the  
> cursor becomes an arrow.
> When entering a button the cursor becomes an iBeam. The opposite of  
> normal behaviour I would say. This happens only in the event of  
> dragging from field 1 to field 2.
> I have tried to create two new fields with no script in them. And  
> dragging between these two do not make the same strange behaviour.
>
> Have my computer got a fever? what is happening?

----------------------------------------------------------------
So Smart Software

For institutions, companies and associations
Built-to-order applications: management, multimedia, internet, etc.
Windows, Mac OS and Linux... With the French touch

Free plugins and tutorials on my website
----------------------------------------------------------------
Web site        http://www.sosmartsoftware.com/
Email        [hidden email]/
Phone        33 (0)1 43 31 77 62
Mobile        33 (0)6 20 74 50 86
----------------------------------------------------------------

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Strang cursor behaviour after a drag event...

Jan Sælid
Great

Thanks Eric

Problem solved.

----- Original Message -----
From: "Eric Chatonet" <[hidden email]>
To: "How to use Revolution" <[hidden email]>
Sent: Monday, October 31, 2005 6:36 PM
Subject: Re: Strang cursor behaviour after a drag event...


Hi Jan,

This happens sometimes in the IDE.
Try to add a handler like the following into an appropriate object
(field, card, etc. depending if you lock the cursor by yourself
elsewhere):

on mouseMove
   unlock cursor
end mouseMove

Hope this helps.
Best Regards from Paris,

Eric Chatonet.

Le 31 oct. 05 à 18:28, Jan Sælid a écrit :

> Hi
>
> I have two fields. In the first one I have placed an empty "On  dragEnd"
> event because I don't want the user to change the field  only drag.
>
> In the second one I have an "Acceptdrop" event together with an "On
> dragDrop" event because I want to check the dragdata before I place  it in
> the field.
>
> Something like this:
>
> In script of Field 1:
>
>     On dragEnd
>         -- nothing in here
>     end dragEnd
>
> In script of field 2:
>
>     on dragEnter
>        set the acceptDrop to true
>     end dragEnter
>
>     on dragDrop
>        --- check the dragdata
>        --- place it in the field if it is allowed
>     end dragDrop
>
>
> Now here is the strange behaviour:
>
> After the text is dragged and placed into the second field. The  cursor
> behaves in a reversed order. When entering a field the  cursor becomes an
> arrow.
> When entering a button the cursor becomes an iBeam. The opposite of
> normal behaviour I would say. This happens only in the event of  dragging
> from field 1 to field 2.
> I have tried to create two new fields with no script in them. And
> dragging between these two do not make the same strange behaviour.
>
> Have my computer got a fever? what is happening?

----------------------------------------------------------------
So Smart Software

For institutions, companies and associations
Built-to-order applications: management, multimedia, internet, etc.
Windows, Mac OS and Linux... With the French touch

Free plugins and tutorials on my website
----------------------------------------------------------------
Web site        http://www.sosmartsoftware.com/
Email        [hidden email]/
Phone        33 (0)1 43 31 77 62
Mobile        33 (0)6 20 74 50 86
----------------------------------------------------------------

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution 

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: Strange cursor behaviour after a drag event...

Jan Sælid
The problem with the reversed cursor after a drag event is back.
I did what mr. Chatonet adviced me to do  - but after a while the problem
still exists.
After a drag of text from one field to another the cursor still shows an
Ibeam over buttons and an arrow over fields.

This must be a bug.......



>>>Great

>>>Thanks Eric

>>>Problem solved.



>>Hi Jan,

>>This happens sometimes in the IDE.
>>Try to add a handler like the following into an appropriate object
>>(field, card, etc. depending if you lock the cursor by yourself
>>elsewhere):

>>on mouseMove
   >>unlock cursor
>>end mouseMove

>>Hope this helps.
>>Best Regards from Paris,

>>Eric Chatonet.

>>Le 31 oct. 05 à 18:28, Jan Sælid a écrit :

> Hi
>
> I have two fields. In the first one I have placed an empty "On  dragEnd"
> event because I don't want the user to change the field  only drag.
>
> In the second one I have an "Acceptdrop" event together with an "On
> dragDrop" event because I want to check the dragdata before I place  it in
> the field.
>
> Something like this:
>
> In script of Field 1:
>
>     On dragEnd
>         -- nothing in here
>     end dragEnd
>
> In script of field 2:
>
>     on dragEnter
>        set the acceptDrop to true
>     end dragEnter
>
>     on dragDrop
>        --- check the dragdata
>        --- place it in the field if it is allowed
>     end dragDrop
>
>
> Now here is the strange behaviour:
>
> After the text is dragged and placed into the second field. The  cursor
> behaves in a reversed order. When entering a field the  cursor becomes an
> arrow.
> When entering a button the cursor becomes an iBeam. The opposite of normal
> behaviour I would say. This happens only in the event of  dragging from
> field 1 to field 2.
> I have tried to create two new fields with no script in them. And dragging
> between these two do not make the same strange behaviour.
>
> Have my computer got a fever? what is happening?


_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution