androidRecorderStartRecording Fail on Second Attempt

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

androidRecorderStartRecording Fail on Second Attempt

Bob Sneidar via use-livecode
Greetings!   If I use androidRecorderStartRecording to record on Android, it works perfectly!   However,  If I attempt to call androidRecorderStartRecording again duiring the same app session, it doesn’t work… it just halts.

Here’s exactly what I’m doing:

In a button I do this:

androidRecorderSetRecordFormat "MPEG-4"
androidRecorderStartRecording fPath

Click the button again, and I do this:

try
   androidRecorderStopRecording //will error if not currently recording
end try

I can call "play fPath" and the file plays correctly.

Click the button again, and I do this (same as before):

androidRecorderSetRecordFormat "MPEG-4"
androidRecorderStartRecording fPath   //FAILS!  //yes, fPath is valid it's the same path as previously used

I tried to get the result after the second call of androidRecorderStartRecording but it couldn't report the result as it had already halted execution.

I don't see a androidRecorderReset.  Also, I tried deleting fPath thinking it worked when there wasn't a file, but that didn't help.  If I reboot the app on the device, it will work again… but only once.

Any thoughts?  

Thanks in advance,
-Dan

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode