file suffix isn't connected to the right standard program

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

file suffix isn't connected to the right standard program

J. Landman Gay via use-livecode
Hello,

I have mp4 videos stored in custom properties. Before playing them I do:

put the mystoredVideo of stack myStack into URL "binfile:myPath\myVideo.mp4"

After the file is created and assigned to the player and the player is
started, nothing happens on Mac (on Windows everything works fine). Looking
at the file, strange to say, BBEdit is connected to these files as the
standard program. All other ".mp4" files on my Mac are connected to the
QuicktimePlayer. How can two files with the same suffix being assigned to
two different programs?

I manually changed the information "open with" to "QuickTime Player" and did
"change all", but the icon of every newly created videos file keeps "BBEdit"
and they still don't want to be played in LC.

What connects my files to BBEdit? Can I do anything more as putting the
video video into URL as binfile? and why don't they play in my LC
VideoPlayer?

Any ideas?

Tiemo

 

 

 

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: file suffix isn't connected to the right standard program

J. Landman Gay via use-livecode
Hi Tiemo,

> Am 26.07.2017 um 15:03 schrieb Tiemo Hollmann TB via use-livecode <[hidden email]>:
>
> Hello,
>
> I have mp4 videos stored in custom properties. Before playing them I do:
>
> put the mystoredVideo of stack myStack into URL "binfile:myPath\myVideo.mp4"
>
> After the file is created and assigned to the player and the player is
> started, nothing happens on Mac (on Windows everything works fine). Looking
> at the file, strange to say, BBEdit is connected to these files as the
> standard program. All other ".mp4" files on my Mac are connected to the
> QuicktimePlayer. How can two files with the same suffix being assigned to
> two different programs?
>
> I manually changed the information "open with" to "QuickTime Player" and did
> "change all", but the icon of every newly created videos file keeps "BBEdit"
> and they still don't want to be played in LC.
>
> What connects my files to BBEdit? Can I do anything more as putting the
> video video into URL as binfile? and why don't they play in my LC
> VideoPlayer?
>
> Any ideas?

you should try set the filetype before you "spit out" the custom property:
...
## No need to check for platform, this does nothing on Windows:
set the filetype to "mp42" ## Hope my memory serves me right :-)
put the mystoredVideo of stack myStack into URL "binfile:myPath/myVideo.mp4"
...
At least worth a try.

Obviously "the filetype" thing is still not compeltely deprecated by Apple.

> Tiemo

Best

Klaus

--
Klaus Major
http://www.major-k.de
[hidden email]


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: file suffix isn't connected to the right standard program

J. Landman Gay via use-livecode
Hi Klaus,
at least the icon of the saved video file doesn't shows anymore BBEdit, but
now "QT MPEG4". Though all other "real" mp4 files on my Mac don't show any
program icon, but a thumbnail preview of the video as the file icon.
And it still doesn't plays within LC.
Thanks for the idea!
Tiemo

-----Ursprüngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag
von Klaus major-k via use-livecode
Gesendet: Mittwoch, 26. Juli 2017 15:14
An: How to use LiveCode <[hidden email]>
Cc: Klaus major-k <[hidden email]>
Betreff: Re: file suffix isn't connected to the right standard program

Hi Tiemo,

> Am 26.07.2017 um 15:03 schrieb Tiemo Hollmann TB via use-livecode
<[hidden email]>:
>
> Hello,
>
> I have mp4 videos stored in custom properties. Before playing them I do:
>
> put the mystoredVideo of stack myStack into URL
"binfile:myPath\myVideo.mp4"

>
> After the file is created and assigned to the player and the player is
> started, nothing happens on Mac (on Windows everything works fine).
> Looking at the file, strange to say, BBEdit is connected to these
> files as the standard program. All other ".mp4" files on my Mac are
> connected to the QuicktimePlayer. How can two files with the same
> suffix being assigned to two different programs?
>
> I manually changed the information "open with" to "QuickTime Player"
> and did "change all", but the icon of every newly created videos file
keeps "BBEdit"
> and they still don't want to be played in LC.
>
> What connects my files to BBEdit? Can I do anything more as putting
> the video video into URL as binfile? and why don't they play in my LC
> VideoPlayer?
>
> Any ideas?

you should try set the filetype before you "spit out" the custom property:
...
## No need to check for platform, this does nothing on Windows:
set the filetype to "mp42" ## Hope my memory serves me right :-) put the
mystoredVideo of stack myStack into URL "binfile:myPath/myVideo.mp4"
...
At least worth a try.

Obviously "the filetype" thing is still not compeltely deprecated by Apple.

> Tiemo

Best

Klaus

--
Klaus Major
http://www.major-k.de
[hidden email]


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: file suffix isn't connected to the right standard program

J. Landman Gay via use-livecode
Solved!
I have to sets of the same videos on my machine, the old ones Quicktime, the
new ones mp4 and I "just" had the path to the videos still on the old set of
videos. So the problem was, that I tried to play my old QT videos (with a
Sorenson codec) with the new player object without QT as mp4. That couldn't
work.
Thanks Klaus for the crucial hint to let me think into the right direction.
Tiemo

-----Ursprüngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag
von Tiemo Hollmann TB via use-livecode
Gesendet: Mittwoch, 26. Juli 2017 15:51
An: 'How to use LiveCode' <[hidden email]>
Cc: Tiemo Hollmann TB <[hidden email]>
Betreff: AW: file suffix isn't connected to the right standard program

Hi Klaus,
at least the icon of the saved video file doesn't shows anymore BBEdit, but
now "QT MPEG4". Though all other "real" mp4 files on my Mac don't show any
program icon, but a thumbnail preview of the video as the file icon.
And it still doesn't plays within LC.
Thanks for the idea!
Tiemo

-----Ursprüngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag
von Klaus major-k via use-livecode
Gesendet: Mittwoch, 26. Juli 2017 15:14
An: How to use LiveCode <[hidden email]>
Cc: Klaus major-k <[hidden email]>
Betreff: Re: file suffix isn't connected to the right standard program

Hi Tiemo,

> Am 26.07.2017 um 15:03 schrieb Tiemo Hollmann TB via use-livecode
<[hidden email]>:
>
> Hello,
>
> I have mp4 videos stored in custom properties. Before playing them I do:
>
> put the mystoredVideo of stack myStack into URL
"binfile:myPath\myVideo.mp4"

>
> After the file is created and assigned to the player and the player is
> started, nothing happens on Mac (on Windows everything works fine).
> Looking at the file, strange to say, BBEdit is connected to these
> files as the standard program. All other ".mp4" files on my Mac are
> connected to the QuicktimePlayer. How can two files with the same
> suffix being assigned to two different programs?
>
> I manually changed the information "open with" to "QuickTime Player"
> and did "change all", but the icon of every newly created videos file
keeps "BBEdit"
> and they still don't want to be played in LC.
>
> What connects my files to BBEdit? Can I do anything more as putting
> the video video into URL as binfile? and why don't they play in my LC
> VideoPlayer?
>
> Any ideas?

you should try set the filetype before you "spit out" the custom property:
...
## No need to check for platform, this does nothing on Windows:
set the filetype to "mp42" ## Hope my memory serves me right :-) put the
mystoredVideo of stack myStack into URL "binfile:myPath/myVideo.mp4"
...
At least worth a try.

Obviously "the filetype" thing is still not compeltely deprecated by Apple.

> Tiemo

Best

Klaus

--
Klaus Major
http://www.major-k.de
[hidden email]


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Loading...