get URL problem on on-rev account

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

get URL problem on on-rev account

dunbarx via use-livecode
Hi list,
I have a problem on my on-rev account for which I am awaiting an answer
from the support; but since I haven't got it yet, I am asking this list.
In an LC script I have 3 successive requests in the form :

        get URL "http://www.mydomain.fr/irev/myscript.lc?0_4"

        get URL ("http://www.mydomain.fr/irev/myscript.lc?0_1_" & it)

        get URL "http://www.mydomain.fr/irev/myscript.lc?0_0"

The domain is the same as the one running the main script containing these
requests. This script has been running perfectly for years. But suddenly,
a few days ago, the second and third requests started to returned empty.
The first one returns the expected result though. The rest of the script
doesn't crash, but the results are flawn because some data is obviously
missing. I checked the logs of the server, but the 2nd and 3rd requests
don't appear in the logs, as if they were never sent.
On the other hand, when I send each request from a browser, it works fine
and returns a consistent result.
I tried to replace the second request in the same script with :
        get URL "http://www.mydomain.fr"
and it works fine and returns the html code of the home page.

Last but not least, I have the same scripts running on the same server,
but in another account and with a different domain, and everything's ok.

Needless to say I'm puzzled... Whet could be the problem, and what should
I look at ?

Thanks in advance,
jbv


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: get URL problem on on-rev account

dunbarx via use-livecode
Try checking 'the result' after each get URL line and see if it gives an error indication - that might help work out what the problem is.

Warmest Regards,

Mark.

Sent from my iPhone

> On 25 Jan 2018, at 20:02, jbv via use-livecode <[hidden email]> wrote:
>
> Hi list,
> I have a problem on my on-rev account for which I am awaiting an answer
> from the support; but since I haven't got it yet, I am asking this list.
> In an LC script I have 3 successive requests in the form :
>
>    get URL "http://www.mydomain.fr/irev/myscript.lc?0_4"
>
>    get URL ("http://www.mydomain.fr/irev/myscript.lc?0_1_" & it)
>
>    get URL "http://www.mydomain.fr/irev/myscript.lc?0_0"
>
> The domain is the same as the one running the main script containing these
> requests. This script has been running perfectly for years. But suddenly,
> a few days ago, the second and third requests started to returned empty.
> The first one returns the expected result though. The rest of the script
> doesn't crash, but the results are flawn because some data is obviously
> missing. I checked the logs of the server, but the 2nd and 3rd requests
> don't appear in the logs, as if they were never sent.
> On the other hand, when I send each request from a browser, it works fine
> and returns a consistent result.
> I tried to replace the second request in the same script with :
>    get URL "http://www.mydomain.fr"
> and it works fine and returns the html code of the home page.
>
> Last but not least, I have the same scripts running on the same server,
> but in another account and with a different domain, and everything's ok.
>
> Needless to say I'm puzzled... Whet could be the problem, and what should
> I look at ?
>
> Thanks in advance,
> jbv
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: get URL problem on on-rev account

dunbarx via use-livecode
On Thu, January 25, 2018 9:28 pm, Mark Waddingham via use-livecode wrote:
> Try checking 'the result' after each get URL line and see if it gives an
> error indication - that might help work out what the problem is.
>

I did that, but the result is always empty; both requests just don't go
through...

jbv


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: get URL problem on on-rev account

dunbarx via use-livecode
is it only the url calls that don't work?  Meaning, if you do a simple: put
"after url # <br>" following each attempt, do THOSE work? If so, then i'm
not sure what to say, especially since you mentioned that the logs don't
show the requests.   If any of the following "puts" fail, it might help you
track down where its broke.

On Thu, Jan 25, 2018 at 3:35 PM, jbv via use-livecode <
[hidden email]> wrote:

> On Thu, January 25, 2018 9:28 pm, Mark Waddingham via use-livecode wrote:
> > Try checking 'the result' after each get URL line and see if it gives an
> > error indication - that might help work out what the problem is.
> >
>
> I did that, but the result is always empty; both requests just don't go
> through...
>
> jbv
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode