Quantcast

iOS plist concern from Apple

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

iOS plist concern from Apple

Ralph DiMola via use-livecode
Hi All,

I’ve just received an email from apple that indicated a plist problem:
”We are reaching out to you because we were unable to process your latest build uploads due to bad binaries. Specifically, your plists had an empty perBinaryResults key"

When I open the plist from the build, I don’t see any key named “perBinaryResults.”

The apps referenced in the email were approved (processed) without issue 5 and 6 weeks ago. I have no idea what they message is referring to. As of right now, I don’t have any idea what to even ask apple… nor, how to fix the issue.

My only “new” thing was to add a font … first time I’ve done so and I included the font with all of the apps listed in the email from apple.

I didn’t make note as to whether I used LC 8.1.0 or 8.1.2 to build the app for submission.

Thanks for any thoughts you can share.

be well,
randy

Randy Hengst
www.classroomFocusedSoftware.com

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: iOS plist concern from Apple

Ralph DiMola via use-livecode
Hi Randy,

See this thread:
http://forums.livecode.com/viewtopic.php?f=49&p=153346#p153346

This ("perBinaryResults") does not sound like a name for a plist key.

Best,
Panos
--

On Fri, Apr 14, 2017 at 3:42 PM, Randy Hengst via use-livecode <
[hidden email]> wrote:

> Hi All,
>
> I’ve just received an email from apple that indicated a plist problem:
> ”We are reaching out to you because we were unable to process your latest
> build uploads due to bad binaries. Specifically, your plists had an empty
> perBinaryResults key"
>
> When I open the plist from the build, I don’t see any key named
> “perBinaryResults.”
>
> The apps referenced in the email were approved (processed) without issue 5
> and 6 weeks ago. I have no idea what they message is referring to. As of
> right now, I don’t have any idea what to even ask apple… nor, how to fix
> the issue.
>
> My only “new” thing was to add a font … first time I’ve done so and I
> included the font with all of the apps listed in the email from apple.
>
> I didn’t make note as to whether I used LC 8.1.0 or 8.1.2 to build the app
> for submission.
>
> Thanks for any thoughts you can share.
>
> be well,
> randy
>
> Randy Hengst
> www.classroomFocusedSoftware.com
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: iOS plist concern from Apple

Ralph DiMola via use-livecode
Thank you, Panos. I hadn't seen that thread… but, another thought. Since I’ve included a font for the first time, I’ve been looking at that as a possible issue.

I included the font in the app using the Copy Files pane of the Settings. Is there something I was supposed to reference in the “Font Mapping File” box of the iOS pane?

be well,
randy

Randy Hengst
www.classroomFocusedSoftware.com

> On Apr 14, 2017, at 10:15 AM, panagiotis merakos via use-livecode <[hidden email]> wrote:
>
> Hi Randy,
>
> See this thread:
> http://forums.livecode.com/viewtopic.php?f=49&p=153346#p153346
>
> This ("perBinaryResults") does not sound like a name for a plist key.
>
> Best,
> Panos
> --
>
> On Fri, Apr 14, 2017 at 3:42 PM, Randy Hengst via use-livecode <
> [hidden email]> wrote:
>
>> Hi All,
>>
>> I’ve just received an email from apple that indicated a plist problem:
>> ”We are reaching out to you because we were unable to process your latest
>> build uploads due to bad binaries. Specifically, your plists had an empty
>> perBinaryResults key"
>>
>> When I open the plist from the build, I don’t see any key named
>> “perBinaryResults.”
>>
>> The apps referenced in the email were approved (processed) without issue 5
>> and 6 weeks ago. I have no idea what they message is referring to. As of
>> right now, I don’t have any idea what to even ask apple… nor, how to fix
>> the issue.
>>
>> My only “new” thing was to add a font … first time I’ve done so and I
>> included the font with all of the apps listed in the email from apple.
>>
>> I didn’t make note as to whether I used LC 8.1.0 or 8.1.2 to build the app
>> for submission.
>>
>> Thanks for any thoughts you can share.
>>
>> be well,
>> randy
>>
>> Randy Hengst
>> www.classroomFocusedSoftware.com
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: iOS plist concern from Apple

Ralph DiMola via use-livecode
Hi Randy,

Just adding the custom font file in the Copy Files will work, but you might
see a long delay on app startup. This is because iOS looks for the
PostScript name of the font. The "Font Mapping File" box is needed for
providing a mapping of the font name to its actual PostScript name (as
referenced from the Font Book).

See the release note of this feature for a better explanation :)

https://github.com/livecodesebastien/livecode/blob/6188ff2f980aa86e454bd16b5e87a6edb2bdea7a/docs/notes/feature-fontmap.md

Best,
Panos
--

On Fri, Apr 14, 2017 at 4:19 PM, Randy Hengst via use-livecode <
[hidden email]> wrote:

> Thank you, Panos. I hadn't seen that thread… but, another thought. Since
> I’ve included a font for the first time, I’ve been looking at that as a
> possible issue.
>
> I included the font in the app using the Copy Files pane of the Settings.
> Is there something I was supposed to reference in the “Font Mapping File”
> box of the iOS pane?
>
> be well,
> randy
>
> Randy Hengst
> www.classroomFocusedSoftware.com
>
> > On Apr 14, 2017, at 10:15 AM, panagiotis merakos via use-livecode <
> [hidden email]> wrote:
> >
> > Hi Randy,
> >
> > See this thread:
> > http://forums.livecode.com/viewtopic.php?f=49&p=153346#p153346
> >
> > This ("perBinaryResults") does not sound like a name for a plist key.
> >
> > Best,
> > Panos
> > --
> >
> > On Fri, Apr 14, 2017 at 3:42 PM, Randy Hengst via use-livecode <
> > [hidden email]> wrote:
> >
> >> Hi All,
> >>
> >> I’ve just received an email from apple that indicated a plist problem:
> >> ”We are reaching out to you because we were unable to process your
> latest
> >> build uploads due to bad binaries. Specifically, your plists had an
> empty
> >> perBinaryResults key"
> >>
> >> When I open the plist from the build, I don’t see any key named
> >> “perBinaryResults.”
> >>
> >> The apps referenced in the email were approved (processed) without
> issue 5
> >> and 6 weeks ago. I have no idea what they message is referring to. As of
> >> right now, I don’t have any idea what to even ask apple… nor, how to fix
> >> the issue.
> >>
> >> My only “new” thing was to add a font … first time I’ve done so and I
> >> included the font with all of the apps listed in the email from apple.
> >>
> >> I didn’t make note as to whether I used LC 8.1.0 or 8.1.2 to build the
> app
> >> for submission.
> >>
> >> Thanks for any thoughts you can share.
> >>
> >> be well,
> >> randy
> >>
> >> Randy Hengst
> >> www.classroomFocusedSoftware.com
> >>
> >> _______________________________________________
> >> use-livecode mailing list
> >> [hidden email]
> >> Please visit this url to subscribe, unsubscribe and manage your
> >> subscription preferences:
> >> http://lists.runrev.com/mailman/listinfo/use-livecode
> > _______________________________________________
> > use-livecode mailing list
> > [hidden email]
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Loading...