play videoClip "nameOfVideo" does not work, Please help

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|

play videoClip "nameOfVideo" does not work, Please help

Ban Nguyen
I create a button name "play"
I put this script on button:
on mouseUp
   play videoClip "MENTORS" at 100,100
end mouseUp

It did not work.  Please help me, thank you
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

Devin Asay

On Jul 11, 2005, at 6:08 PM, Ban Nguyen wrote:

> I create a button name "play"
> I put this script on button:
> on mouseUp
>    play videoClip "MENTORS" at 100,100
> end mouseUp
>
> It did not work.  Please help me, thank you

Did you import the clip into the stack? If so, open the Application  
Browser (Tools menu) and find the imported video clip. Make sure you  
are using the correct name, including extension if any. Also, the  
play command doesn't handle various types of compression well. (Klaus  
Major is the expert in this area.) The QuickTime player object is  
much better at playing compressed files, especially audio compression.)

If you did not import the clip, but are trying to play it as an  
external file, you must specify the entire file path, like this:

     play videoClip "C:/My folder/My other folder/MENTORS.avi"

The exception to this is if you have set the defaultFolder property  
to the folder that contains the video clip file.

Hope this helps.

Devin Asay
Humanities Technology and Research Support Center
Brigham Young University

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

J. Landman Gay
On 7/12/05 9:09 AM, Devin Asay wrote:

> If you did not import the clip, but are trying to play it as an  
> external file, you must specify the entire file path, like this:

As long as we're talking about videoclips, is there a way to store a QT
movie as an imported file in a stack, but still set a player to use it?
I know I can write the movie to disk temporarily and play it from there,
but it would be cleaner if I could just refer to it in the stack. Using
the "play" command to run it doesn't give enough control, I need to use
a player object.

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

RE: play videoClip "nameOfVideo" does not work, Please help

Ban Nguyen
In reply to this post by Ban Nguyen

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of J. Landman
Gay
Sent: Tuesday, July 12, 2005 8:33 AM
To: How to use Revolution
Subject: Re: play videoClip "nameOfVideo" does not work, Please help

On 7/12/05 9:09 AM, Devin Asay wrote:

> If you did not import the clip, but are trying to play it as an  
> external file, you must specify the entire file path, like this:

As long as we're talking about videoclips, is there a way to store a QT
movie as an imported file in a stack, but still set a player to use it?
I know I can write the movie to disk temporarily and play it from there,

but it would be cleaner if I could just refer to it in the stack. Using
the "play" command to run it doesn't give enough control, I need to use
a player object.






-----  Could you  give an example how to use the player object?  I did
imported the moive (MENTORS.wmv) into the stack (videoClips)
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

RE: play videoClip "nameOfVideo" does not work, Please help

Ban Nguyen
In reply to this post by Ban Nguyen


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of J. Landman
Gay
Sent: Tuesday, July 12, 2005 8:33 AM
To: How to use Revolution
Subject: Re: play videoClip "nameOfVideo" does not work, Please help

On 7/12/05 9:09 AM, Devin Asay wrote:

> If you did not import the clip, but are trying to play it as an  
> external file, you must specify the entire file path, like this:

As long as we're talking about videoclips, is there a way to store a QT
movie as an imported file in a stack, but still set a player to use it?
I know I can write the movie to disk temporarily and play it from there,

but it would be cleaner if I could just refer to it in the stack. Using
the "play" command to run it doesn't give enough control, I need to use
a player object.






-----  Could you  give an example how to use the player object?  I did
imported the moive (MENTORS.wmv) into the stack (videoClips)




----- Does it play .wmv movie?
This is what I did:
I create a button and put this code in there
on mouseUp
   play videoClip "MENTORS.wmv" at 100,100
end mouseUp

I didnot not work. What did I do wrong?  Please help





_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

Devin Asay

On Jul 12, 2005, at 9:57 AM, Ban Nguyen wrote:
>
> ----- Does it play .wmv movie?
> This is what I did:
> I create a button and put this code in there
> on mouseUp
>    play videoClip "MENTORS.wmv" at 100,100
> end mouseUp
>
> I didnot not work. What did I do wrong?  Please help

To the best of my knowledge, Revolution (and most other software  
video players) can not play .wmv files. This is a proprietary  
Microsoft technology whose format is not open source.

Others may be more familiar with this issue than I am.

Devin Asay
Humanities Technology and Research Support Center
Brigham Young University

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

Devin Asay
In reply to this post by J. Landman Gay
On Jul 12, 2005, at 9:32 AM, J. Landman Gay wrote:

> On 7/12/05 9:09 AM, Devin Asay wrote:
>
>
>> If you did not import the clip, but are trying to play it as an  
>> external file, you must specify the entire file path, like this:
>>
>
> As long as we're talking about videoclips, is there a way to store  
> a QT movie as an imported file in a stack, but still set a player  
> to use it? I know I can write the movie to disk temporarily and  
> play it from there, but it would be cleaner if I could just refer  
> to it in the stack. Using the "play" command to run it doesn't give  
> enough control, I need to use a player object.

I've never been able to find a way to do it. Seems like a no-brainer,  
though. BZ request, anyone?

Devin

Devin Asay
Humanities Technology and Research Support Center
Brigham Young University

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

Judy Perry
In reply to this post by Devin Asay
Also,  I may be wrong, but I think from a previous email of his that he
may have used a wmv format which I think is proprietary and perhaps
unsupported?

Anybody know about this?

Judy

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

Jeanne A. E. DeVoto
In reply to this post by J. Landman Gay
At 10:32 AM -0500 7/12/2005, J. Landman Gay wrote:
>As long as we're talking about videoclips, is there a way to store a
>QT movie as an imported file in a stack, but still set a player to
>use it? I know I can write the movie to disk temporarily and play it
>from there, but it would be cleaner if I could just refer to it in
>the stack. Using the "play" command to run it doesn't give enough
>control, I need to use a player object.

Aren't you describing a videoclip? The videoclip object is played
through a player, so you can show its controller:

   set the showController of the templatePlayer to true
   play videoclip "My Clip"

Since playing a clip creates a temporary player for display, the
settings of the templatePlayer are used when playing the clip.
--
jeanne a. e. devoto ~ [hidden email]
http://www.jaedworks.com
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

J. Landman Gay
On 7/12/05 1:56 PM, Jeanne A. E. DeVoto wrote:

> At 10:32 AM -0500 7/12/2005, J. Landman Gay wrote:
>
>> As long as we're talking about videoclips, is there a way to store a
>> QT movie as an imported file in a stack, but still set a player to use
>> it? I know I can write the movie to disk temporarily and play it from
>> there, but it would be cleaner if I could just refer to it in the
>> stack. Using the "play" command to run it doesn't give enough control,
>> I need to use a player object.
>
>
> Aren't you describing a videoclip? The videoclip object is played
> through a player, so you can show its controller:
>
>   set the showController of the templatePlayer to true
>   play videoclip "My Clip"
>
> Since playing a clip creates a temporary player for display, the
> settings of the templatePlayer are used when playing the clip.

Oh! Excellent, thank you! This is perfect. I should have known you'd
know. ;)

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

RE: play videoClip "nameOfVideo" does not work, Please help

Ban Nguyen
In reply to this post by Ban Nguyen
>
>> As long as we're talking about videoclips, is there a way to store a
>> QT movie as an imported file in a stack, but still set a player to
use
>> it? I know I can write the movie to disk temporarily and play it from

>> there, but it would be cleaner if I could just refer to it in the
>> stack. Using the "play" command to run it doesn't give enough
control,

>> I need to use a player object.
>
>
> Aren't you describing a videoclip? The videoclip object is played
> through a player, so you can show its controller:
>
>   set the showController of the templatePlayer to true
>   play videoclip "My Clip"
>
> Since playing a clip creates a temporary player for display, the
> settings of the templatePlayer are used when playing the clip.

Oh! Excellent, thank you! This is perfect. I should have known you'd
know. ;)



How do you set the location for this video?
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

Klaus major-k
In reply to this post by Jeanne A. E. DeVoto
Hi Jeanne,

> At 10:32 AM -0500 7/12/2005, J. Landman Gay wrote:
>
>> As long as we're talking about videoclips, is there a way to store  
>> a QT movie as an imported file in a stack, but still set a player  
>> to use it? I know I can write the movie to disk temporarily and  
>> play it from there, but it would be cleaner if I could just refer  
>> to it in the stack. Using the "play" command to run it doesn't  
>> give enough control, I need to use a player object.
>>
>
> Aren't you describing a videoclip? The videoclip object is played  
> through a player, so you can show its controller:
>
>   set the showController of the templatePlayer to true
>   play videoclip "My Clip"
>
> Since playing a clip creates a temporary player for display, the  
> settings of the templatePlayer are used when playing the clip.

Sure?

I thought the controller is a Quicktime-only feature...
And the "play" command does not use Quicktime (except on a mac)
as far as i know?

> --
> jeanne a. e. devoto ~ [hidden email]
> http://www.jaedworks.com

Regards

Klaus Major
[hidden email]
http://www.major-k.de

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

RE: play videoClip "nameOfVideo" does not work, Please help

Ban Nguyen
In reply to this post by Ban Nguyen

> At 10:32 AM -0500 7/12/2005, J. Landman Gay wrote:
>
>> As long as we're talking about videoclips, is there a way to store a
>> QT movie as an imported file in a stack, but still set a player to
use
>> it? I know I can write the movie to disk temporarily and play it from

>> there, but it would be cleaner if I could just refer to it in the
>> stack. Using the "play" command to run it doesn't give enough
control,

>> I need to use a player object.
>
>
> Aren't you describing a videoclip? The videoclip object is played
> through a player, so you can show its controller:
>
>   set the showController of the templatePlayer to true
>   play videoclip "My Clip"
>
> Since playing a clip creates a temporary player for display, the
> settings of the templatePlayer are used when playing the clip.

Oh! Excellent, thank you! This is perfect. I should have known you'd
know. ;)




How do you set the location for this video?






_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

J. Landman Gay
In reply to this post by Jeanne A. E. DeVoto
On 7/12/05 1:56 PM, Jeanne A. E. DeVoto wrote:

> Since playing a clip creates a temporary player for display, the
> settings of the templatePlayer are used when playing the clip.

So now if I want to stop the movie with the controller and then get rid
of it, how do I remove it from the card? It only disappears if the movie
completes and I can't find a way to set the currenttime to the duration.

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

Mark Swindell-2
In reply to this post by Ban Nguyen

On Jul 12, 2005, at 12:35 PM, Ban Nguyen wrote:

>
> How do you set the location for this video?


Set the loc of player 1 to 100,100

Are you using the built-in  documentation at all for your project?

Mark
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

Mark Swindell-2
In reply to this post by Ban Nguyen
On Jul 12, 2005, at 12:35 PM, Ban Nguyen wrote:
>
> How do you set the location for this video?


The location of any object can be set by the following:

Set the loc of <object> to x,y

An object's location is a property of the object.

----
 From the docs:

location property  (any object)
loc
Platform support:
Introduced in version 1.0

Specifies where an object is.

set the location of object to point

if the location of button 1 is within the rect of field 1 then selectIt
set the location of this stack to the mouseLoc
---



Hope this helps,
Mark
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

Jeanne A. E. DeVoto
In reply to this post by J. Landman Gay
At 2:36 PM -0500 7/12/2005, J. Landman Gay wrote:
>>Since playing a clip creates a temporary player for display, the
>>settings of the templatePlayer are used when playing the clip.
>
>So now if I want to stop the movie with the controller and then get
>rid of it, how do I remove it from the card? It only disappears if
>the movie completes and I can't find a way to set the currenttime to
>the duration.

Ugh. That I'm not sure about.

There doesn't seem to be a player reference while the thing is
playing, either. It does return a number in the result that looks an
awful lot like a pending message ID, but it isn't in the
pendingMessages... Hmmm.
--
jeanne a. e. devoto ~ [hidden email]
http://www.jaedworks.com
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: play videoClip "nameOfVideo" does not work, Please help

J. Landman Gay
On 7/12/05 6:28 PM, Jeanne A. E. DeVoto wrote:

> At 2:36 PM -0500 7/12/2005, J. Landman Gay wrote:
>
>>> Since playing a clip creates a temporary player for display, the
>>> settings of the templatePlayer are used when playing the clip.
>>
>>
>> So now if I want to stop the movie with the controller and then get
>> rid of it, how do I remove it from the card? It only disappears if the
>> movie completes and I can't find a way to set the currenttime to the
>> duration.
>
>
> Ugh. That I'm not sure about.
>
> There doesn't seem to be a player reference while the thing is playing,
> either. It does return a number in the result that looks an awful lot
> like a pending message ID, but it isn't in the pendingMessages... Hmmm.

Right. Well, I guess I'll have to go the route where I write the movie
to disk temporarily. It was a valiant try. ;) Maybe Devin is right and I
should feature-request it.

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution