question about IDE behavior

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

question about IDE behavior

Jon-3
I often find myself editing a Script, Applying the script, and then
immediately going to the main Rev menu to do a Files/Save.  
Unfortunately, Save is grayed out if I have a Script Editor
open/active.  I have to click on the main Stack in order to get the menu
to allow me to do a Save.

Any idea whether this behavior is necessary or not?  I don't understand,
technically, why one would not (or should not) be able to be do a Save
while the Script Editor is active.

If no one can explain why this behavior is necessary, I may BZ it.

:)

Jon
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: question about IDE behavior

J. Landman Gay
Jon wrote:

> I often find myself editing a Script, Applying the script, and then
> immediately going to the main Rev menu to do a Files/Save.  
> Unfortunately, Save is grayed out if I have a Script Editor
> open/active.  I have to click on the main Stack in order to get the menu
> to allow me to do a Save.
>
> Any idea whether this behavior is necessary or not?  I don't understand,
> technically, why one would not (or should not) be able to be do a Save
> while the Script Editor is active.
>
> If no one can explain why this behavior is necessary, I may BZ it.

You can probably Bugzilla it, since the dimmed item sounds like a bug.
However, in the mean time, you can just type Control-S in the script
editor and it will bring the stack forward, save, and then toggle the
script editor to the front again. Or at least it does that on a Mac.

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com
_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: question about IDE behavior

Dan Shafer
Not sure I'd call this a bug, but it seems like a bad design  
decision. When you're in the Script Editor, you have a whole  
different set of menus than when you're in the main IDE. I just  
always took it for granted that that was "the way things are" and  
I've gotten used to using Command-S (except, of course, when that  
breaks for God knows what unfathomable reason) and going merrily on  
my way. Come to think of it, if the menu's command-key equivalent  
works and the item is dimmed out, that does feel like a bug so I  
agree, Jacque!

Dan

On Aug 24, 2005, at 1:46 PM, J. Landman Gay wrote:


> Jon wrote:
>
>
>> I often find myself editing a Script, Applying the script, and  
>> then immediately going to the main Rev menu to do a Files/Save.  
>> Unfortunately, Save is grayed out if I have a Script Editor open/
>> active.  I have to click on the main Stack in order to get the  
>> menu to allow me to do a Save.
>> Any idea whether this behavior is necessary or not?  I don't  
>> understand, technically, why one would not (or should not) be able  
>> to be do a Save while the Script Editor is active.
>> If no one can explain why this behavior is necessary, I may BZ it.
>>
>>
>
> You can probably Bugzilla it, since the dimmed item sounds like a  
> bug. However, in the mean time, you can just type Control-S in the  
> script editor and it will bring the stack forward, save, and then  
> toggle the script editor to the front again. Or at least it does  
> that on a Mac.
>
> --
> Jacqueline Landman Gay         |     [hidden email]
> HyperActive Software           |     http://www.hyperactivesw.com
> _______________________________________________
> use-revolution mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution
>
>


_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: question about IDE behavior

Charles Hartman

On Aug 24, 2005, at 7:14 PM, Dan Shafer wrote:

> gotten used to using Command-S (except, of course, when that breaks  
> for God knows what unfathomable reason)


Yes, I keep getting that too. Is it a votable bug? In the dim (I mean  
"concentrated") state I'm often in when designing & coding, I  
sometimes don't notice that the magic thumb-and-index gesture I'm  
religiously performing isn't actually *doing* anything.

Charles

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: question about IDE behavior

Dan Shafer
The trouble is, Charles, that I don't see this happen only in Rev. I  
think it's an OS X bug though I've never been able to pin it down.

Dan

On Aug 24, 2005, at 4:33 PM, Charles Hartman wrote:

>
> On Aug 24, 2005, at 7:14 PM, Dan Shafer wrote:
>
>
>> gotten used to using Command-S (except, of course, when that  
>> breaks for God knows what unfathomable reason)
>>
>
>
> Yes, I keep getting that too. Is it a votable bug? In the dim (I  
> mean "concentrated") state I'm often in when designing & coding, I  
> sometimes don't notice that the magic thumb-and-index gesture I'm  
> religiously performing isn't actually *doing* anything.
>
> Charles
>
> _______________________________________________
> use-revolution mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution
>

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution
Reply | Threaded
Open this post in threaded view
|

Re: question about IDE behavior

Charles Hartman

On Aug 24, 2005, at 8:08 PM, Dan Shafer wrote:

> The trouble is, Charles, that I don't see this happen only in Rev.  
> I think it's an OS X bug though I've never been able to pin it down.
>


Hm. I've seen it only in Rev. I wonder if there's some class or group  
of apps?

Charles

_______________________________________________
use-revolution mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-revolution