script/engine broken when moved to 64bit server at JaguarPC

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

script/engine broken when moved to 64bit server at JaguarPC

Mike Kerner via use-livecode

<http://lists.runrev.com/pipermail/use-livecode/2017-September/241684.html>
I've received this from JaguarPC:

----
[Sun Sep 10 01:51:36.334093 2017] [cgid:error] [pid 22868:tid
139689650484992] [client 69.73.180.11:50074] End of script output before
headers: keygentest.cgi

That occurs when a script has insufficient permissions but I couldn't
find any script having incorrect permissions in the account. Also we
have checked there has been no dependency issue either.

You have SSH access enabled on your account so your developer should be
able to login and investigate the cause of this issue through debugging
on shell. If he finds anything wrong with the setup, he can update us
regarding that.

We have now following Perl version installed on the new server, you
might want to regenerate the executable lccgi to ensure it is compatible
with following version:

==
[root@sagitarius cgi-bin]# perl -v

This is perl 5, version 16, subversion 3 (v5.16.3) built for
x86_64-linux-thread-multi

(with 34 registered patches, see perl -V for more detail)

Besides that Bobsled server has similar setup so I am afraid, moving to
that server will help actually.

We have now live chat support working which you can access through our
official website. If you want to chat with us, you are most welcome.

Please let us know if we can be of further assistance.

Regards,
Bilal | L3 Support Representative
------

I don't have the skills to debug through shell (that's why I like to use
a tool like Livecode!) and I can't regenerate the Livecode engine..!

Our script (which I haven't touched) and the engine both have
permissions set to 755. Sagitarius (which they currently have us on) and
bobsled (where Jacque has a setup that's working) are both 64bit servers
running CentOS 7.

Curt

--
Sent from Postbox
<https://www.postbox-inc.com/?utm_source=email&utm_medium=siglink&utm_campaign=reach>
_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: script/engine broken when moved to 64bit server at JaguarPC

Mike Kerner via use-livecode
Hi Curt,

If you email me off list and don't mind sharing your ssh details temporarily with us, we will take a look to see what the problem is.

CentOS 7 is one of our supported Linux distros for LiveCode server so we'd like to find out what configuration JaguarPC has to cause the problem and sort it out.

Warmest Regards,

Mark.

Sent from my iPhone

> On 12 Sep 2017, at 15:32, Curtis Ford via use-livecode <[hidden email]> wrote:
>
>
> <http://lists.runrev.com/pipermail/use-livecode/2017-September/241684.html>
> I've received this from JaguarPC:
>
> ----
> [Sun Sep 10 01:51:36.334093 2017] [cgid:error] [pid 22868:tid 139689650484992] [client 69.73.180.11:50074] End of script output before headers: keygentest.cgi
>
> That occurs when a script has insufficient permissions but I couldn't find any script having incorrect permissions in the account. Also we have checked there has been no dependency issue either.
>
> You have SSH access enabled on your account so your developer should be able to login and investigate the cause of this issue through debugging on shell. If he finds anything wrong with the setup, he can update us regarding that.
>
> We have now following Perl version installed on the new server, you might want to regenerate the executable lccgi to ensure it is compatible with following version:
>
> ==
> [root@sagitarius cgi-bin]# perl -v
>
> This is perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux-thread-multi
>
> (with 34 registered patches, see perl -V for more detail)
>
> Besides that Bobsled server has similar setup so I am afraid, moving to that server will help actually.
>
> We have now live chat support working which you can access through our official website. If you want to chat with us, you are most welcome.
>
> Please let us know if we can be of further assistance.
>
> Regards,
> Bilal | L3 Support Representative
> ------
>
> I don't have the skills to debug through shell (that's why I like to use a tool like Livecode!) and I can't regenerate the Livecode engine..!
>
> Our script (which I haven't touched) and the engine both have permissions set to 755. Sagitarius (which they currently have us on) and bobsled (where Jacque has a setup that's working) are both 64bit servers running CentOS 7.
>
> Curt
>
> --
> Sent from Postbox <https://www.postbox-inc.com/?utm_source=email&utm_medium=siglink&utm_campaign=reach>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode