tsneterr: (6) could not resolve host

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

tsneterr: (6) could not resolve host

Klaus major-k via use-livecode
Hello,

using LC 8.1.2 / 8.1.3 I get an "tsneterr: (6) could not resolve host:
public" when trying to access a file in a web server directory with user and
password protection

put URL "http://public:myPW@.../mypath/my.txt" into tResult

when opening the same file in a not pw protected directory, everything is
fine and I get the content of the file

Testing the same with 8.1 or 9.0 dp 4 it works also with the pw protected
dir, like it should.

Is this a known issue with tsnet? Any workarounds?

Thanks

Tiemo

 

 

 

 

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: tsneterr: (6) could not resolve host

Klaus major-k via use-livecode
Forgot to say: Windows 10

-----Ursprüngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag
von Tiemo Hollmann TB via use-livecode
Gesendet: Mittwoch, 15. März 2017 16:00
An: LiveCode User Liste senden <[hidden email]>
Cc: Tiemo Hollmann TB <[hidden email]>
Betreff: tsneterr: (6) could not resolve host

Hello,

using LC 8.1.2 / 8.1.3 I get an "tsneterr: (6) could not resolve host:
public" when trying to access a file in a web server directory with user and
password protection

put URL "http://public:myPW@.../mypath/my.txt" into tResult

when opening the same file in a not pw protected directory, everything is
fine and I get the content of the file

Testing the same with 8.1 or 9.0 dp 4 it works also with the pw protected
dir, like it should.

Is this a known issue with tsnet? Any workarounds?

Thanks

Tiemo

 

 

 

 

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: AW: tsneterr: (6) could not resolve host

Klaus major-k via use-livecode
Hi Tiemo,

I have not heard of this issue before but will see if I can reproduce it
and get back to you.

A workaround would be to use the tsNetGetSync function directly so that
you can specify the user/pass separately like this:

--
local tHeaders, tOutHeaders, tResultCode, tBytes, tSettings
put "public" into tSettings["username"]
put "myPW" into tSettings["password"]
put tsNetGetSync("http://www.myHost/mypath/my.txt", tHeaders,
tOutHeaders, tResultCode, tBytes, tSettings) into tResult
--

Hope that helps,

Cheers,

Charles


On 16/03/2017 1:00 AM, Tiemo Hollmann TB via use-livecode wrote:

> Forgot to say: Windows 10
>
> -----Ursprüngliche Nachricht-----
> Von: use-livecode [mailto:[hidden email]] Im Auftrag
> von Tiemo Hollmann TB via use-livecode
> Gesendet: Mittwoch, 15. März 2017 16:00
> An: LiveCode User Liste senden <[hidden email]>
> Cc: Tiemo Hollmann TB <[hidden email]>
> Betreff: tsneterr: (6) could not resolve host
>
> Hello,
>
> using LC 8.1.2 / 8.1.3 I get an "tsneterr: (6) could not resolve host:
> public" when trying to access a file in a web server directory with user and
> password protection
>
> put URL "http://public:myPW@.../mypath/my.txt" into tResult
>
> when opening the same file in a not pw protected directory, everything is
> fine and I get the content of the file
>
> Testing the same with 8.1 or 9.0 dp 4 it works also with the pw protected
> dir, like it should.
>
> Is this a known issue with tsnet? Any workarounds?
>
> Thanks
>
> Tiemo
>
>  
>
>  
>
>  
>
>  
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: AW: tsneterr: (6) could not resolve host - can anyone else test this?

Klaus major-k via use-livecode
I have not been able to replicate this issue here, but I am using an
older version of Windows.

Is there anyone that can try this on various versions of Windows to see
if this problem is specific to Win 10?

Try typing the following into the message box:

put URL
"http://test_auth:test_pass@.../test_auth/"

If it is successful, you should see "Authentication successful." appear
in the message box.

Thanks,

Charles


On 16/03/2017 6:31 PM, Charles Warwick via use-livecode wrote:

> Hi Tiemo,
>
> I have not heard of this issue before but will see if I can reproduce
> it and get back to you.
>
> A workaround would be to use the tsNetGetSync function directly so
> that you can specify the user/pass separately like this:
>
> --
> local tHeaders, tOutHeaders, tResultCode, tBytes, tSettings
> put "public" into tSettings["username"]
> put "myPW" into tSettings["password"]
> put tsNetGetSync("http://www.myHost/mypath/my.txt", tHeaders,
> tOutHeaders, tResultCode, tBytes, tSettings) into tResult
> --
>
> Hope that helps,
>
> Cheers,
>
> Charles
>
>
> On 16/03/2017 1:00 AM, Tiemo Hollmann TB via use-livecode wrote:
>> Forgot to say: Windows 10
>>
>> -----Ursprüngliche Nachricht-----
>> Von: use-livecode [mailto:[hidden email]] Im
>> Auftrag
>> von Tiemo Hollmann TB via use-livecode
>> Gesendet: Mittwoch, 15. März 2017 16:00
>> An: LiveCode User Liste senden <[hidden email]>
>> Cc: Tiemo Hollmann TB <[hidden email]>
>> Betreff: tsneterr: (6) could not resolve host
>>
>> Hello,
>>
>> using LC 8.1.2 / 8.1.3 I get an "tsneterr: (6) could not resolve host:
>> public" when trying to access a file in a web server directory with
>> user and
>> password protection
>>
>> put URL "http://public:myPW@.../mypath/my.txt" into tResult
>>
>> when opening the same file in a not pw protected directory,
>> everything is
>> fine and I get the content of the file
>>
>> Testing the same with 8.1 or 9.0 dp 4 it works also with the pw
>> protected
>> dir, like it should.
>>
>> Is this a known issue with tsnet? Any workarounds?
>>
>> Thanks
>>
>> Tiemo
>>
>>
>>
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription
>> preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: tsneterr: (6) could not resolve host - can anyone else test this?

Klaus major-k via use-livecode
Tried it here with

LC 8.1.3, Win 7 Pro, 64bit -> works
LC 8.1.3, Win 10 Pro, 32bit -> works



Matthias Rebbe
Bramkampsieke 13
32312 Lübbecke
Tel +49 5741 310000
    +49 160 5504462
Fax: +49 5741 310002
eMail: [hidden email] <mailto:[hidden email]>

BR5 Konverter - BR5 -> MP3 <http://matthiasrebbe.eu/portfolio/produkte/brx/>

> Am 16.03.2017 um 11:10 schrieb Charles Warwick via use-livecode <[hidden email] <mailto:[hidden email]>>:
>
> I have not been able to replicate this issue here, but I am using an older version of Windows.
>
> Is there anyone that can try this on various versions of Windows to see if this problem is specific to Win 10?
>
> Try typing the following into the message box:
>
> put URL "http://test_auth:test_pass@.../test_auth/ <http://test_auth:test_pass@.../test_auth/>"
>
> If it is successful, you should see "Authentication successful." appear in the message box.
>
> Thanks,
>
> Charles
>
>
> On 16/03/2017 6:31 PM, Charles Warwick via use-livecode wrote:
>> Hi Tiemo,
>>
>> I have not heard of this issue before but will see if I can reproduce it and get back to you.
>>
>> A workaround would be to use the tsNetGetSync function directly so that you can specify the user/pass separately like this:
>>
>> --
>> local tHeaders, tOutHeaders, tResultCode, tBytes, tSettings
>> put "public" into tSettings["username"]
>> put "myPW" into tSettings["password"]
>> put tsNetGetSync("http://www.myHost/mypath/my.txt <http://www.myhost/mypath/my.txt>", tHeaders, tOutHeaders, tResultCode, tBytes, tSettings) into tResult
>> --
>>
>> Hope that helps,
>>
>> Cheers,
>>
>> Charles
>>
>>
>> On 16/03/2017 1:00 AM, Tiemo Hollmann TB via use-livecode wrote:
>>> Forgot to say: Windows 10
>>>
>>> -----Ursprüngliche Nachricht-----
>>> Von: use-livecode [mailto:[hidden email] <mailto:[hidden email]>] Im Auftrag
>>> von Tiemo Hollmann TB via use-livecode
>>> Gesendet: Mittwoch, 15. März 2017 16:00
>>> An: LiveCode User Liste senden <[hidden email] <mailto:[hidden email]>>
>>> Cc: Tiemo Hollmann TB <[hidden email] <mailto:[hidden email]>>
>>> Betreff: tsneterr: (6) could not resolve host
>>>
>>> Hello,
>>>
>>> using LC 8.1.2 / 8.1.3 I get an "tsneterr: (6) could not resolve host:
>>> public" when trying to access a file in a web server directory with user and
>>> password protection
>>>
>>> put URL "http://public:myPW@.../mypath/my.txt <http://public:myPW@.../mypath/my.txt>" into tResult
>>>
>>> when opening the same file in a not pw protected directory, everything is
>>> fine and I get the content of the file
>>>
>>> Testing the same with 8.1 or 9.0 dp 4 it works also with the pw protected
>>> dir, like it should.
>>>
>>> Is this a known issue with tsnet? Any workarounds?
>>>
>>> Thanks
>>>
>>> Tiemo
>>>
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> use-livecode mailing list
>>> [hidden email] <mailto:[hidden email]>
>>> Please visit this url to subscribe, unsubscribe and manage your subscription
>>> preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode <http://lists.runrev.com/mailman/listinfo/use-livecode>
>>>
>>>
>>> _______________________________________________
>>> use-livecode mailing list
>>> [hidden email] <mailto:[hidden email]>
>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email] <mailto:[hidden email]>
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode <http://lists.runrev.com/mailman/listinfo/use-livecode>
>>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email] <mailto:[hidden email]>
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode <http://lists.runrev.com/mailman/listinfo/use-livecode>

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: AW: tsneterr: (6) could not resolve host - can anyone else test this?

Klaus major-k via use-livecode
In reply to this post by Klaus major-k via use-livecode
Hi Charles,

this test URL works for me also in 8.1.3
my URL still doesn't works in 8.1.3 (but in 9.0 and older versions) - what
happened to tsnet in 8.1.3?
your workaround with tsNetGetSync also works with my URL in 8.1.3 - whats
the difference under the hood to put URL?
interesting results!
thanks!

Tiemo

-----Ursprüngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag
von Charles Warwick via use-livecode
Gesendet: Donnerstag, 16. März 2017 11:11
An: [hidden email]
Cc: Charles Warwick <[hidden email]>
Betreff: Re: AW: tsneterr: (6) could not resolve host - can anyone else test
this?

I have not been able to replicate this issue here, but I am using an older
version of Windows.

Is there anyone that can try this on various versions of Windows to see if
this problem is specific to Win 10?

Try typing the following into the message box:

put URL
"http://test_auth:test_pass@.../test_auth/"

If it is successful, you should see "Authentication successful." appear in
the message box.

Thanks,

Charles


On 16/03/2017 6:31 PM, Charles Warwick via use-livecode wrote:

> Hi Tiemo,
>
> I have not heard of this issue before but will see if I can reproduce
> it and get back to you.
>
> A workaround would be to use the tsNetGetSync function directly so
> that you can specify the user/pass separately like this:
>
> --
> local tHeaders, tOutHeaders, tResultCode, tBytes, tSettings put
> "public" into tSettings["username"] put "myPW" into
> tSettings["password"] put
> tsNetGetSync("http://www.myHost/mypath/my.txt", tHeaders, tOutHeaders,
> tResultCode, tBytes, tSettings) into tResult
> --
>
> Hope that helps,
>
> Cheers,
>
> Charles
>
>
> On 16/03/2017 1:00 AM, Tiemo Hollmann TB via use-livecode wrote:
>> Forgot to say: Windows 10
>>
>> -----Ursprüngliche Nachricht-----
>> Von: use-livecode [mailto:[hidden email]] Im
>> Auftrag von Tiemo Hollmann TB via use-livecode
>> Gesendet: Mittwoch, 15. März 2017 16:00
>> An: LiveCode User Liste senden <[hidden email]>
>> Cc: Tiemo Hollmann TB <[hidden email]>
>> Betreff: tsneterr: (6) could not resolve host
>>
>> Hello,
>>
>> using LC 8.1.2 / 8.1.3 I get an "tsneterr: (6) could not resolve host:
>> public" when trying to access a file in a web server directory with
>> user and password protection
>>
>> put URL "http://public:myPW@.../mypath/my.txt" into tResult
>>
>> when opening the same file in a not pw protected directory,
>> everything is fine and I get the content of the file
>>
>> Testing the same with 8.1 or 9.0 dp 4 it works also with the pw
>> protected dir, like it should.
>>
>> Is this a known issue with tsnet? Any workarounds?
>>
>> Thanks
>>
>> Tiemo
>>
>>
>>
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription
>> preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: AW: tsneterr: (6) could not resolve host - can anyone else test this?

Klaus major-k via use-livecode
In reply to this post by Klaus major-k via use-livecode
LC 8.1.3  - Windows 10 64Bit - Works for me

-----Original Message-----
From: use-livecode [mailto:[hidden email]] On Behalf Of Charles Warwick via use-livecode
Sent: 16 March 2017 10:11
To: [hidden email]
Cc: Charles Warwick <[hidden email]>
Subject: Re: AW: tsneterr: (6) could not resolve host - can anyone else test this?

I have not been able to replicate this issue here, but I am using an older version of Windows.

Is there anyone that can try this on various versions of Windows to see if this problem is specific to Win 10?

Try typing the following into the message box:

put URL
"http://test_auth:test_pass@.../test_auth/"

If it is successful, you should see "Authentication successful." appear in the message box.

Thanks,

Charles


On 16/03/2017 6:31 PM, Charles Warwick via use-livecode wrote:

> Hi Tiemo,
>
> I have not heard of this issue before but will see if I can reproduce
> it and get back to you.
>
> A workaround would be to use the tsNetGetSync function directly so
> that you can specify the user/pass separately like this:
>
> --
> local tHeaders, tOutHeaders, tResultCode, tBytes, tSettings put
> "public" into tSettings["username"] put "myPW" into
> tSettings["password"] put
> tsNetGetSync("http://www.myHost/mypath/my.txt", tHeaders, tOutHeaders,
> tResultCode, tBytes, tSettings) into tResult
> --
>
> Hope that helps,
>
> Cheers,
>
> Charles
>
>
> On 16/03/2017 1:00 AM, Tiemo Hollmann TB via use-livecode wrote:
>> Forgot to say: Windows 10
>>
>> -----Ursprüngliche Nachricht-----
>> Von: use-livecode [mailto:[hidden email]] Im
>> Auftrag von Tiemo Hollmann TB via use-livecode
>> Gesendet: Mittwoch, 15. März 2017 16:00
>> An: LiveCode User Liste senden <[hidden email]>
>> Cc: Tiemo Hollmann TB <[hidden email]>
>> Betreff: tsneterr: (6) could not resolve host
>>
>> Hello,
>>
>> using LC 8.1.2 / 8.1.3 I get an "tsneterr: (6) could not resolve host:
>> public" when trying to access a file in a web server directory with
>> user and password protection
>>
>> put URL "http://public:myPW@.../mypath/my.txt" into tResult
>>
>> when opening the same file in a not pw protected directory,
>> everything is fine and I get the content of the file
>>
>> Testing the same with 8.1 or 9.0 dp 4 it works also with the pw
>> protected dir, like it should.
>>
>> Is this a known issue with tsnet? Any workarounds?
>>
>> Thanks
>>
>> Tiemo
>>
>>
>>
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription
>> preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: AW: tsneterr: (6) could not resolve host - can anyone else test this?

Klaus major-k via use-livecode
Panos from LC solved the mystery. In my URL the password has a special
character, which can't be handled in 8.1.2 and 8.1.3 on Windows. When doing
urlencode(myPW), it also works in 8.1.3
The why is not known
Tiemo


-----Ursprüngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag
von Paul Richards via use-livecode
Gesendet: Donnerstag, 16. März 2017 15:22
An: How to use LiveCode <[hidden email]>
Cc: Paul Richards <[hidden email]>
Betreff: RE: AW: tsneterr: (6) could not resolve host - can anyone else test
this?

LC 8.1.3  - Windows 10 64Bit - Works for me

-----Original Message-----
From: use-livecode [mailto:[hidden email]] On Behalf
Of Charles Warwick via use-livecode
Sent: 16 March 2017 10:11
To: [hidden email]
Cc: Charles Warwick <[hidden email]>
Subject: Re: AW: tsneterr: (6) could not resolve host - can anyone else test
this?

I have not been able to replicate this issue here, but I am using an older
version of Windows.

Is there anyone that can try this on various versions of Windows to see if
this problem is specific to Win 10?

Try typing the following into the message box:

put URL
"http://test_auth:test_pass@.../test_auth/"

If it is successful, you should see "Authentication successful." appear in
the message box.

Thanks,

Charles


On 16/03/2017 6:31 PM, Charles Warwick via use-livecode wrote:

> Hi Tiemo,
>
> I have not heard of this issue before but will see if I can reproduce
> it and get back to you.
>
> A workaround would be to use the tsNetGetSync function directly so
> that you can specify the user/pass separately like this:
>
> --
> local tHeaders, tOutHeaders, tResultCode, tBytes, tSettings put
> "public" into tSettings["username"] put "myPW" into
> tSettings["password"] put
> tsNetGetSync("http://www.myHost/mypath/my.txt", tHeaders, tOutHeaders,
> tResultCode, tBytes, tSettings) into tResult
> --
>
> Hope that helps,
>
> Cheers,
>
> Charles
>
>
> On 16/03/2017 1:00 AM, Tiemo Hollmann TB via use-livecode wrote:
>> Forgot to say: Windows 10
>>
>> -----Ursprüngliche Nachricht-----
>> Von: use-livecode [mailto:[hidden email]] Im
>> Auftrag von Tiemo Hollmann TB via use-livecode
>> Gesendet: Mittwoch, 15. März 2017 16:00
>> An: LiveCode User Liste senden <[hidden email]>
>> Cc: Tiemo Hollmann TB <[hidden email]>
>> Betreff: tsneterr: (6) could not resolve host
>>
>> Hello,
>>
>> using LC 8.1.2 / 8.1.3 I get an "tsneterr: (6) could not resolve host:
>> public" when trying to access a file in a web server directory with
>> user and password protection
>>
>> put URL "http://public:myPW@.../mypath/my.txt" into tResult
>>
>> when opening the same file in a not pw protected directory,
>> everything is fine and I get the content of the file
>>
>> Testing the same with 8.1 or 9.0 dp 4 it works also with the pw
>> protected dir, like it should.
>>
>> Is this a known issue with tsnet? Any workarounds?
>>
>> Thanks
>>
>> Tiemo
>>
>>
>>
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription
>> preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: AW: tsneterr: (6) could not resolve host - can anyone else test this?

Klaus major-k via use-livecode
FYI. I have used the "#" sign in a URL PW, which is not allowed in a URL
string, as Charles pointed out. Only because of an incorrect handling in the
curl library as part of tsnet, my program has worked over the years.
Urlencode(myPW) will do it for the future. So, better never use "#" in a
URL!
Tiemo

-----Ursprüngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag
von Tiemo Hollmann TB via use-livecode
Gesendet: Donnerstag, 16. März 2017 18:00
An: 'How to use LiveCode' <[hidden email]>
Cc: Tiemo Hollmann TB <[hidden email]>
Betreff: AW: AW: tsneterr: (6) could not resolve host - can anyone else test
this?

Panos from LC solved the mystery. In my URL the password has a special
character, which can't be handled in 8.1.2 and 8.1.3 on Windows. When doing
urlencode(myPW), it also works in 8.1.3 The why is not known Tiemo


-----Ursprüngliche Nachricht-----
Von: use-livecode [mailto:[hidden email]] Im Auftrag
von Paul Richards via use-livecode
Gesendet: Donnerstag, 16. März 2017 15:22
An: How to use LiveCode <[hidden email]>
Cc: Paul Richards <[hidden email]>
Betreff: RE: AW: tsneterr: (6) could not resolve host - can anyone else test
this?

LC 8.1.3  - Windows 10 64Bit - Works for me

-----Original Message-----
From: use-livecode [mailto:[hidden email]] On Behalf
Of Charles Warwick via use-livecode
Sent: 16 March 2017 10:11
To: [hidden email]
Cc: Charles Warwick <[hidden email]>
Subject: Re: AW: tsneterr: (6) could not resolve host - can anyone else test
this?

I have not been able to replicate this issue here, but I am using an older
version of Windows.

Is there anyone that can try this on various versions of Windows to see if
this problem is specific to Win 10?

Try typing the following into the message box:

put URL
"http://test_auth:test_pass@.../test_auth/"

If it is successful, you should see "Authentication successful." appear in
the message box.

Thanks,

Charles


On 16/03/2017 6:31 PM, Charles Warwick via use-livecode wrote:

> Hi Tiemo,
>
> I have not heard of this issue before but will see if I can reproduce
> it and get back to you.
>
> A workaround would be to use the tsNetGetSync function directly so
> that you can specify the user/pass separately like this:
>
> --
> local tHeaders, tOutHeaders, tResultCode, tBytes, tSettings put
> "public" into tSettings["username"] put "myPW" into
> tSettings["password"] put
> tsNetGetSync("http://www.myHost/mypath/my.txt", tHeaders, tOutHeaders,
> tResultCode, tBytes, tSettings) into tResult
> --
>
> Hope that helps,
>
> Cheers,
>
> Charles
>
>
> On 16/03/2017 1:00 AM, Tiemo Hollmann TB via use-livecode wrote:
>> Forgot to say: Windows 10
>>
>> -----Ursprüngliche Nachricht-----
>> Von: use-livecode [mailto:[hidden email]] Im
>> Auftrag von Tiemo Hollmann TB via use-livecode
>> Gesendet: Mittwoch, 15. März 2017 16:00
>> An: LiveCode User Liste senden <[hidden email]>
>> Cc: Tiemo Hollmann TB <[hidden email]>
>> Betreff: tsneterr: (6) could not resolve host
>>
>> Hello,
>>
>> using LC 8.1.2 / 8.1.3 I get an "tsneterr: (6) could not resolve host:
>> public" when trying to access a file in a web server directory with
>> user and password protection
>>
>> put URL "http://public:myPW@.../mypath/my.txt" into tResult
>>
>> when opening the same file in a not pw protected directory,
>> everything is fine and I get the content of the file
>>
>> Testing the same with 8.1 or 9.0 dp 4 it works also with the pw
>> protected dir, like it should.
>>
>> Is this a known issue with tsnet? Any workarounds?
>>
>> Thanks
>>
>> Tiemo
>>
>>
>>
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription
>> preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Loading...