type the label of me

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

type the label of me

Rick Harrison via use-livecode
Hi
I’ve got a vocabulary trainer for French.

To make it easier for the students to produce letters with accents such as „é“ (ascii-code 142), „à“ and „ç“ I’ve a number of buttons the label of which is the accented letter. As long as I use LC < 7.0 the script „type the label of me“ works fine  - producing the accented letter just at the position of the blinking cursor in a textfield -, but doesn’t when I use LC >= 7. With normal letters such as „l“ or „ C’ „ the script works fine using any LC version.

The script „put "C’ „ after text of field“ also works fine using any version, but here the letter isn’t in every case in its right place.

Any ideas I should change so that I can make my standalones using LC 8.x.x.?

Martin



_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: type the label of me

Rick Harrison via use-livecode
Hi Martin

It appears to me that you have found a bug, probably something to do with the switch to Unicode in the LC engine.

I ran a similar script in LC 8.1.4 rc1 - on a Mac, as it happens.

In my button the label is “Adélie”. The output resulting from the ‘type’ command is
Adlie

and the count of characters in  the field is 5, not 6 as it should be.

If I capture the characters being ‘typed’ using ‘rawKeyDown’, I get

65
100
16777449
108
105
101

So the accented letter creates what appears to be a Unicode character, except that I can’t find a Unicode character of that value after some rather limited Googling. The other characters correspond to the relevant ASCII characters.

Can someone else confirm this, and it so, I’ll be happy to report it as a bug.

Graham



> On 15 Apr 2017, at 15:11, martin meili via use-livecode <[hidden email]> wrote:
>
> Hi
> I’ve got a vocabulary trainer for French.
>
> To make it easier for the students to produce letters with accents such as „é“ (ascii-code 142), „à“ and „ç“ I’ve a number of buttons the label of which is the accented letter. As long as I use LC < 7.0 the script „type the label of me“ works fine  - producing the accented letter just at the position of the blinking cursor in a textfield -, but doesn’t when I use LC >= 7. With normal letters such as „l“ or „ C’ „ the script works fine using any LC version.
>
> The script „put "C’ „ after text of field“ also works fine using any version, but here the letter isn’t in every case in its right place.
>
> Any ideas I should change so that I can make my standalones using LC 8.x.x.?
>
> Martin
>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: type the label of me

Rick Harrison via use-livecode
I've just had a go with this too, and got exactly the same result
("Adlie") which would seem
to suggest that type has not been "Unicodized" yet.

I have found an effective workaround that goes like this:

(script of a button with the label "Adélie")

on mouseUp
   put 1 into KK
   repeat until KK > 6
      put char KK of the label of me after fld "f1"
      wait 30 ticks
      add 1 to KK
   end repeat
end mouseUp

Richmond.


On 4/15/17 6:33 pm, Graham Samuel via use-livecode wrote:

> Hi Martin
>
> It appears to me that you have found a bug, probably something to do with the switch to Unicode in the LC engine.
>
> I ran a similar script in LC 8.1.4 rc1 - on a Mac, as it happens.
>
> In my button the label is “Adélie”. The output resulting from the ‘type’ command is
> Adlie
>
> and the count of characters in  the field is 5, not 6 as it should be.
>
> If I capture the characters being ‘typed’ using ‘rawKeyDown’, I get
>
> 65
> 100
> 16777449
> 108
> 105
> 101
>
> So the accented letter creates what appears to be a Unicode character, except that I can’t find a Unicode character of that value after some rather limited Googling. The other characters correspond to the relevant ASCII characters.
>
> Can someone else confirm this, and it so, I’ll be happy to report it as a bug.
>
> Graham
>
>
>
>> On 15 Apr 2017, at 15:11, martin meili via use-livecode <[hidden email]> wrote:
>>
>> Hi
>> I’ve got a vocabulary trainer for French.
>>
>> To make it easier for the students to produce letters with accents such as „é“ (ascii-code 142), „à“ and „ç“ I’ve a number of buttons the label of which is the accented letter. As long as I use LC < 7.0 the script „type the label of me“ works fine  - producing the accented letter just at the position of the blinking cursor in a textfield -, but doesn’t when I use LC >= 7. With normal letters such as „l“ or „ C’ „ the script works fine using any LC version.
>>
>> The script „put "C’ „ after text of field“ also works fine using any version, but here the letter isn’t in every case in its right place.
>>
>> Any ideas I should change so that I can make my standalones using LC 8.x.x.?
>>
>> Martin
>>
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: type the label of me

Rick Harrison via use-livecode
In reply to this post by Rick Harrison via use-livecode
As a workaround, try:

 put "C’" into the selection

--
Jacqueline Landman Gay         |     [hidden email]
HyperActive Software           |     http://www.hyperactivesw.com



On April 15, 2017 8:13:22 AM martin meili via use-livecode
<[hidden email]> wrote:

> Hi
> I’ve got a vocabulary trainer for French.
>
> To make it easier for the students to produce letters with accents such as
> „é“ (ascii-code 142), „à“ and „ç“ I’ve a number of buttons the label of
> which is the accented letter. As long as I use LC < 7.0 the script „type
> the label of me“ works fine  - producing the accented letter just at the
> position of the blinking cursor in a textfield -, but doesn’t when I use LC
> >= 7. With normal letters such as „l“ or „ C’ „ the script works fine using
> any LC version.
>
> The script „put "C’ „ after text of field“ also works fine using any
> version, but here the letter isn’t in every case in its right place.
>
> Any ideas I should change so that I can make my standalones using LC 8.x.x.?
>
> Martin
>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: type the label of me

Rick Harrison via use-livecode
In reply to this post by Rick Harrison via use-livecode
Can you put the character into the selected chunk, or the selection, or something like that?

Sent from my iPhone

> On Apr 15, 2017, at 9:11 AM, martin meili via use-livecode <[hidden email]> wrote:
>
> Hi
> I’ve got a vocabulary trainer for French.
>
> To make it easier for the students to produce letters with accents such as „é“ (ascii-code 142), „à“ and „ç“ I’ve a number of buttons the label of which is the accented letter. As long as I use LC < 7.0 the script „type the label of me“ works fine  - producing the accented letter just at the position of the blinking cursor in a textfield -, but doesn’t when I use LC >= 7. With normal letters such as „l“ or „ C’ „ the script works fine using any LC version.
>
> The script „put "C’ „ after text of field“ also works fine using any version, but here the letter isn’t in every case in its right place.
>
> Any ideas I should change so that I can make my standalones using LC 8.x.x.?
>
> Martin
>
>
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: type the label of me

Rick Harrison via use-livecode
In reply to this post by Rick Harrison via use-livecode
I confirm that this is a bug. It has been reported before as bug 9294 with the status FIXED, so I have written another report to reopen it. This has the number 19593 - the mothership will presumably acknowledge it as a duplicate of 9294 in due course.


Graham

Happy Easter to all (yes, including those who don’t celebrate Easter or do but not on this day… probably a disguised cheese remark, but let it go.)

> On 15 Apr 2017, at 17:33, Graham Samuel via use-livecode <[hidden email]> wrote:
>
> Hi Martin
>
> It appears to me that you have found a bug, probably something to do with the switch to Unicode in the LC engine.
>
> I ran a similar script in LC 8.1.4 rc1 - on a Mac, as it happens.
>
> In my button the label is “Adélie”. The output resulting from the ‘type’ command is
> Adlie
>
> and the count of characters in  the field is 5, not 6 as it should be.
>
> If I capture the characters being ‘typed’ using ‘rawKeyDown’, I get
>
> 65
> 100
> 16777449
> 108
> 105
> 101
>
> So the accented letter creates what appears to be a Unicode character, except that I can’t find a Unicode character of that value after some rather limited Googling. The other characters correspond to the relevant ASCII characters.
>
> Can someone else confirm this, and it so, I’ll be happy to report it as a bug.
>
> Graham
>
>
>
>> On 15 Apr 2017, at 15:11, martin meili via use-livecode <[hidden email]> wrote:
>>
>> Hi
>> I’ve got a vocabulary trainer for French.
>>
>> To make it easier for the students to produce letters with accents such as „é“ (ascii-code 142), „à“ and „ç“ I’ve a number of buttons the label of which is the accented letter. As long as I use LC < 7.0 the script „type the label of me“ works fine  - producing the accented letter just at the position of the blinking cursor in a textfield -, but doesn’t when I use LC >= 7. With normal letters such as „l“ or „ C’ „ the script works fine using any LC version.
>>
>> The script „put "C’ „ after text of field“ also works fine using any version, but here the letter isn’t in every case in its right place.
>>
>> Any ideas I should change so that I can make my standalones using LC 8.x.x.?
>>
>> Martin
>>
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> [hidden email]
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
> _______________________________________________
> use-livecode mailing list
> [hidden email]
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode
Reply | Threaded
Open this post in threaded view
|

Re: type the label of me

Rick Harrison via use-livecode
In reply to this post by Rick Harrison via use-livecode
Put "ç" into the selection does the trick.
Many thanks Jacqueline!
Martin

Von meinem iPad gesendet

_______________________________________________
use-livecode mailing list
[hidden email]
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode